WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 |   ...   | 3 | 4 ||

в)

 
где 

г)


д)


е)


ж)

если точка лежит внутри круга радиусом r (r>0) с центром в точке (a,b) 

в противном случае


[ Ответ ]

7.12. Постройте графики функций y(x), заданных командами если:

а)

если x<=-1

то y:=1/x**2

иначе

если x<=2

то y:=x*x

иначе y:=4

все

все

в)

если x<-0.5

то y:=1/abs(x)

иначе

если x<1

то y:=2

иначе y:=1/(x-0.5)

все

все

     Решение

г)

если x<0

то y:=1

иначе

если x<3.14

то y:=cos(x)

иначе y:=-1

все

все

б)

если x<-5

то y:=-5

иначе

если x<0

то y:=x

иначе

если x<3

то y:=2*x

иначе y:=6

все

все

все

д)

если abs(x)>2

то y:=x*x

иначе

если x<0

то y:=-2*x

иначе

если x>=1

то y:=4

иначе y:=4*x*x

все

все

все


[ Ответ ]

7.13. Определите значение целочисленной переменной S после выполнения операторов:

а)

S:=128

нц для i от 1 до 4

S:=div(S,2)

кц

Решение

i

S

 

128

1

128/2=64

2

64/2=32

3

32/2=16

4

16/2=8

Ответ: S=8

г)

S:=0

нц для i от 1 до 2

нц для j от 2 до 3

S:=S+i+j

кц

кц

Решение

i

j

S

 

 

0

1

2

0+1+2=3

 

3

3+1+3=7

2

2

7+2+2=11

 

3

11+2+3=16

Ответ: S=16

б)

S:=1; a:=1

нц для i от 1 до 3

S:=S+i*(i+1)*a

a:=a+2

кц

д)

нц для i от 1 до 3

S:=0

нц для j от 2 до 3

S:=S+i+j

кц


кц

в)

S:=1; a:=1

нц для i от 1 до 3

S:=S+i

нц для j oт 2 до 3

S:=S+j

кц

кц

е)

нц для i от 1 до 2

S:=0

нц для j oт 2 до 3

нц для k oт 1 до 2

S:=S+i+j+k

кц

кц

кц


[ Ответ ]

7.14. Определите значение переменной S после выполнения операторов:

а)

i:=0; S:=0

нц пока i<3

i:=i+1;

S:=S+i*i

кц

г)

S:=0; N:=125

нц пока N>0

S:=S+mod(N,10) | S — сумма цифр

N:=div(N,10) | числа N

кц

Решение

Условие i < 3

i

S

 

0

0

0 < 3 да

1

0+12=1

1 < 3 да

2

1+22=5

2 < 3 да

3

5+32=14

3 < 3 нет(кц)

 

 

Ответ: S=14

Решение

Условие N > 0

S

N

 

0

125

125 > 0 да

0+5=5

12

12 > 0 да

5+2=7

1

1 > 0 да

7+1=8

0

0 > 0 нет (кц)

 

 

Ответ: S=8

б)

S:=0; i:=1

нц пока i>1

S:=S+1/i

i:=i-1


кц

д)

а:=1; b:=1; S:=0;

нц пока a<=5

a:=a+b; b:=b+a;

S:=S+a+b

кц

в)

S:=0; i:=1; j:=5

нц пока i<j

S:=S+i*j

i:=i+1

j:=j-1

кц

е)

a:=1; b:=1

нц пока a+b<10

a:=a+1

b:=b+a

кц


S:=a+b


[ Ответ ]

7.15. Составте алгоритмы решения задач линейной структуры (условия этих задач заимствены из учебного пособия В.М. Заварыкина, В.Г. Житомирского и М.П. Лапчика "Основы информатики и вычислительной техники", 1989):

а) в треугольнике известны три стороны a, b и c; найти (в градусах) углы этого треугольника, используя формулы:

С=180o-(А+В).

Пояснение. Обратите внимание на то, что стандартные тригонометрические функции arccos и arcsin возвращают вычисленное значение в радианной мере.
Решение:

алг Углы треугольника(арг вещ a,b,c, рез вещ UgolA,UgolB,UgolC)

нач вещ RadGr,UgolARad

| RadGr — коэф. перевода угла из радианной меры в градусную

| UgolARad — угол A (в радианах)

RadGr:=180/3.14

UgolARad:=ArcCos((b*b+c*c-a*a)/(2*b*c))

UgolA:=UgolARad*RadGr

UgolB:=ArcSin(b*sin(UgolARad)/a)*RadGr

UgolC:=180-(UgolA+UgolB)

кон

б) в треугольнике известны две стороны a, b и угол C (в радианах) между ними; найти сторону c, углы A и B (в радианнах) и площадь треугольника, используя формулы:

 
  с2 = a2 + b2 - 2ab cos C.

Пояснение. Сначала нужно найти сторону c, а затем остальные требуемые значения;

в) в треугольнике известны три стороны a, b и c; найти радиус описанной окружности и угол A (в градусах), используя формулы:

   где  

г) в правильной треугольной пирамиде известны сторона основания a и угол A (в градусах) наклона боковой грани к плоскости основания; найти объем и площадь полной поверхности пирамиды, используя формулы:

V=Socн· H/2;

где

д) в усеченном конусе известны радиус оснований R и r и угол A (в радианах) наклона образующей к поверхности большого основания; найти объем и площадь боковой поверхности конуса, используя формулы:


где

e) в правильной четырехугольной пирамиде сторона основания равна a, а боковое ребро наклонено к плоскости основания под углом A; найти объем и площадь полной поверхности пирамиды и площадь сечения, проходящего через вершину пирамиды и диагональ основания d; использовать формулы:


[ Ответ ]

7.16. Составте алгоритм решения задач развлетвляющейся структуры:

а) определить, является ли треугольник с заданными сторонами a, b, c равнобедренным;
Решение:

алг Треугольник(арг вещ a,b,c, рез лог Otvet)

дано | a>0, b>0, c>0, a+b>c, a+c>b, b+c>a

надо | Otvet = да, если треугольник равнобедренный

| Otvet = нет, если треугольник не равноведренный

нач

если (a=b) или (a=c) или (b=c)

то Otvet:= да

иначе Otvet:= нет

все

кон

б) определить количество положительных чисел среди заданных чисел a, b и c;

в) меньшее из двух заданных неравных чисел увеличить вдвое, а большее оставить без изменения;

г) числа a и b — катеты одного прямоугольного треугольника, а c и d — другого; определить, являются ли эти треугольники подобными;

д) данны три точки на плоскости; определить, какая из них ближе к началу координат;

е) определить, принадлежит ли заданная точка (x,y) плоской фигуре, являющейся кольцом с центром в начале координат, с внутренним радиусом r1 и внешним радиусом r2;

ж) упорядочить по возрастанию последовательность трех чисел a, b и c.
[ Ответ ]

Pages:     | 1 |   ...   | 3 | 4 ||



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.