WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 || 3 | 4 |   ...   | 5 |
  1. алг Замена (арг лит Str1, Str2, арг рез лит Text)
  2. дано | длины подстрок Str1 и Str2 совпадают
  3. надо | всюду в строке Text подстрока Str1 заменена на Str2
  4. алг Число максимумов (арг цел N, арг вещ таб A[1:N], рез цел K)
  5. дано | N>0
  6. надо | К - число максимальных элементов в таблице А
  7. алг Сопротивление (арг вещ R1, R2, арг цел N, рез вещ R)
  8. дано | N>5, R1>0, R2>0
  9. надо | R - сопротивление схемы

Здесь в предложениях дано и надо после знака "|" записаны комментарии. Комментарии можно помещать в конце любой строки. Они не обрабатываются транслятором, но существенно облегчают понимание алгоритма.

Команды школьного АЯ

Оператор присваивания. Служит для вычисления выражений и присваивания их значений переменным. Общий вид: А := В, где знак ":=" означает команду заменить прежнее значение переменной, стоящей в левой части, на вычисленное значение выражения, стоящего в правой части.

Например, a:=(b+c)*sin(Pi/4); i:=i+1.

Для ввода и вывода данных используют команды

  • ввод имена переменных
  • вывод имена переменных, выражения, тексты.

Для ветвления применяют команды если и выбор, для организации циклов — команды для и пока, описанные в разделе 7.9.

Пример записи алгоритма на школьном АЯ

алг Сумма квадратов (арг цел n, рез цел S)

дано | n > 0

надо | S = 1*1 + 2*2 + 3*3 +... + n*n

нач цел i

  ввод n; S:=0

  нц для i от 1 до n

    S:=S+i*i

  кц

  вывод "S = ", S

кон

7.9. Что такое базовые алгоритмические структуры

Алгоритмы можно представлять как некоторые структуры, состоящие из отдельных базовых (т.е. основных) элементов. Естественно, что при таком подходе к алгоритмам изучение основных принципов их конструирования должно начинаться с изучения этих базовых элементов. Для их описания будем использовать язык схем алгоритмов и школьный алгоритмический язык.

Логическая структура любого алгоритма может быть представлена комбинацией трех базовых структур:

следование, ветвление, цикл.

Характерной особенностью базовых структур является наличие в них одного входа и одного выхода.

1. Базовая структура следование. Образуется из последовательности действий, следующих одно за другим:

Школьный алгоритмический язык

Язык блок-схем

действие 1
действие 2
.........
действие n

2. Базовая структура ветвление. Обеспечивает в зависимости от результата проверки условия (да или нет) выбор одного из альтернативных путей работы алгоритма. Каждый из путей ведет к общему выходу, так что работа алгоритма будет продолжаться независимо от того, какой путь будет выбран.

Структура ветвление существует в четырех основных вариантах:

  • если-то;
  • если-то-иначе;
  • выбор;
  • выбор-иначе.

Школьный алгоритмический язык

Язык блок-схем

1. если-то

если условие

  то действия

все

2. если-то-иначе

если условие

  то действия 1

  иначе действия 2

все

3. выбор

выбор

  при условие 1: действия 1

  при условие 2: действия 2

 ............

  при условие N: действия N

все

4. выбор-иначе

выбор

  при условие 1: действия 1

  при условие 2: действия 2

 ............

  при условие N: действия N

  иначе действия N+1

все

Примеры команды если

Школьный алгоритмический язык

Язык блок-схем

если x > 0

  то y := sin(x)

все

если a > b

  то a := 2*a; b := 1

  иначе b := 2*b

все

выбор

  при n = 1: y := sin(x)

  при n = 2: y := cos(x)

  при n = 3: y := 0

все

выбор

  при a > 5: i := i+1

  при a = 0: j := j+1

  иначе i := 10; j:=0

все


 

3. Базовая структура цикл. Обеспечивает многократное выполнение некоторой совокупности действий, которая называется телом цикла. Основные разновидности циклов представлены в таблице:
 

Школьный алгоритмический язык

Язык блок-схем

Цикл типа пока.

Предписывает выполнять тело цикла до тех пор, пока выполняется условие, записанное после слова пока.

нц пока условие

  тело цикла (последовательность действий)

кц

Цикл типа для.

Предписывает выполнять тело цикла для всех значений некоторой переменной (параметра цикла) в заданном диапазоне.

нц для i от i1 до i2

  тело цикла (последовательность действий)

кц

Примеры команд пока и для

Школьный алгоритмический язык

Язык блок-схем

нц пока i <= 5

  S := S+A[i]

  i := i+1

кц

нц для i от 1 до 5

  X[i] := i*i*i

  Y[i] := X[i]/2

кц


 

7.10. Какие циклы называют итерационными

Особенностью итерационного цикла является то,что число повторений операторов тела цикла заранее неизвестно. Для его организации используется цикл типа пока. Выход из итерационного цикла осуществляется в случае выполнения заданного условия.

На каждом шаге вычислений происходит последовательное приближение и проверка условия достижения искомого результата.

Пример. Составить алгоритм вычисления суммы ряда
 


с заданной точностью (для данного знакочередующегося степенного ряда требуемая точность будет достигнута, когда очередное слагаемое станет по абсолютной величине меньше).

Вычисление сумм — типичная циклическая задача. Особенностью же нашей конкретной задачи является то, что число слагаемых (а, следовательно, и число повторений тела цикла) заранее неизвестно. Поэтому выполнение цикла должно завершиться в момент достижения требуемой точности.

При составлении алгоритма нужно учесть, что знаки слагаемых чередуются и степень числа х в числителях слагаемых возрастает.

Решая эту задачу "в лоб" путем вычисления на каждом i-ом шаге частичной суммы
 

S:=S+(-1)**(i-1)*x**i/i,


мы получим очень неэффективный алгоритм, требующий выполнения большого числа операций. Гораздо лучше организовать вычисления следующим образом: если обозначить числитель какого-либо слагаемого буквой р, то у следующего слагаемого числитель будет равен -р*х (знак минус обеспечивает чередование знаков слагаемых), а само слагаемое m будет равно p/i, где i - номер слагаемого.

Сравните эти два подхода по числу операций.
 

Алгоритм на школьном АЯ

Блок-схема алгоритма


алг Сумма (арг вещ x, Eps, рез вещ S)

  дано | 0 < x < 1

  надо | S = x - x**2/2 + x**3/3 -...

нач цел i, вещ m, p

  ввод x, Eps

  S:=0; i:=1 | начальные значения

  m:=1; p:=-1

  нц пока abs(m) > Eps

  p:=-p*x | p - числитель

          | очередного слагаемого

  m:=p/i  | m - очередное слагаемое

  S:=S+m  | S - частичная сумма

  i:=i+1  | i - номер

          | очередного слагаемого

  кц

  вывод S

кон

Алгоритм, в состав которого входит итерационный цикл, называется итеpационным алгоpитмом. Итерационные алгоритмы используются при реализации итерационных численных методов.

В итерационных алгоритмах необходимо обеспечить обязательное достижение условия выхода из цикла (сходимость итерационного процесса). В противном случае произойдет зацикливание алгоритма, т.е. не будет выполняться основное свойство алгоритма — результативность.

7.11. Что такое вложенные циклы

Возможны случаи, когда внутри тела цикла необходимо повторять некоторую последовательность операторов, т. е. организовать внутренний цикл. Такая структура получила название цикла в цикле или вложенных циклов. Глубина вложения циклов (то есть количество вложенных друг в друга циклов) может быть различной.

При использовании такой структуры для экономии машинного времени необходимо выносить из внутреннего цикла во внешний все операторы, которые не зависят от параметра внутреннего цикла.

Пример вложенных циклов для

Вычислить сумму элементов заданной матрицы А(5,3).
 

Матрица А
 

нц для i от 1 до 5

  нц для j от 1 до 3

    S:=S+A[i,j]

  кц

кц

Пример вложенных циклов пока

Вычислить произведение тех элементов заданной матрицы A(10,10), которые расположены на пересечении четных строк и четных столбцов.
 

i:=2; P:=1

нц пока i <= 10

  j:=2

  нц пока j <= 10

    P:=P*A[i,j]

    j:=j+2

  кц

  i:=i+2

кц

7.12. Чем отличается программный способ записи алгоритмов от других

При записи алгоритма в словесной форме, в виде блок-схемы или на псевдокоде допускается определенный произвол при изображении команд. Вместе с тем такая запись точна настолько, что позволяет человеку понять суть дела и исполнить алгоритм.

Однако на практике в качестве исполнителей алгоритмов используются специальные автоматы — компьютеры. Поэтому алгоритм, предназначенный для исполнения на компьютере, должен быть записан на "понятном" ему языке. И здесь на первый план выдвигается необходимость точной записи команд, не оставляющей места для произвольного толкования их исполнителем.

Следовательно, язык для записи алгоритмов должен быть формализован. Такой язык принято называть языком программирования, а запись алгоритма на этом языке — программой для компьютера.

7.13.Что такое уровень языка программирования

В настоящее время в мире существует несколько сотен реально используемых языков программирования. Для каждого есть своя область применения.

Любой алгоритм, как мы знаем, есть последовательность предписаний, выполнив которые можно за конечное число шагов перейти от исходных данных к результату. В зависимости от степени детализации предписаний обычно определяется уровень языка программирования — чем меньше детализация, тем выше уровень языка.

По этому критерию можно выделить следующие уровни языков программирования:

  • машинные;
  • машинно-оpиентиpованные (ассемблеpы);
  • машинно-независимые (языки высокого уровня).

Машинные языки и машинно-ориентированные языки — это языки низкого уровня, требующие указания мелких деталей процесса обработки данных.

Языки же высокого уровня имитируют естественные языки, используя некоторые слова разговорного языка и общепринятые математические символы. Эти языки более удобны для человека.

Языки высокого уровня делятся на:

Pages:     | 1 || 3 | 4 |   ...   | 5 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.