WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 || 3 | 4 |   ...   | 8 |

• В соответствии с условием задачи (1.1) выбрать в поле знака необходимый знак, например =.

• В поле "Ограничение" введите адрес ячейки правой части рассматриваемого ограничения, например $H$10.

• Аналогично введите ограничения: $F$11>=$H$11, $F$12<=$H$12.

• Подтвердите ввод всех перечисленных выше условий нажатием кнопки OK.

Окно "Поиск решения" после ввода всех необходимых данных задачи (1.1) представлено на рис. 1.6.

Если при вводе условия задачи возникает необходимость в изменении или удалении внесенных ограничений или граничных условий, то это делают, нажав кнопки "Изменить" или "Удалить" (см. рис. 1.6).

1.3.1.2. Решение задачи Установка параметров решения задачи Задача запускается на решение в окне "Поиск решения". Но предварительно для установления конкретных параметров решения задач оптимизации определенного класса необходимо нажать кнопку "Параметры" и заполнить некоторые поля окна "Параметры поиска решения" (рис. 1.8).

Рис. 1.8. Параметры поиска решения, подходящие для большинства задач ЛП Параметр "Максимальное время" служит для назначения времени (в секундах), выделяемого на решение задачи. В поле можно ввести время, не превышающее 32 767 секунд (более 9 часов).

Параметр "Предельное число итераций" служит для управления временем решения задачи путем ограничения числа промежуточных вычислений. В поле можно ввести количество итераций, не превышающее 32 767.

Параметр "Относительная погрешность" служит для задания точности, с которой определяется соответствие ячейки целевому значению или приближение к указанным границам. Поле должно содержать число из интервала от 0 до 1. Чем меньше количество десятичных знаков во введенном числе, тем ниже точность. Высокая точность увеличит время, которое требуется для того, чтобы сошелся процесс оптимизации.

Параметр "Допустимое отклонение" служит для задания допуска на отклонение от оптимального решения в целочисленных задачах. При указании большего допуска поиск решения заканчивается быстрее.

Параметр "Сходимость" применяется только при решении нелинейных задач.

Установка флажка "Линейная модель" обеспечивает ускорение поиска решения линейной задачи за счет применение симплекс-метода.

Подтвердите установленные параметры нажатием кнопки "OK".

Запуск задачи на решение Запуск задачи на решение производится из окна "Поиск решения" путем нажатия кнопки "Выполнить".

После запуска на решение задачи ЛП на экране появляется окно "Результаты поиска решения" с одним из сообщений, представленных на рис. 1.9, 1.10 и 1.11.

Рис. 1.9. Сообщение об успешном решении задачи Рис. 1.10. Сообщение при несовместной системе ограничений задачи Рис. 1.11. Сообщение при неограниченности ЦФ в требуемом направлении Иногда сообщения, представленные на рис. 1.10 и 1.11, свидетельствуют не о характере оптимального решения задачи, а о том, что при вводе условий задачи в Excel были допущены ошибки, не позволяющие Excel найти оптимальное решение, которое в действительности существует (см. ниже подразд. 1.3.5).

Если при заполнении полей окна "Поиск решения" были допущены ошибки, не позволяющие Excel применить симплекс-метод для решения задачи или довести ее решение до конца, то после запуска задачи на решение на экран будет выдано соответствующее сообщение с указанием причины, по которой решение не найдено. Иногда слишком малое значение параметра "Относительная погрешность" не позволяет найти оптимальное решение.

Для исправления этой ситуации увеличивайте погрешность поразрядно, например от 0,000001 до 0,00001 и т.д.

В окне "Результаты поиска решения" представлены названия трех типов отчетов: "Результаты", "Устойчивость", "Пределы". Они необходимы при анализе полученного решения на чувствительность (см. ниже подразд. 3.3). Для получения же ответа (значений переменных, ЦФ и левых частей ограничений) прямо в экранной форме просто нажмите кнопку "OK".

После этого в экранной форме появляется оптимальное решение задачи (рис. 1.12).

Рис. 1.12. Экранная форма задачи (1.1) после получения решения 1.3.2. Целочисленное программирование Допустим, что к условию задачи (1.1) добавилось требование целочисленности значений всех переменных. В этом случае описанный выше процесс ввода условия задачи необходимо дополнить следующими шагами.

• В экранной форме укажите, на какие переменные накладывается требование целочисленности (этот шаг делается для наглядности восприятия условия задачи) (рис. 1.13).

• В окне "Поиск решения" (меню "Сервис""Поиск решения"), нажмите кнопку "Добавить" и в появившемся окне "Добавление ограничений" введите ограничения следующим образом (рис. 1.14):

- в поле "Ссылка на ячейку" введите адреса ячеек переменных задачи, то есть $B$3:$E$3;

- в поле ввода знака ограничения установите "целое";

- подтвердите ввод ограничения нажатием кнопки "OK".

Рис. 1.13. Решение задачи (1.1) при условии целочисленности ее переменных Рис. 1.14. Ввод условия целочисленности переменных задачи (1.1) На рис. 1.13 представлено решение задачи (1.1), к ограничениям которой добавлено условие целочисленности значений ее переменных.

1.3.3. Двухиндексные задачи ЛП Двухиндексные задачи ЛП вводятся и решаются в Excel аналогично одноиндексным задачам. Специфика ввода условия двухиндексной задачи ЛП состоит лишь в удобстве матричного задания переменных задачи и коэффициентов ЦФ.

Рассмотрим решение двухиндексной задачи, суть которой заключается в оптимальной организации транспортных перевозок штучного товара со складов в магазины (табл. 1.2).

Таблица 1.Исходные данные транспортной задачи Тарифы, руб./шт. 1-й магазин 2-й магазин 3-й магазин Запасы, шт.

1-й склад 2-й склад 1 3-й склад 54 100 4-й склад Потребности, шт. Целевая функция и ограничения данной задачи имеют вид L (X )= 2x11 + 9x12 + 7x13 + x + 5x + 5x31 + 21 + 4x32 +100x33 + 2x + 3x + 6x43 min;

41 x11 + x12 + x13 = 25, x + x22 + x23 = 50, x31 + x32 + x33 = 35, (1.5) x + x42 + x43 = 75, x + x21 + x31 = 45, x12 + x22 + x32 = 90, x + x23 + x33 = 50, xij 0,xij - целые (i =1,4; j =1,3).

Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи (1.5) и ее решение представлены на рис. 1.15, 1.16, 1.17 и в табл. 1.3.

Рис. 1.15. Экранная форма двухиндексной задачи (1.5) (курсор в целевой ячейке F15) Таблица 1.Формулы экранной формы задачи (1.5) Объект математической модели Выражение в Excel Переменные задачи C3:EФормула в целевой ячейке F15 =СУММПРОИЗВ(C3:E6;C12:E15) =СУММ(C3:E3) Ограничения по строкам =СУММ(C4:E4) в ячейках F3, F4, F5, F6 =СУММ(C5:E5) =СУММ(C6:E6) =СУММ(C3:C6) Ограничения по столбцам =СУММ(D3:D6) в ячейках С7, D7, E=СУММ(E3:E6) Суммарные запасы и потребности =СУММ(H3:H6) в ячейках H8, G9 =СУММ(C9:E9) Рис. 1.16. Ограничения и граничные условия задачи (1.5) Рис. 1.17. Экранная форма после получения решения задачи (1.5) (курсор в целевой ячейке F15) 1.3.4. Задачи с булевыми переменными Частным случаем задач с целочисленными переменными являются задачи, в результате решения которых искомые переменные x могут j принимать только одно из двух значений: 0 или 1. Такие переменные в честь предложившего их английского математика Джорджа Буля называют булевыми. На рис. 1.18 представлена экранная форма с решением некоторой двухиндексной задачи с булевыми переменными.

Рис. 1.18. Решение двухиндексной задачи с булевыми переменными Помимо задания требования целочисленности (см. подразд. 1.3.2) при вводе условия задач с булевыми переменными необходимо:

• для наглядности восприятия ввести в экранную форму слово "булевы" в качестве характеристики переменных (см. рис.1.18);

• в окне "Поиск решения" добавить граничные условия, имеющие смысл ограничения значений переменных по их единичной верхней границе (рис. 1.19).

Рис. 1.19. Добавление условия единичной верхней границы значений переменных двухиндексной задачи с булевыми переменными Вид окна "Поиск решения" для задачи с булевыми переменными, представленной на рис. 1.18, приведен на рис. 1.20.

Рис. 1.20. Окно "Поиск решения" для задачи с булевыми переменными, представленной на рис. 1.1.3.5. Возможные ошибки при вводе условий задач ЛП Если при решении задачи ЛП выдается сообщение о невозможности нахождения решения, то возможно, что причина заключается в ошибках ввода условия задачи в Excel. Поэтому, прежде чем делать вывод о принципиальной невозможности нахождения оптимального решения задачи, ответьте на вопросы из табл. 1.4.

1.4. ПРИМЕРНЫЕ ВОПРОСЫ НА ЗАЩИТЕ РАБОТЫ 1. Каковы основные этапы решения задач ЛП в MS Excel 2. Каков вид и способы задания формул для целевой ячейки и ячеек левых частей ограничений 3. В чем смысл использования символа $ в формулах MS Excel 4. В чем различие использования в формулах MS Excel символов ";" и ":" 5. Почему при вводе формул в ячейки ЦФ и левых частей ограничений в них отображаются нулевые значения 6. Каким образом в MS Excel задается направление оптимизации ЦФ 7. Какие ячейки экранной формы выполняют иллюстративную функцию, а какие необходимы для решения задачи 8. Как наглядно отобразить в экранной форме ячейки, используемые в конкретной формуле, с целью проверки ее правильности 9. Поясните общий порядок работы с окном "Поиск решения".

10. Каким образом можно изменять, добавлять, удалять ограничения в окне "Поиск решения" 11. Какие сообщения выдаются в MS Excel в случаях: успешного решения задачи ЛП; несовместности системы ограничений задачи; неограниченности ЦФ Таблица 1.Список вопросов, позволяющих выявить ошибки ввода условия задачи в Excel Вопрос № Месторасположение в Excel Правильно ли Вы ввели численные значения и знаки (+, —) коэффициентов целевой функции и 1 Экранная форма ограничений, правых частей ограничений 2 Сбалансирована ли двухиндексная задача Экранная форма Правильны ли формулы в целевой ячейке и в ячейках левых частей ограничений Для наглядности 3 проверки поставьте курсор на ячейку с формулой и сделайте двойной щелчок левой клавишей мыши. Экранная форма Рамкой в экранной форме будут выделены ячейки, участвующие в данной формуле (см. рис.1.4, 1.5).

4 Правильно ли указан адрес целевой ячейки Окно "Поиск решения" 5 Правильно ли указано направление оптимизации ЦФ Окно "Поиск решения" Окно "Поиск решения" 6 Правильно ли указаны адреса ячеек переменных Поле "Изменяя ячейки" Экранная форма, Окно "Поиск решения" 7 Правильно ли введены знаки ограничений (<=, >=, =) Поле "Ограничения" Окно "Поиск решения" 8 Правильно ли указаны адреса ячеек левых и правых частей ограничений Поле "Ограничения" Окно "Поиск решения" 9 Не забыли ли Вы задать требование неотрицательности переменных Поле "Ограничения" Окно "Поиск решения" Не забыли ли Вы задать требования по единичному значению верхней границы переменных (для задач с булевыми переменными) Поле "Ограничения" Окно "Поиск решения" 11 Не забыли ли Вы задать условие целочисленности переменных (согласно условию задачи) Поле "Ограничения" 12 Проверьте правильность установки параметров (см. подразд.1.3.1.2) Окно "Параметры поиска решения" 12. Объясните смысл параметров, задаваемых в окне "Параметры поиска решения".

13. Каковы особенности решения в MS Excel целочисленных задач ЛП 14. Каковы особенности решения в MS Excel двухиндексных задач ЛП 15. Каковы особенности решения в MS Excel задач ЛП с булевыми переменными 1.5. ВАРИАНТЫ Используя MS Excel, найти решение для модели ЛП, соответствующей заданному варианту (табл. 1.5).

Таблица 1.Варианты задач к лабораторной работе № № варианта Математическая модель L(X) = 5x1 + 7x2 - 6x3 + 9x4 + 8x5 max;

0,7x 1+ 0,9x2 +1,5x3 + 2,3x4 +1,8x5 50000, 0,4x +1,1x2 - 0,5x3 +1,3x4 - 2,8x5 32000, 0,5x + 1,8x3 + 0,7x4 + 2x5 40000, 2,2x -1,4x2 - 0,8x3 + 0,9x4 = 15000, x j 0 (j = 1,5).

L(X) = x1 + 4x3 + 8x -12x5 min;

x 1+ 9x 2 + 2x3 - 4x 4 = 250, 0,4x1 + x 2 - 5x3 + 3x 4 + 8x5 460, 0,5x + 10x2 - 8x3 + 6x + 2x5 190, 1 11x - 8,5x3 + 3x + 2x5 = 210, 2 x j 0 (j =1,5).

L(X) = -45x1 + 65x2 + 2x - 3x5 max;

15x 1+ 18x2 + 34x4 - 22x5 = 56, 2x + 7x3 - 4x4 + 3x5 91, 0,2x + 0,8x2 + 1,5x3 + 0,9x4 + 4x5 26, 1,8x - 42x2 + 6,4x3 + 3x5 = 15, x j 0 (j = 1,5).

№ варианта Математическая модель L(X) = 14x1 - 9x2 - x4 + 6,4x5 min;

0,9x 1 +10x2 - 28x4 + 5x5 245, 0,8x +1,7x2 - 0,2x3 - 0,5x4 = 9, 6x + 4x3 - 7x4 + 6,3x5 54, 8x + 6,2x2 - 4,8x4 + 2,9x5 17, x j 0 (j = 1,5).

L(X) = 46x1 + 2,3x2 + 9,4x3 - 4x5 max;

3x 1 + 7,8x3 +12x4 + 9x5 49, 2,3x + 5x3 + 5,6x4 - x5 86, 16x - 40x4 + 29x5 = 50, 190x - 98x2 - 4x4 +150x5 300, x j 0 (j = 1,5).

L(X) = 0,5x 1 +1,8x3 - 9,2x4 +14x5 min;

9,6x 2 +15,7x3 + 24x4 - 8x5 74, 0,8x +11,1x 2 - 4,5x 3 +1,5x4 - 6,3x5 = 22, 14x + 45x 2 - 38x4 + 26x5 46, 220x -148x 2 - 7x 3 + 95x5 150, x j 0 (j = 1,5).

L(X) = 12x2 + 89x3 - 5x5 max;

2x 1 + 9,6x2 +15,7x3 + 22x4 - 8x5 73, 0,9x +11,1x2 - 4,3x3 +1,5x4 + 6,4x5 = 19, 14x + 45x2 - 38x4 + 26x5 49, 220x -150x2 + 3x3 + 95x5 = 133, x j 0 (j = 1,5).

L(X) = 4x + 6x2 -14x3 + 49x5 min;

21x 1+ 9x2 - 2x4 -12x5 58, 110x - 60x3 + 80x4 - 45x5 = 290, 5x + 27x3 -14x4 + x5 72, 87x - 6,4x2 +130x4 = 140, x j 0 (j = 1,5).

№ варианта Математическая модель L(X) = -38x 1 + 60x2 + x3 + 4x4 + 8x5 max;

18x 1+ 4x2 + 2x3 -12x5 86, 2x +19x3 - 7x4 +10x5 = 130, 0,4x + 3x2 - 4,2x3 + 2x4 - 5x5 34, 2,1x +13x2 - 20x3 + 6x4 = 18, x j 0 (j = 1,5).

L(X) = 10x 1 + 40x3 +13x4 + 56x5 min;

7x 1+16x3 + 5x4 + 25x5 600, 8x +1,7x2 - 0,5x4 + 4,7x5 = 890, 6x + 4x3 - 7x4 + 6,3x5 270, 84x + 62x2 + 80x3 +14x5 2300, x j 0 (j = 1,5).

L(X) = 84x1 + 5,7x2 +10x4 - 3x5 max;

4x 1+ 8,5x2 +16x3 +10x5 50, 10,4x + 6x3 + 2x4 + 4x5 120, 19x + 18x2 - 20x4 + 30x5 = 600, 200x + 45x2 - 8x3 + 3,4x4 210, x j 0 (j = 1,5).

L(X) = 0,84x2 - 4x3 + 3,8x4 +12x5 min;

15x 1+ 9,6x2 + 34x4 - 8x5 180, 0,6x +11,1x2 - 2,6x3 +1,5x4 - 6,3x5 = 68, 14x + 64x3 - 38x4 +12x5 81, 190x -148x2 - 7x3 + 84x5 230, x j 0 (j =1,5).

2. ЛАБОРАТОРНАЯ РАБОТА № 2 (ЧАСТЬ I) “ОДНОИНДЕКСНЫЕ ЗАДАЧИ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ” 2.1. ЦЕЛЬ РАБОТЫ Приобретение навыков построения математических моделей одноиндексных задач ЛП и решения их в Microsoft Excel.

2.2. ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ 1. Согласно номеру своего варианта выберите условие задачи и постройте ее модель.

2. Найдите оптимальное решение задачи в Excel и продемонстрируйте его преподавателю.

Pages:     | 1 || 3 | 4 |   ...   | 8 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.