WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 | 2 || 4 | 5 |   ...   | 8 |

Применение формул 1. В ячейку G1 введите заголовок Новый оклад (формула).

2. Выделите диапазон G2:G11, введите формулу =ОКРУГЛ(старый оклад* значение индекса увеличения оклада;0) Нажмите Ctrl+Enter.

Использование коэффициентов Размер оклада каждого сотрудника с помощью определенного коэффициента «привязывается» к окладу ведущего специалиста (например, директора или начальника отдела). Допустим, оклад начальника отдела Реализации составляет 1400 руб. Новая зарплата других сотрудников определяется умножением оклада начальника на заранее установленный коэффициент.

1. В ячейку Н1 введите заголовок Новый оклад (коэффициенты), в ячейку I1 – Оклад (расчетный), в ячейку – Коэффициент.

2. В ячейку I2 занесите старый оклад начальника отдела Реализации – 1400,00 руб., в ячейку I3 – индекс увеличения оклада, в ячейку I4 формулу расчета нового оклада начальника =ОКРУГЛ(I2*(1+I3);0).

3. Заполните диапазон J2:J11 коэффициентами, используемыми при перерасчете окладов, а в диапазон Н2:Н11 формулами расчета нового оклада сотрудников, например для ячейки Н2 =ОКРУГЛ($I$4*J2;0).

Расчет окладов всеми рассмотренными способами с числовыми данными приведен на рисунке:

Рисунок Проверка данных Обратите внимание на лист Сотрудники: в строке 10 указан сотрудник, который уже уволился, но ему начисляется заработная плата. Автоматизируем процессы поиска и исправления ошибок.

1. Вставьте новый лист, который назовите Проверка данных. На новом листе разместите:

• столбцы с листа Количество сотрудников: Отдел, Должность, Фамилия, Табельный номер, Оклад;

• столбцы с листа Сотрудники: Табельный номер, Фамилия, Отдел, Дата приема на работу, Дата увольнения.

2. Внесите ошибки в табельные номера.

Если работник уволен Формула, с помощью которой можно определить, числился ли сотрудник в списке работников на момент расчета премии, основана на функции ЕПУСТО, относящийся к категории Проверки свойств и значений.

ЕПУСТО(значение) – функция проверяет содержимое ячейки и, если ячейка ничего не содержит, возвращает логическое значение ИСТИНА, если в ячейке находится какая-либо информация, функция возвращает значение ЛОЖЬ.

Т.е. с помощью этой функции можно выяснить занесено какое-либо значение в ячейки столбца Дата увольнения. Если ячейка пуста, то сотрудник еще работает.

Сравнение табельных номеров.

Воспользуемся функцией ЕСЛИ: =ЕСЛИ(D2=G2;ИСТИНА;ЛОЖЬ) Сравнение фамилий У нас в одном столбце указана лишь фамилия, а в другом фамилия и инициалы. Поэтому воспользуемся текстовыми функциями:

• сосчитаем количество символов в ячейке С2 (фамилия и инициалы) до первого пробела;

• извлечь из ячейки С2 количество символов, расположенных слева от первого пробела.

Для определения символов, предшествующих первому пробелу, воспользуемся функцией НАЙТИ.

=НАЙТИ(" ";С2) – в ячейке С2 занесена фамилия с инициалами.

Далее применим функцию ЛЕВСИМВ:

ЛЕВСИМВ(C2;НАЙТИ(" ";C2)-1)– получим фамилию без инициалов. Отнимается 1, т.к. функция НАЙТИ определяет положение пробела, следующего после фамилии.

Осталось сравнить фамилии, в итоге получится формула:

=ЕСЛИ(H2=ЛЕВСИМВ(C2;НАЙТИ(" ";C2)-1);ИСТИНА;ЛОЖЬ) Соответствие всем условиям Для проверки выполнения всех трех условий: сотрудник не уволен, совпадения табельных номеров и совпадения фамилий, воспользуемся функцией И, которая возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ, получим формулу: =И(L2;M2;N2) Результаты представлены на рисунке 32:

Рисунок Составление сложной формулы методом вложения Будем заменять ссылки на ячейку содержимым этой ячейки, т.е. если формула включает адрес ячейки, которая, в свою очередь, содержит формулу, необходимо вместо адреса вставить саму формулу, находящуюся по этому адресу.

Для этого выделяется первая формула без знака = и копируется, затем курсор устанавливается на ячейку, ссылающуюся на эту формулу, и вместо адреса ячейки вставляется сама формула с помощью Ctrl+Insert и т.д.

В результате получим итоговую формулу:

=И(ЕПУСТО(К2);ЕСЛИ(D2=J2;ИСТИНА;ЛОЖЬ);

ЕСЛИ(H2=ЛЕВСИМВ(C2;НАЙТИ(" ";C2)-1);ИСТИНА;ЛОЖЬ)) Промежуточные столбцы L, M и N можно удалить, а можно скрыть., для этого выделите скрываемые столбцы и выполните ФорматСтолбцыСкрыть или из контекстного меню Скрыть.

Расчет премии за выслугу лет Премия за выслугу лет зависит от стажа работника, ее величина определяется на основании данных таблицы:

Стаж, годы Премия, % Менее 1 Не начисляется От 1 до 3 (3 не входит) От 3 до 5 (5 не входит) От 5 до 10 (10 не входит) Свыше 10 Алгоритм вычисления премии.

1. Определить общее количество проработанных на предприятии дней (из даты начисления премии необходимо вычесть дату приема на работу).

2. Определить число отработанных сотрудником лет, разделив полученное на предыдущем этапе число дней на 365,25 – среднее число дней в году с учетом високосных лет.

3. Отбросить от полученного значения дробную часть.

4. Произвести начисление премии согласно таблице.

5. Если проверка, выполненная выше, не показала ошибку, зачесть полученную сумму премии, в противном случае выдать сообщение об ошибке.

1. Определение полного количества лет работы на предприятии:

Для отбрасывания дробной части используем математическую функцию ОТБР, которая усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.

В итоге для первого сотрудника имеем формулу: =ОТБР(($O$2J2)/365,25), где $О$2 – ячейка, содержащая дату расчета премии, J2 – дата приема на работу 1 сотрудника.

2. Расчет суммы премии.

Расчет производится с использованием логических функций ЕСЛИ.

Первая формула создается по принципу: если служащий проработал менее года (значение ячейки Q2 сравнивается со значением ячейки N4), то премия равна произведению значения оклада, указанного в ячейке Е2, на коэффициент, внесенный в ячейку О4. В противном случае рассматривается стаж от 1 года до 3 лет и т.д. В итоге для первого сотрудника формула для расчета премии будет иметь вид:

=ЕСЛИ(Q2<1;O4;ЕСЛИ(Q2<$N$5;E2*$O$5;ЕСЛИ(Q2<$N$6;E2*$O$6;

ЕСЛИ(Q2<$N$7;E2*$O$7;E2*$O$8)))) 3. Учет проверки условий (если сотрудник не уволен, табельные номера и фамилии совпадают, то начисляется премия, в противном случае выводится - Ошибка!) =ЕСЛИ(L2;S2;"Ошибка!") В результате должна получиться следующая таблица:

Рисунок 4. Формирование приказа о премии за выслугу лет • создайте типовой бланк приказа в Word, оставив место для вставки таблицы, сформированной в Excel;

«»2006 г.

Приказ №_ Выплатить премию за выслугу лет за 2006 год следующим сотрудникам:

• перейдите в Excel и выделите диапазон ячеек и скопируйте его в буфер обмена;

• перейдите в текстовый редактор, установите курсор в место вставки таблицы и выполните команду ПравкаСпециальная вставка;

• в диалоговом окне Специальная вставка, в списке Как выделите Лист Microsoft Excel(объект) • установите переключатель Связать.

В результате на странице текстового документа появится объект, связанный с электронной таблицей. Изменения, вносимые в электронной таблице, будут отражаться в документе Word.

Тема 5. Работа с датами и числами.

Excel предоставляет в распоряжение пользователя множество числовых форматов и функций. Однако встроенные средства, позволяющие написать дату и число прописью, в программе отсутствуют.

День недели прописью Используем функцию ДЕНЬНЕД, которая возвращает день недели, соответствующий аргументу дата_в_числовом_формате. Microsoft Excel хранит даты как ряд последовательных номеров, что позволяет выполнять над ними вычисления. По умолчанию день 1 января 1900 года имеет номер 1, а 1 января 2008 — номер 39448, так как интервал в днях между этими датами составляет 39448.

Алгоритм 1. Введем в ячейку А1 любую дату.

2. В ячейке А2 определим день недели с помощью =ДЕНЬНЕД(А1;2).

3. В ячейке А3 с помощью функции ЕСЛИ запишем название этого дня недели:

=ЕСЛИ(A2=1;"Понедельник";ЕСЛИ(A2=2;"Вторник";

ЕСЛИ(A2=3;"Среда";ЕСЛИ(A2=4;"Четверг";

ЕСЛИ(A2=5;"Пятница";ЕСЛИ(A2=6;"Суббота";"Воскресенье")))))) 4. С помощью операции копирования заменим ссылку на ячейку А2 формулой, которую она содержит (=ДЕНЬНЕД(А1;2)), в результате получим:

=ЕСЛИ(ДЕНЬНЕД(A1;2)=1;"Понедельник";

ЕСЛИ(ДЕНЬНЕД(A1;2)=2;"Вторник";ЕСЛИ(ДЕНЬНЕД(A1;2)=3;"Среда";

ЕСЛИ(ДЕНЬНЕД(A1;2)=4;"Четверг";ЕСЛИ(ДЕНЬНЕД(A1;2)=5;"Пятница";

ЕСЛИ(ДЕНЬНЕД(A1;2);"Суббота";"Воскресенье")))))) Рисунок Дата прописью Дата прописью имеет широкое применение, например, при составлении платежных поручений и накладных. Задача состоит в том, чтобы заставить Excel написать дату словами, например, дату 4.10.2004 представить в виде текста от 4 октября 2004 года.

Решить эту задачу можно следующим методом: сначала разбить дату на составляющие: день, месяц и год (причем для месяца сформировать не его порядковый номер в году, а название), а затем все компоненты соединить в текстовой строке.

Алгоритм.

1. В ячейку А1 введите произвольную дату.

2. В ячейке А2 определите номер дня месяца с помощью функции =ДЕНЬ(A1).

3. В ячейке А3 определите номер месяца: =МЕСЯЦ(A1).

4. В ячейке А4 определите год: =ГОД(A1).

5. Ячейки А5:А6 - обеспечивают написание названия месяца (до 7 функций ЕСЛИ могут быть вложены друг в друга в качестве значений аргументов, поэтому для формирования названия месяца придется использовать две ячейки):

Ячейка А5:

=ЕСЛИ(A3=7;"июля";ЕСЛИ(A3=8;"августа";ЕСЛИ(A3=9;"сентября";ЕСЛИ(A3= 10;"октября";ЕСЛИ(A3=11;"ноября";"декабря"))))) Ячейка А6:

=ЕСЛИ(A3=1;"января";ЕСЛИ(A3=2;"февраля";ЕСЛИ(A3=3;"марта";

ЕСЛИ(A3=4;"апреля";ЕСЛИ(A3=5;"мая";A5))))) 6. Ячейка А7 – добавляет нуль перед номером дня месяца, если этот номер меньше или равен 9: =ЕСЛИ(A2<=9;0;"") 7. Ячейка А8 – содержит дату прописью:

=СЦЕПИТЬ("от ";A7;ДЕНЬ(A1);" ";A6;" ";ГОД(A1);" года") Рисунок В ячейке А8 можно создать сложную формулу:

=СЦЕПИТЬ("от ";ЕСЛИ(A2<=9;0;"");ДЕНЬ(A1);" ";ЕСЛИ(A3=1;"января";ЕСЛИ(A3=2;"февраля";ЕСЛИ(A3=3;"марта";

ЕСЛИ(A3=4;"апреля";ЕСЛИ(A3=5;"мая";A5)))));" ";ГОД(A1);" года") после чего можно удалить ячейки А6:А7.

Написание суммы прописью При заполнении различных документов наряду с суммой в числовом виде требуется указывать ее величину прописью. Создадим электронную таблицу, которая автоматизирует данную работу. В примере рассмотрим только сумму, записываемую трехзначным числом, для больших чисел таблица создается аналогично.

Алгоритм работы таблицы Ячейка АВход Диапазон ячеек А2:DРазделение числа на разряды Диапазон ячеек А5:CНаписание прописью цифр каждого разряда Ячейки А14, DПрисвоение разрядам наименований (тысячи, миллионы) Ячейка CПрисвоение наименований и склонение Единицы измерения (рубли, евро и т.д.) Диапазон ячеек А15:АСоединение и текстовая обработка всех элементов В результате выполнения алгоритма таблица с числовыми значениями для сотен будет иметь вид:

Рисунок 1. Введите в ячейку А1 введите произвольное трехзначное число.

2. Разделение числа на разряды.

Для определения, сколько целых миллионов, тысяч, сотен, десятков имеется в числе, необходимо разделить число на значение соответствующей разрядности и отбросить дробную часть. Например, для определения количества целых сотен число надо разделить на 100 и отбросить дробную часть результата:

=ОТБР(А1/100;0) Если число больше или равно 100, то мы получим количество сотен в этом числе. В противном случае результатом будет 0.

3. Определение значения каждого разряда.

Для этого выделяется младший разряд в числах, которые находятся в третьей строке. Это делается путем вычитания из них значений, которые находятся в ячейках левее, умноженные на 10.

В ячейке В4 для единиц введена формула: =B3-A3*Формула для копеек несколько отличается: в случае, когда число копеек не превышает 9, перед цифрой будет добавляться ноль, а значит сумма, в которой указаны только целые рубли, должна выглядеть как «22 рубля 00 копеек». В ячейку D4 введите формулу: =ЕСЛИ(D3<=9;0;" ") 4. Формирование числительных для каждого разряда.

Рассмотрим столбец Единицы - ячейка С5. Если в ячейках С4 и Внаходятся числа 1, то функция возвратит текст – одиннадцать. Если же значение 1 находится только в ячейке А4, а ячейка В4 содержит другое число, то возвращается текст 0 – один. Если в ячейке В4 находится число отличное от 1, то управление передается ячейке С6 и т.д. В ячейке С5 содержится формула: =ЕСЛИ(C4=1;ЕСЛИ(B4=1;"одиннадцать";"один");C6).

Рассмотрим столбец Десятки. Вначале проводится проверка ячейки В4 на наличие там значения 0. Если это значение присутствует, т.е. число десятков равно 0, то формула выдает пустое значение. Если же в ячейке Внаходится другое значение, то начинает работать первая функция ЕСЛИ, она проверяет, находится ли в ячейке В4 число 1, если это так, то необходимо посмотреть, какое значение находится в столбце Единицы – ячейка С4, если там находится 0, то формула выдает - десять, если же любое другое значение, то « ». Если в ячейке С4 – число отличное от 1, то управление передается в ячейку - В6. В ячейке В5 содержится формула:

=ЕСЛИ(B4=0;" ";ЕСЛИ(B4=1;ЕСЛИ(C4=0;"десять";" ");B6)) 5. Формирование названия разрядов.

Выполняется для тысяч и миллионов.

6. Формирование названия единицы измерения в соответствующем падеже.

Склоняется единица измерения – рубль. Формула в ячейке С14 имеет следующий вид:

=ЕСЛИ(B4+C4=0;"нуль рублей";ЕСЛИ(ПРАВСИМВ(C5;1)="н";"рубль";

ЕСЛИ(ПРАВСИМВ(C5;1)="а";"рубля";ЕСЛИ(ПРАВСИМВ(C5;1)="е";"рубля";

ЕСЛИ(ПРАВСИМВ(C5;1)="и";"рубля";"рублей"))))) 7. Соединение всех компонентов надписи.

Применяются текстовые функции, которые обрабатывают и соединяют результаты предыдущих вычислений. В ячейку А15 введена формула: =СЦЕПИТЬ(A5;" ";B5;" ";C5;" ";C14;" ";D4;D3;" коп.") 8. Удаление лишних пробелов.

=СЖПРОБЕЛЫ(А15) – функция оставляет в тексте только одиночные пробелы, ее также можно применять для обработки текстов, полученных из других прикладных программ, если эти тексты содержат избыточные пробелы.

9. Запись итоговой суммы с большой буквы.

- выделяется первый (самый левый символ): =ЛЕВСИМВ(А16;1) - назначается для этого символа прописная буква: =ПРОПИСН(А17) - извлекаются все символы, кроме первого =ПРАВСИМВ(А18;ДЛСТР(А18)-1) - соединяются первая прописная буква и оставшийся текст:

=СЦЕПИТЬ(А18;А19) В итоге таблица c формулами будет иметь вид:

Рисунок Тестирование таблицы При вложении одной формулы в другую легко допустить ошибку.

Pages:     | 1 | 2 || 4 | 5 |   ...   | 8 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.