WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 || 3 | 4 |   ...   | 8 |

Частоты можно также вычислить с помощью команды СервисАнализ данных. Средство анализа данных является одной из надстроек Excel. Если в меню Сервис отсутствует команда Анализ данных, то для ее установки необходимо выполнить команду СервисНадстройкиПакет анализа.

После выбора пункта Гистограмма откроется окно В поле Входной интервал введите диапазон Е3:Е8, по которому строим диаграмму. В поле Интервал карманов введите диапазон I3:I5 со значениями верхних границ интервалов. В поле выходной интервал укажите $К$3. На рисунке 23 приведен результат построения гистограммы:

Рисунок Расчет итоговой выручки по объему реализации Рисунок В ячейки А3:С3 введены стоимости трех различных товаров, а в ячейки В6:D8 – объемы их реализации по месяцам. Суммарную стоимость реализованных товаров по месяцам можно рассчитать двумя способами:

1 способ. Выделите диапазон ячеек Е6:Е8 и введите формулу:

{=МУМНОЖ(В6:D6);ТРАНСП($А$3:$С$3)} 2 способ. В ячейку F6 введите формулу =СУММПРОИЗВ(B6:D6;$А$3:$С$3) и протяните на ячейки F7:F7.

Ведомость по расчету просроченных платежей Рассмотрим пример составления отчетной ведомости фирмы, продающей компьютеры, позволяющей определить количество и сумму просроченных клиентами платежей:

Рисунок 1. В ячейку Е2 введите формулу, определяющую срок просрочки платежа =ЕСЛИ(D2=0;$H$2-C2;" "), которую протащите на диапазон Е3:Е20.

2. В ячейки F8, F9 и F10 соответственно введены формулы {=СУММ((Е2:Е20>0)*(Е2:Е20<=29)*(B2:B20))} {=СУММ((Е2:Е20>=30)*(Е2:Е20<=39)*(B2:B20))} {=СУММ((Е2:Е20>=40)*(B2:B20))}, вычисляющие суммарные стоимости просроченных оплат сроком до дней, от 30 до 39 дней и свыше 40 дней. Поясним третью формулу: Excel в формуле массива возвращает условие (Е2:Е20>=40) в виде массива, состоящего из 0 и 1, где 0 стоит на месте ячейки со значением меньше и 1 – на месте ячейки со значением не меньше 40. Следовательно, данная формула вычисляет сумму произведений элементов массива (Е2:Е20>=40) (с единицами в случае просрочки на указанный срок и нулями – в противном случае) и массивы В2:В20 (с ценами процессоров). Таким образом, третья формула возвращает суммарную стоимость заказов, просроченных не менее чем на 40 дней.

3. В ячейки F2, F3 и F4 соответственно введены формулы {=СУММ((Е2:Е20>0)*(Е2:Е20<=29))} {=СУММ((Е2:Е20>=30)*(Е2:Е20<40))} =СЧЕТЕСЛИ(Е2:Е20; “>=40”), вычисляющие количество просроченных оплат сроком до 29 дней, от 30 до 39 дней и свыше 40 дней.

Ведомости по расчету затрат на производство Предположим, что фирма производит CD-диски. Упаковка диска обходится фирме в 1 руб./шт., стоимость материалов – 4 руб./шт. Готовые диски фирма продает по цене 10 руб./шт. Технические возможности фирмы позволяют выпускать до 5000 дисков в день. Оплата труда рабочих сдельная и зависит от количества выпущенных дисков. За первую тысячу дисков оплата труда рабочих составляет 0,3 руб./шт., за вторую тысячу дисков – 0,4 руб./шт., за третью тысячу дисков – 0,5 руб./шт., за четвертую тысячу дисков – 0,6 руб./шт. и свыше 4000 дисков – 0,7 руб./шт.

Фирме поступил заказ на изготовление 4500 СD-дисков. Необходимо подсчитать суммарные издержки и прибыль от выполнения данного заказа.

Для упрощения чтения формул присвоим с помощью команды ВставкаИмяПрисвоить диапазонам D2:D7, E2:E7, F2:F7 и ячейке В1, соответственно имена: ДискиШт, ОплатаРубШт, ОплатаРуб, ЗаказШт.

Зарплата рабочих, в зависимости от объема выпущенных дисков, находится в диапазоне F2:F7 и вычисляется по формуле:

{=ЕСЛИ(ЗаказШт-1000>ДискиШт;1000*ОплатаРубШт;

ЕСЛИ(ЗаказШт>ДискиШт;(ЗаказШт-ДискиШт)*ОплатаРубШт;0))} Фигурные скобки в начале и конце формулы являются признаком массива и вводятся нажатием Ctrl+Shift+Enter либо после завершения ввода формулы, либо в процессе ее редактирования.

На рисунках 26 и 27 приведен расчет затрат на производство с числовыми данными и формулами:

Рисунок Рисунок Тема 3. Создание табличной базы данных сотрудников.

База данных как способ хранения и обработки различной информации играют в настоящее время огромную роль. В базах данных хранятся сведения о клиентах, заказах, справочники адресов и телефонов и т.д.

Для учета данных о сотрудниках на предприятиях используют разнообразные методы, рассмотрим учет с помощью Excel.

Формирование списка.

Аналогом простой базы в Excel служит список. Список – группа строк таблицы, содержащая связанные данные, причем каждый столбец списка содержит однотипные данные.

Предположим, что перечень столбцов списка, который будет применяться при создании базы данных, набран в текстовом редакторе Word.

1. Откройте документ в MS Word и наберите в один столбец:

1. Порядковый номер; 10. Пол;

2. Табельный номер; 11. Улица;

3. Фамилия; 12. Дом;

4. Имя; 13. Квартира;

5. Отчество; 14. Домашний телефон;

6. Отдел; 15. Дата рождения;

7. Должность; 16. Идентификационный код;

8. Дата приема на работу; 17. Количество детей;

9. Дата увольнения; 18. Льготы по ПН;

19. Совместитель-многодетный; 21. Справочный столбец.

20. Непрерывный стаж с;

2. Перенесите список в Excel, начиная с ячейки А2.

3. Обработайте перенесенные текстовые данные.

Обратите внимание, что все заголовки оформлены следующим образом:

порядковый номер; точка; пробел; текст заголовка; точка с запятой. Необходимо очистить текст от лишних символов, для этого:

в ячейку В2 введите формулу =ДЛСТР(А2) для определения длины текста заголовка, протяните формулу на диапазон В3:В22;

в ячейку С2 введите формулу =ЛЕВСИМВ(А2;В2-1) для удаления последнего символа из заголовка;

в ячейку D2 введите формулу =ПРАВСИМВ(С2;В2-4) для удаления начальных символов из заголовка;

В результате таблица с формулами примет вид:

Рисунок создайте в столбце D сложную формулу для обработки текста, для этого:

- активизируйте ячейку В4 и в режиме правки в строке формул скопируйте находящуюся в этой ячейке формулу без знака равенства;

- нажмите Enter и поместите табличный курсор в ячейку С4;

- в строке формул выделите ссылку на адрес ячейки В4 и вместо этой ссылки вставьте содержимое буфера обмена и т.д. В результате получится формула:

=ПРАВСИМВ(ЛЕВСИМВ(A2;ДЛСТР(A2)-1);ДЛСТР(A2)-4), проверьте правильность созданной формулы, удалив столбцы В и С;

4. Перенесите заголовки из столбца в строку:

выделите и скопируйте в буфер обмена полученный после обработки текст;

поместите табличный курсор в ячейку А1, которая будет служить началом строки заголовка списка;

из контекстного меню выберите Специальная вставка;

отметьте опции значения и транспонировать, Ок.

5. Введите данные в базу данных.

Просмотр табличной базы данных Для удобства работы со списком необходимо видеть строку заголовков и три левых столбца, содержащих номер по порядку, табельный номер и фамилию работника. Существует несколько методов, позволяющих установить необходимый режим просмотра данных:

• открытие нескольких окон • разделение таблицы на области • закрепление областей таблицы Работа с окнами Возможно для одного и того же рабочего листа открыть два окна: ОкноНовое. В списке появится два имени База1, База2.

Команда ОкноРасположить, позволяет изменить расположение окон.

Переключение между окнами:

• щелчок указателем мыши на этом окне • Ctrl+Tab • ОкноИмя нужного окна При внесении изменений в одно окно они появляются и в другом.

Дополнительное окно можно закрыть, свернуть, развернуть или скрыть.

Разделение таблицы на области 1. Поместить курсор в ту ячейку, где должна появиться граница раздела.

2. ОкноРазделить.

Каждое из окон имеет независимые области прокрутки.

Закрепление областей 1. Поместить курсор в ту ячейку, слева от которой столбцы останутся закрепленными.

2. ОкноЗакрепить области.

Для отмены закрепления областей ОкноСнять закрепление областей.

Отбор данных Может выполняться с помощью Автофильтра и Расширенного фильтра.

Автофильтр.

1. Укажите любую ячейку таблицы.

2. ДанныеФильтрАвтофильтр.

3. В столбце, в котором нужно произвести отбор, из списка выберите нужный критерий отбора. Например, если курсор был поставлен в столбец Фамилия:

Рисунок При выборе одного из значений фильтруемого диапазона, в списке останутся только записи с указанным значением в данном поле.

Отбор по наименьшему или наибольшему значению 1. В столбце, содержащем числа, нажмите кнопку со стрелкой и выберите вариант (Первые 10...).

2. В поле слева введите количество записей для показа.

3. В среднем поле выберите вариант наибольших или наименьших.

4. В поле справа выберите вариант элементов списка или процент от количества элементов.

Например:

1. Задается отбор 7 записей, в которых ячейки текущего столбца содержат самые большие значения в заданном списке.

2. Отбирается 7% записей, в которых ячейки текущего столбца содержат наименьшие значения в списке.

Пользовательский автофильтр Появляется при выборе категории Условие. Оператор ИЛИ позволяет отображать строки, удовлетворяющие одному из двух критериев отбора, а оператор И – строки, удовлетворяющие обоим критериям одновременно.

Например, задан отбор записей с должностями Начальник или Менеджер.

Расширенный фильтр Вызывается командой ДанныеФильтрРасширенный фильтр.

Позволяет задавать условия отбора одновременно для нескольких полей 1. Вставить перед списком несколько пустых строк.

2. Сформировать диапазон условий:

в первую строку скопировать заголовки фильтруемых столбцов;

во вторую ввести условия отбора.

Например:

a. Отбор женщин, работающих в отделе Контроля:

b. Отбор мужчин с перечисленными именами:

c. Отбор мужчин, имеющих имя Иван или отчество Петрович:

3. Установить курсор внутри списка данных и выполнить команды ДанныеФильтрРасширенный фильтр.

4. Указать исходный диапазон.

5. Указать диапазон условий отбора, включая заголовки.

6. Указать, где выводить фильтрованный список (левую верхнюю ячейку диапазона).

Диапазон условий, оформленный в виде таблицы или опросной формы, может находиться не только на текущем листе, а в любом доступном для вашего компьютера месте. Это позволяет отобрать товары на складе, документы в архиве, книги в библиотеке и подготовить документы на их получение. Спланируем возможный вариант:

1. Создайте на отдельном листе диапазон условий в виде таблицы из одной колонки Табельный номер, укажите несколько значений.

2. Откройте одновременно два окна База и диапазон условий на экране, расположите их рядом.

3. Зафиксируйте курсор на листе База.

4. ДанныеФильтрРасширенный фильтр. Укажите необходимые диапазоны.

При задании критерия отбора в Excel могут использоваться:

текстовые константы:

- строки с ячейками, значение которых начинается текстом;

- строки с ячейками, содержание которых точно соответствует заданному образцу; строчные и прописные буквы при фильтрации не различаются;

знаки подстановки:

- – любой символ в той же позиции, что и знак вопроса;

- * - любая последовательность символов в той же позиции, что и звездочка;

- ~, ~*, ~~ - вывод спецсимволов, *, ~, например Где~ Ищет «Где».

Диалоговое окно Форма Позволяет вводить и просматривать данные. Выводится командой ДанныеФорма. Выбор кнопки Критерии позволяет выводить данные по нужному параметру.

Тема 4. Должностные оклады и премии.

Информация, которая находится в созданной базе данных, предназначена для широкого круга пользователей.

Определение количества сотрудников в каждом отделе и занимающих определенные должности Рисунок 1. В файле База данных.xls добавьте новый лист, назовите его Количество сотрудников.

2. Скопируйте на него с листа Сотрудники столбцы Отдел, Должность, Фамилия, Табельный номер. В столбце Фамилия подпишите инициалы.

Поменяйте несколько строк местами.

3. Добавьте столбец Оклад и заполните его, причем размер оклада должен выражаться целым числом рублей, т.е. не содержать копеек.

4. На этом же листе разметьте таблицы определения количества сотрудников в каждом отделе и занимающих определенные должности, как указано на рисунке.

5. В ячейки Н2:Н4 поместите формулы для определения количества сотрудников в отделах, например для ячейки Н2 формула будет иметь вид =СЧЕТЕСЛИ($А$2:$А$11;А5) или =СЧЕТЕСЛИ($А$2:$А$11;”Контроля”) 6. В ячейки Н8:Н13 поместите формулы для определения количества сотрудников, занимающих определенные должности, например для ячейки Н8 формула будет иметь вид =СЧЕТЕСЛИ($В$2:$В$11;В8) или =СЧЕТЕСЛИ($В$2:$В$11;”Аудитор”) 7. В ячейках Н5 и Н14 просуммируйте количество сотрудников по отделам и по должностям.

8. Выполните проверку рассчитываемых значений:

Результаты сложных и наиболее важных расчетов всегда нужно проверять на правильность. Важным средством контроля могут служить дополнительные ячейки, в которых производятся те же расчеты, но другим методом, или расчеты, позволяющие проверить основной результат.

Для нашей задачи возможен следующий метод контроля: если в списке работников нет ошибки, то значения в столбце оклады должны быть больше нуля, для этого в ячейку Н16 занесем формулу =СЧЕТЕСЛИ($Е$2:$Е$11;”>0”) Если расчеты производились правильно, то численность сотрудников по должностям и отделам должна совпадать.

Изменение должностных окладов.

Предположим, финансовые возможности предприятия позволяют увеличить штатные оклады сотрудников на 7,7%. Рассчитаем новые ставки, воспользовавшись несколькими методами. При этом необходимо учитывать, что размер оклада должен выражаться целым числом, то есть не содержать копеек.

Скопируйте лист Количество сотрудников и переименуйте его в Оклады.

Использование диалогового окна Специальная вставка 1. Скопируйте лист Количество сотрудников и переименуйте его в Оклады.

2. В ячейку F1 введите заголовок Новый оклад (Специальная вставка), в диапазон F2:F11 скопируйте значения старых окладов.

3. В ячейку С14 введите значение индекса увеличения оклада (1,077).

4. Скопируйте содержимое данной ячейки.

5. Выделите диапазон F2:F11, содержащий оклады.

6. Из контекстного меню выберите Специальная вставка.

7. В области Вставить появившегося окна активизируйте переключатель Значения, в области Операция - переключатель Умножить, Ок.

В результате все числа, указанные в ячейках F2:F11, будут умножены на значение 1,077, введенное в ячейку С14. Но при использовании данного метода значения увеличенных окладов выражены в рублях с копейками.

Pages:     | 1 || 3 | 4 |   ...   | 8 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.