WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 | 2 || 4 | 5 |

«Электронная библиотека “Либрус” ( ) Научно-техническая библиотека электронных книг. Первоначально задуманная как хранилище компьютерной литературы, в настоящий момент библиотека содержит книжные издания по ...»

-- [ Страница 3 ] --

Таблица.Cell(Счетчик,2).Range О.InsertAfter("Синоним");

Таблица.Cell(Счетчик,3).Range О.InsertAfter("Тип");

Таблица.Cell(Счетчик,4).Ranged.InsertAfter("Комментарий");

// Устанавливаем жирный шрифт для шапки таблицы Документ.Range( Таблица.Cell( Счетчик,!). Range.Start, Таблица.Cell(Счетчик,4).Range.End).Font.Bold = Истина;

Для каждого Значение Из Объект[Параметр.Ключ] Цикл Счетчик = Счетчик + 1;

// Заполняем содержимое таблицы Попытка Таблица.Cell(Счетчик,1).Range().InsertAfter(Значение.Имя);

Исключение КонецПопытки;

Попытка Таблица.Cell( Счетчик,2).Range().InsertAfter( Значение.Синоним);

Исключение КонецПопытки;

Попытка СтрокаТипов = " ;

" // Выводим все типы Для каждого Тип Из Значение.Тип.Типы() Цикл СтрокаТипов = СтрокаТипов + " " + Строка(Тип);

КонецЦикла;

Таблица.Cell(Счетчик,3).Ranged.InsertAfter(СтрокаТипов);

Исключение КонецПопытки;

Попытка Таблица.Cell( Счетчик,4).Range ().

InsertAfter( Значение.Комментарий);

Исключение КонецПопытки;

Использование OLE Automation КонецЦикла;

КонецЕсли;

КонецЦикла;

КонецЦикла;

КонецЕсли;

КонецЦикла;

// Показываем документ Word.Visible = Истина;

// Устанавливаем активность документа Word.Activate();

Word = Неопределено;

В данном примере используется коллекция Tables, которая предназначена для доступа ко всем таблицам документа. С помощью метода Add данного свойства можно добавлять новые таблицы в документ. Данный метод имеет три параметра:

1. Первый параметр — область документа, в которую помещается таблица.

2. Второй параметр — количество строк.

3. Третий параметр — количество столбцов.

Для того чтобы заполнить ячейки таблицы значениями, нужно сначала по лучить ссылку на данную таблицу, указав в коллекции Tables номер необ ходимой таблицы, а затем с помощью метода таблицы cell указать, в какую область ячейки необходимо добавить текст.

В примере специально не описывается работа с метаданными, т. к. подразу мевается, что читатель знаком с данным объектом. Для версии 7.7 системы "1С:Предприятие" приведенный код будет отличаться только принципами работы с метаданными. Все, что касается объекта word.Application одина ково работает в обеих версиях системы.

Динамическое создание и выполнение макросов MS Word С ПОМОЩЬЮ Объектов W o r d. A p p l i c a t i o n И E x c e l. A p p l i c a t i o n МОЖНО ДИна мически добавлять макросы в документ MS Word или Excel и выполнять их на OLE-сервере.

Перед добавлением макроса необходимо проверить, существует ли доступ к VB-проекту. Для этого в MS Word 2002 (в других версиях последователь ность действий может быть другой) необходимо выбрать пункт Параметры в меню Сервис;

на закладке Безопасность нажать кнопку Защита от макросов 160 Глава и в появившемся окне установить флажок Доверять доступ к Visual Basic Project.

Приведем пример добавления макроса в документ MS Word и запуска его на OLE-сервере (листинг 4.30).

убавление макроса в документ MS Word и запуск его // Определяем текст макроса на языке VBA ТекстМакроса = "Sub VBAFunction() I Selection.TypeText Text:=""Добрый день, уважаемый читатель!"" I Selection.TypeParagraph I Selection.TypeText Text:=""Добро пожаловать на наш форум"" I Application.Keyboard (1033) I Selection.TypeText Text:="": http://forum.erpg.ru"" I Selection.TypeParagraph I Selection.MoveUp Unit:=wdLine, Count:= iSelection.EndKey Unit:=wdLine, Extend:=wdExtend I Selection.Style = ActiveDocument.Styles(""Заголовок 1"") I Selection.MoveDown Unit:=wdLine, Count:=l I Selection.HomeKey Unit:=wdLine I Selection.EndKey Unit:=wdLine, Extend:=wdExtend I Selection.Style = ActiveDocument.Styles(""Заголовок 2"") IActiveDocument.SaveAs FileName:=""C:/Example.doc"", FileFormat:= I wdForraatDocument, LockComments:=False, Passwords"""", I AddToRecentFiles:= I True, WritePassword:="""", ReadOnlyRecommended:=False, I EmbedTrueTypeFonts:= I False, SaveNativePictureForroat:=False, SaveFormsData:=False, I SaveAsAOCELetter:=False I End Sub";

// Создание объекта Word = Новый СОМОбъект("Word.Application");

// Добавление нового документа Word.Documents.Add();

// Определяем ссылку на VB-проект VBComponents = Word. ActiveDocument.VBProj ect.VBComponents;

// Добавляем новый макрос Count = VBComponents.Count();

Использование OLE Automation VBComponents.Add(1);

VBComponents.Item(Count + 1).CodeModule.InsertLines(1, ТекстМакроса);

// Выполняем макрос с именем VBAFunction Word.Application.Run("VBAFunction");

// Закрываем OLE-сервер Word.Quit();

// Очищаем переменную Word = Неопределено;

Данный пример создает новый макрос с именем VBAFunction и запускает его на OLE-сервере. Процедура VBAFunction создает новый документ в формате MS Word, пишет в него две строки, форматирует их и записывает созданный документ в файл Example.doc, который будет находиться в кор невом каталоге диска С:.

Проверка орфографии текстов в MS Word Как уже было сказано ранее, текстовые процессоры и другие программы предоставляют множество полезных возможностей. Например, самый попу лярный текстовый редактор Microsoft Word позволяет выполнять проверку орфографии. Эту очень важную функцию редактора можно использовать в конфигурациях системы "1С:Предприятие" там, где необходимо проверить орфографию введенного текста.

Для проверки орфографии необходимо создать OLE-объект Word. Application и вызвать его метод checkSpeiiing. Данный метод содержит множество па раметров, но обязательным является только один — строка с текстом, кото рый будет проверяться. Метод возвращает истина, если ошибок обнаружено не будет, и ложь, если текст содержит орфографические ошибки.

Рассмотрим пример работы метода CheckSpeiiing (листинг 4.31).

I Листинг 4.31. Проверка наличия орфографических ошибок в тексте Попытка Ворд = Новый СОМОбъект("Word.Application");

//Создаем объект MS Word Исключение Предупреждение("Microsoft Word не установлен!",,"Ошибка!");

Возврат Ложь;

КонецПопытки;

• // Проверяем строку на ошибки 6 Зак. 162 Глава ТекстБезОшибок = Ворд.CheckSpelling(Текст) ;

Если ТекстБезОшибок Тогда Сообщить("Ошибок не обнаружено!");

Иначе Сообщить("Текст содержит орфографические ошибки!");

КонецЕсли;

Данный пример позволяет определить, содержит текст орфографические ошибки или нет, но не дает знать, в каких именно словах были допущены эти ошибки. Для определения каждого неправильно написанного слова необходимо добавить новый документ в MS Word, перенести в него прове ряемый текст и проверить с помощью метода CheckSpelling каждое слово, после чего закрыть документ (листинг 4.32).

// Проверяем строку на ошибки ТекстБезОшибок = Ворд.CheckSpelling(Текст);

Если ТекстБезОшибок Тогда // Нет ошибок Сообщить("Ошибок не обнаружено!");

Иначе // Обнаружены ошибки, будем проверять по словам // Запомним, был ли Word активен Ворд_Активен = Ворд.Visible;

// Добавляем новый документ ВремДок = Ворд.Documents.Add();

// Получаем пустую область в начале документа МояОбласть = ВремДок.Range(0, 0);

// Добавляем в эту область нашу строку МояОбласть.InsertBefore(Текст);

// Подсчитываем число слов в области ЧислоСлов = МояОбласть.Words.Count;

Для НомерСлова = 1 По ЧислоСлов Цикл // Выбираем очередное слово ПровОбласть = МояОбласть.Words(НомерСлова);

ПровСлово = СокрЛП(ПровОбласть.Text);

Использование OLE Automation // Проверяем наше слово на ошибки СловоБезОшибок = Ворд.CheckSpelling(ПровСлово);

Если НЕ СловоБезОшибок Тогда Сообщить("Ошибка в слове: " + ПровСлово};

КонецЕсли;

КонецЦикла;

ВремДок.Close(wdDoNotSaveChanges,,);

• Если Не Ворд_Активен Тогда Ворд.Quit();

КонецЕсли;

Сообщить("Текст содержит орфографические ошибки! ") ;

КонецЕсли;

Данный пример уже выводит те слова, в которых были обнаружены ошибки.

Но MS Word, помимо проверки слов, позволяет предлагать еще и варианты замены неправильно написанных слов. Рассмотрим пример проверки ор фографии слов и вывода вариантов их замены (листинг 4.33).

Листинг 4.33. Проверка орфог Для НомерСлова = 1 По ЧислоСлов Цикл // Выбираем очередное слово ПровОбласть = МояОбласть.Words(НомерСлова);

ПровСлово = СокрЛП(ПровОбласть.Text);

// Проверяем наше слово на ошибки СловоБезОшибок = Ворд.CheckSpelling(ПровСлово);

Если НЕ СловоБезОшибок Тогда Сообщить("Ошибка в слове: " + ПровСлово);

// Получаем варианты замен, но их может и не быть // Проверяем орфографию, указав, что возвращать нужно множество замен Замены = ПровОбласть.GetSpellingSuggestions(,Истина,,0);

// Получаем число возможных замен ЧислоЗамен = Замены.Count;

Если ЧислоЗамен > 0 Тогда 164 Глава Для НомерЗамены = 1 По ЧислоЗамен Цикл СловоЗамены = СокрЛП(Замены.Item(НомерЗамены).Name);

Сообщить(" Вариант замены: " + СловоЗамены);

КонецЦикла;

КонецЕсли;

КонецЕсли;

КонецЦикла;

С помощью предложенных примеров можно реализовать полноценную про верку орфографии в любых конфигурациях системы "1С:Предприятие" вер сий 7.7 и 8.0. Единственное требование к системе — должно быть установ лено приложение Microsoft Word.

Работа с Microsoft Excel С помощью объекта Excel.Application, предоставляемого OLE-сервером MS Excel, можно программно создавать электронные таблицы, а также ис пользовать все функции MS Excel, предоставляемые пользователям.

Основным, в объектной модели Excel, является объект Application, содер жащий коллекцию workbooks объектов типа workBook. Каждый объект типа workBook содержит коллекцию объектов worksheets типа worksheet, кол лекцию объектов charts типа chart и др. Манипуляция рабочими книгами, их листами, ячейками, диаграммами и др. осуществляется путем обращения к свойствам и методам этих объектов.

Запуск MS Excel, создание и открытие рабочих книг Для создания примеров использования Microsoft Excel можно использовать следующий код создания контроллера:

Excel = Новый СОМОбъект("Excel.Application").

Создать новую рабочую книгу Excel можно, используя метод Add коллекции Workbooks объекта Application:

Excel.WorkBooks.Add().

Для создания рабочей книги на основе шаблона следует указать его имя в качестве первого параметра метода Add:

Excel.WorkBooks.Add("С:\Templates\tm.xlt").

В качестве первого параметра этого метода можно также использовать сле дующие константы:

О -4109 — рабочая книга состоит из листа с диаграммой;

П -4167 — рабочая книга состоит из листа с данными.

Использование OLE Automation / В этом случае рабочая книга будет содержать лист того типа, который задан указанной константой (график, обычный лист с данными и др.).

Для открытия уже существующего документа следует воспользоваться мето дом Open КОЛЛекЦИИ WorkBooks:

Excel.Documents.Open("С:\MyExcelFile.xls").

Отметим, что свойство ActiveWorkBook объекта Excel.Application указыва ет на текущую активную рабочую книгу среди одной или нескольких откры тых. Помимо этого к рабочей книге можно обращаться по ее порядковому номеру. Например, ко второй открытой рабочей книге можно обратиться с помощью записи:

Excel.WorkBooks[2].

Сделать рабочую книгу активной можно с помощью метода Activate:

Excel.WorkBooks[2].Activate().

Следующее, чему следует научиться, — это сохранять рабочие книги в файлах.

Сохранение, печать и закрытие рабочих книг MS Excel Закрытие документа может быть осуществлено с помощью метода close:

E x c e l. W o r k B o o k s [ 2 ]. C l o s e ( ) ИЛИ Excel.ActiveWorkBook.Close().

Метод close имеет несколько необязательных (в случае позднего связыва ния) параметров, влияющих на правила сохранения рабочей книги. Первый из параметров принимает значения истина или ложь и влияет на то, сохра нять ли изменения, внесенные в рабочую книгу. Второй параметр — имя файла, в котором нужно сохранить рабочую книгу (если в нее были внесены изменения). Третий параметр также принимает значения истина или ложь и влияет на то, будет ли пересылаться документ следующему пользователю по электронной почте.

Просто сохранить рабочую книгу, не закрывая ее, можно с помощью метода Save ИЛИ SaveAs:

Excel.ActiveWorkBook.Save();

Excel.ActiveWorkBook.SaveAs("C:\MyWorkBook.xls").

Метод SaveAs имеет более десятка параметров, влияющих на то, как именно сохраняется документ (под каким именем, с паролем или без него, какова кодовая страница для содержащегося в ней текста и др.).

Закрыть среду Excel можно с помощью метода Quit объекта Excel.Application. В случае Excel этот метод параметров не имеет.

Вывод документа Excel на устройство печати можно осуществить с по мощью метода Printout объекта workBook, например:

Excel.ActiveWorkBook.Printout().

Глава Если нужно изменить параметры печати, следует указать значения соответ ствующих параметров метода Printout (в случае Excel их восемь).

Обращение к листам и ячейкам Обращение к листам рабочей книги производится с помощью коллекции worksheets объекта workBook. Каждый член этой коллекции представляет собой объект Worksheet. К члену этой коллекции можно обратиться по его порядковому номеру, например:

Excel.WorkBooks[1].Worksheets[1].Name = "Страница 1".

Приведенная выше запись иллюстрирует, как можно изменить имя листа рабочей книги.

К листу рабочей книги можно обратиться и по имени, например:

Excel.WorkBooks[1].Worksheets["Лист!"].Name = "Страница 1".

Обращение к отдельным ячейкам листа производится с помощью коллекции Cells объекта worksheet. Например, добавить данные в ячейку BI можно следующим образом:

Excel.WorkBooks[I].Worksheets["Лист!"].Cells[1,2].Value="25".

Здесь первая из координат ячейки указывает на номер строки, вторая — на номер столбца.

Добавление формул в ячейки производится аналогичным способом:

Excel.WorkBooks[1].Worksheets["Лист!"].Cells[3,2].Value=" =SUM(B1:B2)".

Очистить ячейку можно с помощью метода ciearcontents.

Форматирование текста в ячейках производится с помощью свойств Font и interior объекта ceil и их свойств. Например, фрагмент кода, приведен ный в листинге 4.34, выводит текст в ячейке красным жирным шрифтом Courier размера 16 на желтом фоне.

1^^ишшшишИИ11^НйИИИШИИШ1ИИШИИИИ i Листинг 4.34. Форматирование текста в ячейках Excel.WorkBooks[l].Worksheets[1].Cells[3,2].Interior.Colorlndex = 6;

Excel.WorkBooks[1].Worksheets[!].Cells[3,2].Font.Colorlndex = 3;

Excel.WorkBooks[1].Worksheets[1].Cells[3,2].Font.Name = "Courier";

Excel.WorkBooks[1].Worksheets[1].Cells[3,2].Font.Size = 16;

Excel.WorkBooks[1].Worksheets[1].Cells[3,2].Font.Bold = Истина;

Свойство Colorlndex может принимать числовые значения от 1 до 56. Ниже приведены значения только основных цветов:

П 1 — белый;

П 2 — черный;

Использование OLE Automation П з — красный;

П 5 — синий;

П б — желтый;

О 7 — лиловый;

П ю — зеленый;

П зз — голубой;

П 39 — сиреневый;

П 46 — оранжевый.

Обратиться к текущей ячейке можно с помощью свойства ActiveCeii объ екта Excel.Application, а узнать местоположение ячейки можно с по мощью свойства Address объекта cell, например:

Сообщить(Excel.ActiveCeii.Address).

Помимо обращения к отдельным ячейкам, можно манипулировать прямо угольными областями ячеек с помощью объекта Range. В листинге 4.35 по казан пример заполнения прямоугольного участка текстом и изменение цве та шрифта в ячейках.

Листинг 4.35. Манипулирование прямоугольной областью ячеек ЯЯЯЯвЯЯЯвЯЯЯЯЯЯЯвЯШЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯвЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯК: тЯЯЯШ Excel.WorkBooks[l].Worksheets[2].Range["A1:C5"].Value = "MAV";

Excel.WorkBooks[1].Worksheets[2].Range["A1:C5"].Font.Colorlndex = 3;

Объект Range также часто используется для копирования прямоугольных областей через буфер обмена. В листинге 4.36 приведен пример, иллюстри рующий копирование такой области.

Excel.WorkBooks[1].Worksheets[2].Range["Al:C5"].Copy();

Excel.WorkBooks[l].Worksheets[2].Range["All:CIS"].Select();

Excel.WorkBooks [1].Worksheets [2]. PasteO;

Обратите внимание на то, что диапазон, куда копируются данные, предва рительно выделяется с помощью метода select.

Отметим, что примерно таким же образом можно копировать данные и из других приложений (например, из Microsoft Word).

Довольно часто при автоматизации Excel используются его возможности, связанные с построением диаграмм. В дальнейшем будет показано, как это сделать.

168 Глава Создание диаграмм Диаграммам Excel соответствует объект chart, который может располагаться как на отдельном листе, так и на листе с данными. Если объект chart рас полагается на листе с данными, ему соответствует член коллекции chartobjects объекта worksheet и создание диаграммы нужно начать с до бавления элемента в эту колекцию:

Chart = Excel.WorkBooks[1].Worksheets[2].ChartObjects.Add(10,50,400,400) Параметрами этого метода являются координаты левого верхнего угла диа граммы и ее размеры в пунктах (1/72 дюйма).

Если же диаграмма располагается на отдельном листе (не предназначенном для хранения данных), то ее создание нужно начать с добавления элемента в коллекцию sheets объекта Application (которая отличается от коллекции Worksheets тем, что содержит листы всех типов, а не только листы с дан ными):

Excel.WorkBooks[1].Sheets.Add(,,1,-4109).

В этом случае первый параметр метода Add указывает порядковый номер листа, перед которым нужно поместить данный лист (или листы, если их несколько). Второй параметр — порядковый номер листа, после которого нужно поместить данный лист (используется обычно либо первый, либо второй параметр). Третий параметр определяет, сколько нужно создать лис тов, а четвертый — какого типа должен быть лист. Значения четвертого па раметра совпадают со значениями первого параметра метода Add коллекции WorkBooks объекта Application, и при использовании имен соответствую щих констант следует определить их в приложении-контроллере.

Простейший способ создать диаграмму, с точки зрения пользователя, — создать ее с помощью соответствующего эксперта на основе прямоугольной области с данными. Точно так же можно создать диаграмму и посредством контроллера автоматизации. Для этой цели у объекта chart, являющегося свойством объекта chartobject (члена коллекции chartobjects), имеется метод chartwizard. Первым параметром этого метода является объект Range, содержащий диапазон ячеек для построения диаграммы, а вторым — числовой параметр, указывающий, какого типа должна быть эта диаграмма (листинг 4.37). Возможные значения параметра, отвечающего за тип диа граммы, можно найти в справочном файле.

....--... -...... I Листинг 4.37. Создание диаграммы с помощью мастера L '_ :„„.^:„^„._^.,„-. _„ _:* „1^„ „. •• // Создание диаграммы Ch.Chart.ChartWizard(Excel.WorkBooks[l].Worksheets[2].Range["A1:C5"], -4100);

// Оформление диаграммы Использование OLE Automation Ch.Chart.HasTitle = 1;

Ch.Chart.HasLegend = Ложь;

Ch.Chart.ChartTitle.Text = "Пример диаграммы Excel";

Ch.Chart.Axes(1).HasTitle = Истина;

Ch.Chart.Axes(1).AxisTitle.Text = "Подпись вдоль оси абсцисс";

Ch.Chart.Axes(2).HasTitle = Истина;

Ch.Chart.Axes(2).AxisTitle.Text = "Подпись вдоль оси ординат";

У объекта chart имеется множество свойств, отвечающих за внешний вид диаграммы. С их помощью можно изменить ее точно так же, как пользова тели делают это вручную. В листинге 4.37 приводится пример создания за головка диаграммы и подписей вдоль ее осей (отметим, что оси есть не у всех типов диаграмм).

Еще один способ создания диаграммы — определить все ее параметры с по мощью свойств объекта chart, включая определение точек (значений) и се рий (рядов), на основе которых она должна быть построена. Данные для серии обычно находятся в объекте Range, содержащем строку или столбец данных, а добавление серии к диаграмме производится путем добавления члена к коллекции seriescoiiection (листинг 4.38).

нг 4.38. Опре, кта Chi Excel.WorkBooks[1].Sheets.Add(,,1,-4109) ;

Excel.WorkBooks[1].Sheets[1].ChartType := -4102;

Rng = App.WorkBooks[l].Worksheets[2].Range["B1:B5"];

Excel.WorkBooks[1].Sheets[l].SeriesCollection.Add(Rng);

В данном примере к диаграмме, созданной на отдельном листе, специально предназначенном для диаграмм, добавляется одна серия на основе диапазо на ячеек другого листа.

Далее будут рассмотрены примеры практического применения Microsoft Excel.

Выгрузка метаданных в MS Excel Рассмотрим пример выгрузки метаданных произвольной конфигурации сис темы "1C:Предприятие 8.0" в лист Microsoft Excel (листинг 4.39).

. Выгрузка метаданных в MS Excel для версии 8. Попытка Excel = Новый СОМОбъект("Excel.Application");

Исключение 170 Глава Сообщить("Не удалось открыть Excel");

Возврат;

КонецПопытки;

// Добавляем новый лист Excel.Application.Workbooks.Add(1);

Лист = Excel.ActiveSheet;

// Задаем имя закладки Лист.Name = "Данные";

НомерСтроки = 0;

//Перебор типов метаданных Для Каждого ТипОбъекта Из ВсеТипы Цикл Состояние(ТипОбъекта.Значение);

Если Метаданные[ТипОбъекта.Ключ].Количество() > 0 Тогда // Добавляем новую строку НомерСтроки = НомерСтроки + 1;

// Устанавливаем текст в ячейку Лист.Cells(НомерСтроки, 1).Value = ТипОбъекта.Значение;

// Перебираем конкретные объекты Для каждого Объект Из Метаданные[ТипОбъекта.Ключ] Цикл // Добавляем новую строку НомерСтроки = НомерСтроки + 1;

// Устанавливаем текст в ячейку Лист.Cells(НомерСтроки, 1).Value = Объект.Синоним;

// Перебираем параметры метаданных Для каждого Параметр Из ВсеПараметры Цикл Попытка Количество = Объект[Параметр.Ключ].Количество();

Исключение Продолжить;

КонецПопытки;

Если Количество > 0 Тогда // Добавляем новую строку НомерСтроки = НомерСтроки + 1;

Использование OLE Automation Лист.Cells(НомерСтроки, 1).Value = Параметр.Значение + " ( + Количество + " " " );

// Добавляем новую таблицу НомерСтроки = НомерСтроки + 1;

Лист.Cells(НомерСтроки, 1).Value = "Имя";

Лист.Cells(НомерСтроки, 2).Value = "Синоним";

Лист.Cells(НомерСтроки, 3).Value = "Тип";

Лист.Cells(НомерСтроки, 4).Value = "Комментарий";

Для каждого Значение Из Объект[Параметр.Ключ] Цикл НомерСтроки = НомерСтроки + 1;

// Заполняем содержимое таблицы Попытка.

Лист.Cells(НомерСтроки, 1).Value = Значение.Имя;

Исключение КонецПопытки;

Попытка Лист.Cells(НомерСтроки, 2).Value = Значение.Синоним;

Исключение КонецПопытки;

Попытка СтрокаТипов = " ;

" // Выводим все типы Для каждого Тип Из Значение.Тип.Типы() Цикл СтрокаТипов = СтрокаТипов + " " + Строка(Тип);

КонецЦикла;

Лист.Cells(НомерСтроки, 3}.Value = СтрокаТипов;

Исключение КонецПопытки;

Попытка Лист.Cells(НомерСтроки, 4).Value = Значение.Комментарий;

Исключение КонецПопытки;

КонецЦикла;

КонецЕсли;

КонецЦикла;

КонецЦикла;

КонецЕсли;

172 Глава КонецЦикла;

// Показываем документ Excel.Visible = Истина;

Excel = Неопределено;

Данный пример работает аналогично примеру, приведенному в листинге 4.21, за исключением того, что данные выгружаются в лист MS Excel. Основной недостаток данного примера в том, что все тексты ячеек не отформатирова ны и представлены одним цветом, что затрудняет чтение таблицы.

В листинге 4.40 показан пример цветового оформления ячеек MS Excel и задание в них определенного шрифта.

| Листинг 4.40. Оформление ячеек в MS Excel // Получаем ссылку на определенную ячейку Ячейка = Лист.Cells(НомерСтроки, НомерКолонки);

// Устанавливаем отступ в 2 символа Ячейка.Insertlndent(2);

// Устанавливаем размер шрифта Ячейка.Font.Size = 12;

// Устанавливаем цвет Ячейка.Font.ColorIndex = 5;

// Устанавливаем жирный шрифт Ячейка.Font.Bold = Истина;

// Устанавливаем ширину колонки Ячейка.ColumnWidth = 20;

// Очищаем все границы Ячейка.Borders(5).LineStyle = -4142;

// Устанавливаем левую границу Ячейка.Borders(1).LineStyle = 1;

// Устанавливаем верхнюю границу Ячейка.Borders(8).LineStyle = 1;

// Устанавливаем нижнюю границу Ячейка.Borders(9).LineStyle = 1;

// Устанавливаем правую границу Ячейка.Borders(10).LineStyle = I;

11 Устанавливаем выравнивание по левому краю Ячейка.VerticalAlignment = -4160;

// Устанавливаем перенос слов Ячейка.WrapText = Истина;

Использование OLE Automation В первой строке данного примера в переменную ячейка помещается ссылка на конкретную ячейку с координатами номерстроки и номерКолонки. После этого через данную переменную устанавливается размер шрифта, цвет тек ста, ширина ячейки, границы, положение текста и т. д.

Создание сводных таблиц MS Excel Большое количество пользователей, работающих с системой "1С:Предприятие", некоторые отчеты формируют и анализируют в Microsoft Excel. Самое удоб ное средство анализа данных в MS Excel — это сводные таблицы (рис. 4.1) и сводные диаграммы.

с D _L _j В Е A -f— 1 (Тип рРасход т Текущие расходы по филиалу 2 Автор IMAV -г э:

Месяц т( Сумма, $ Счет -^(Аналитика •*• OS.2004 ОЬщий итог -5095, сч. 91 -4688,02 -407, -4812 -9116, сч. 60 -13928, -1739, ;

-1739, сч. О -2929,64 -2929, 9 сч. -17028, 10 сч. 70 Зарплата за август -17028, I -12228, Аванс за сентябрь -12228, ;

-29257, 12 сч. 70 Итог -29257, : -1854,6 -1854, 13 сч. -346,611 -627, 14 сч. 10 -974, - 15 сч. 20 - -383,18 -383, 16 сч. -56552, 17 Общий итог -9846,63:

-46705, Рис. 4.1. Пример сводной таблицы MS Excel С помощью встроенного языка системы "1С:Предприятие" и OLE-сервера MS Excel можно формировать сводные таблицы и диаграммы. Рассмотрим пример их формирования (листинг 4.41).

I Листинг 4.41. Создание сводной таблицы MS Excel для версии 7. Функция СформироватьСводнуюТаблицу(ТЗ, Заголовок, Период, Условия) Перем Значение;

Если ТЗ..КоличествоСтрок() < 2 Тогда Предупреждение("Невозможно сформировать сводную таблицу, содержащую 174 Глава менее двух строк!", 5);

Возврат 0;

КонецЕсли;

Попытка // Запускаем Excel-Server Excel = СоздатьОбъект("Excel.Application");

Исключение Сообщить(ОписаниеОшибки О,"!");

Возврат 0;

КонецПопытки;

Попытка Excel.Application.Workbooks.Add(1);

Excel.ActiveSheet.Name = "Данные";

// Выводим данные Для СтрокаТЗ = 1 По ТЗ.КоличествоСтрок() Цикл Для КолонкаТЗ = 1 По ТЗ.КоличествоКолонок() Цикл Значение = ТЗ.ПолучитьЗначение(СтрокаТЗ, КолонкаТЗ);

Excel.ActiveSheet.Cells(СтрокаТЗ+1, КолонкаТЗ).Value = Значение;

Если СтрокаТЗ = 1 Тогда ТЗ.Получить ПараметрыКолонки(КолонкаТЗ,"",0,0,Значение,0,"",1);

Excel.ActiveSheet.Cells(1, КолонкаТЗ).Value = Значение;

КонецЕсли;

КонецЦикла;

КонецЦикла;

// Выводим сводную таблицу Excel.Application. ActiveWorkbook.PivotCaches(). Add(1, "Данные!R1C1:R" + (1+ТЗ.КоличествоСтрок()) + "С" + ТЗ.КоличествоКолонок()). CreatePivotTable("", "СводнаяТаблица");

Excel.ActiveSheet.Name = "Таблица";

// Далее идет цветовое оформление Excel.Rows("1:4").Select ();

Excel.Selection.Insert(-4121);

Excel.ActiveSheet.Cells(1, 1).Value = Заголовок;

Excel.ActiveSheet.Cells(1, 1).Font.Size = 16;

Использование OLE Automation Excel.ActiveSheet.Cells(1, 1).Font.Colorlndex = 3;

Excel.ActiveSheet.Cells(1, 1).Font.Bold = 1;

Excel.ActiveSheet.Cells(1, 1).Font.Italic = 1;

Excel.ActiveSheet.Cells(1, 1).Font.Underline = 2;

Excel.ActiveSheet.Cells(2, 1).Value = Период;

Excel.ActiveSheet.Cells(2, 1).Font.Size = 8;

Excel.ActiveSheet.Cells(2, 1).Font.Colorlndex = 3;

Excel.ActiveSheet.Cells(3, 1).Value = Условия;

Excel.ActiveSheet.Cells(3, 1).Font.Size = 8;

Excel.ActiveSheet.Cells(7, 1).Select();

// Все готово. Показываем окно Excel Excel.Application.Visible = 1;

Исключение Excel.Quit();

Сообщить(ОписаниеОшибки О,"!");

Возврат 0;

КонецПопытки ;

Возврат 1;

КонецФункции //СформироватьСводнуюТаблицу В данном примере функция СформироватьСводнуюТаблицу имеет четыре па раметра.

О тз — таблица значений, которая будет использоваться в качестве источ ника данных для формирования сводной таблицы. Имена колонок таб лицы значений будут совпадать с именами колонок сводной таблицы MS Excel;

О Заголовок — название отчета (тип Строка), которое будет выводиться в первой строке таблицы Excel;

О период — период формирования отчета (тип Строка), которое будет вы водиться во второй строке таблицы Excel;

О УСЛОВИЯ — условия и комментарии к отчету (тип строка), которые будут выводиться в третьей строке таблицы Excel.

Функция возвращает 1, если сводная таблица была успешно сформирована, и о — иначе.

176 Глава Работа с Microsoft PowerPoint С помощью объекта PowerPoint.Application, предоставляемого OLE-сервером MS PowerPoint, можно программно открывать и манипулировать презента циями.

Основным в объектной модели PowerPoint является объект Application, содержащий коллекцию Presentations (презентации) объектов типа Presentation. Каждый объект типа Presentation содержит коллекцию slides (слайды) объектов типа slide, соответствующих слайдам презента ции. Слайды, в свою очередь, содержат коллекции shapes типа shape, соот ветствующие элементам слайдов презентации. Манипуляция презентациями, слайдами и их элементами осуществляется путем обращения к свойствам и методам этих объектов.

Запуск MS PowerPoint и открытие презентаций Для открытия уже существующей презентации документа следует восполь зоваться методом Open коллекции Presentations:

Арр.Presentations.Open("С:\MyPresentation.ppt");

Следует отметить, что свойство ActivePresentation объекта PowerPoint.Application указывает на текущую активную презентацию сре ди одной или нескольких открытых. Кроме того, к рабочей книге можно обращаться по ее порядковому номеру. Например, ко второй открытой ра бочей книге можно обратиться так:

Арр.Presentations.Item(2).

В листинге 4.42 приведен пример запуска MS PowerPoint и открытие пре зентации.

// Создание объекта приложения PowerPoint Арр = Новый СОМОбъект("PowerPoint.Application");

// Установка видимости окна приложения Арр.Visible = Истина;

// Открытие презентации Арр. Presentations. Open ("С: \Фундамент.ppt") ;

// Уничтожение объекта приложения Арр.Quit();

Отметим также, что в случае PowerPoint, в отличие от Word и Excel, объ ект Application не имеет метода Activate для того, чтобы сделать актив Использование OLE Automation ной конкретную презентацию среди нескольких открытых. Для реше ния этой задачи следует обращаться к коллекции windows объекта Presentation либо К объектам DocumentWindow И SlideShowWindow, на пример: А р р. P r e s e n t a t i o n s. I t e m ( l ). W i n d o w s. I t e m ( l ). A c t i v a t e ( ).

Сохранение, печать и закрытие презентаций Закрытие презентации можно осуществить, используя метод close:

Арр. P r e s e n t a t i o n s. I t e m ( 2 ). C l o s e ( ) ИЛИ Арр. ActivePresentation.Close ( ).

Обратите внимание на то, что в случае PowerPoint метод close закрывает презентацию, не предлагая пользователю сохранить изменения. К тому же он не имеет параметров, с помощью которых можно было бы повлиять на возможность сохранения изменений.

^ Примечание В случае Word и Excel метод Close обладал параметрами, влияющими на возможность сохранения документа перед его закрытием.

Для сохранения презентации следует воспользоваться методом save или SaveAs. Например:

Арр.Presentations.Item(2).Save();

Арр. Presentations. Item(2). SaveAs ("С: \Фундамент-Копия.ppt").

В общем случае метод SaveAs имеет три параметра, влияющих на то, как именно сохраняется презентация. Первый из них (обязательный) и пред ставляет собой строку, содержащую имя файла, в котором сохраняется пре зентация. Если в этой строке путь к файлу не указан, файл сохраняется в текущем каталоге.

Второй параметр (необязательный). Он указывает, в каком формате сохра няется презентация. Этот параметр может принимать значения:

П 1 — формат текущей версии PowerPoint;

П 2 — формат PowerPoint (версия 7);

П з — формат PowerPoint (версия 4);

П 4 — формат PowerPoint (версия 3);

П 5 — сохранить как шаблон;

П б — формат RTF;

П 7 — формат SlideShow (*.pps);

d 8 — формат PowerPoint Addln (*.ppa);

П ю — формат PowerPoint 4 Far East (версия для Китая, Японии, стран Юго-Восточной Азии);

Глава П и — формат по умолчанию, определяемый текущими настройками PowerPoint;

О 12 — формат HTML;

П 13 — формат HTML (версия 3);

П 14 — формат HTML для текстов в двухбайтовой кодировке;

О 15 — формат WMF;

О 16 — формат GIF;

О 17 — формат JPG П 18 — формат PNG;

П 19 — формат BMP.

Третий параметр указывает, нужно ли внедрять в презентацию используе мые в ней шрифты. Он может принимать значения истина (внедрять шриф ты) или ложь (не внедрять шрифты). По умолчанию используется значение Ложь.

Закрыть PowerPoint можно с помощью метода Quit объекта PowerPoint.Application. В случае PowerPoint этот метод параметров не имеет.

Вывод документа PowerPoint на устройство печати можно осуществить с помощью метода Printout объекта Presentation, например:

Арр.Presentations.Item(2).Printout().

Если нужно изменить параметры печати, следует указать значения соответст вующих (необязательных) параметров метода Printout. В случае PowerPoint их пять. Первые два параметра указывают номера слайдов, которые должны быть напечатаны. Третий параметр — представляет собой строку с именем файла, если вывод происходит в файл вместо принтера. Четвертый параметр (целое число) указывает, сколько экземпляров документа печатать. Пятый па раметр определяет, должен ли быть напечатанный документ разобран по эк земплярам, и принимает значения истина (по умолчанию) или Ложь. Так, для вывода документа с пятого по двадцатый слайды в файл C:\MyOutput.prn в трех экземплярах можно использовать следующий код:

Арр.Presentations.Item(2).Printout(5,20,"с:\MyOutput.prn",3).

Однако, помимо параметров метода Printout, влияющих на то, какой прин тер используется и сколько экземпляров печатается, на режим печати пре зентации влияет также свойство Printoptions объекта Presentation. Это свойство представляет собой объект Printoption, имеющий, в свою оче редь, набор свойств, влияющих на то, в каком виде печатается презентация (слайды, выдачи, заметки и др.), печатаются ли рамки вокруг слайдов, сколько слайдов на странице располагается в случае печати выдач, печатает ся ли фон слайдов и др. Указанный набор свойств примерно отражает, что Использование OLE Automation пользователь PowerPoint может изменить, выбрав пункт Print из меню PowerPoint (в том числе и имя принтера, имя презентации, и число копий).

Демонстрация слайдов Для показа слайдов используется метод Run объекта Slideshowsettings, яв ляющегося свойством объекта Presentation:

Арр.Presentations.Item(l).SlideShowSettings.Run().

Для установки режима показа слайдов также используется объект Slideshowsettings. Его свойство RangeType указывает, какой именно фраг мент презентации нужно демонстрировать. Возможные значения этого свойства следующие:

П 1 — вся презентация;

П 2 — выделенный диапазон слайдов;

П з — именованная демонстрация.

Свойства StartingSlide И EndingSlide объекта SlideShowSettings СОДер жат номера первого и последнего слайда демонстрируемого фрагмента. Эти свойства имеет смысл применять в тех случаях, если свойство RangeType этого же объекта равно 2.

Свойство AdvanceMode объекта Slideshowsettings указывает, каким обра зом производится смена слайдов при демонстрации:

П 1 — ручная смена слайдов;

О 2 — смена слайдов в соответствии с временем показа каждого слайда;

П з — запись времени показа слайдов.

Свойство LoopUntiistopped объекта Slideshowsettings, принимающее зна чение истина или ложь, указывает, демонстрируются ли слайды непрерывно до нажатия пользователем клавиши . Это свойство целесообразно применять, если свойство AdvanceMode объекта Slideshowsettings установ лено равным 2. Отметим также, что время показа слайдов, если таковое не записано пользователем вручную, можно установить программно, с помощью свойства siideShowTransition объекта slide. В листинге 4.43 приведен пример использования описанных выше свойств и методов.

Для Номер = 2 по 7 Цикл Арр.Presentations.Item(I).Slides.Item(Номер).SiideShowTransition.

AdvanceTime = 1;

Арр.Presentations.Item(1).Slides.Item(Номер).SlideShowTrans ition.

AdvanceOnTime = Истина;

180 Глава КонецЦикла;

Арр.Presentations.Item(l).SlideShowSettings.StartingSlide = 2;

App.Presentations.Item(1).SlideShowSettings.EndingSlide = 7;

App.Presentations.Item(1).SlideShowSettings.AdvanceMod = 2;

App.Presentations.Item(l).SlideShowSettings.LoopUntilStopped = Истина;

App.Presentations.Item(l).SlideShowSettings.RangeType = 2;

App.Presentations.Item(l).SlideShowSettings.Run();

В данном фрагменте кода время показа слайдов со второго по седьмой уста навливается равным одной секунде, далее указывается, что эти слайды будут демонстрироваться в соответствии с заданным временем непрерывно до на жатия клавиши , а затем запускается показ слайдов.

Свойство siideShowTransition объекта slide может быть использовано для определения анимационных эффектов при смене слайдов. В листинге 4. приведен фрагмент кода, иллюстрирующий, каким образом устанавливаются анимационные эффекты и звуковое сопровождение при смене слайда.

Листинг 4.44. Звуковое сопровождение при смене слайда App.Presentations.Item (I).Slides.Item (2).SiideShowTransition.EntryEffeet = 770;

App.Presentations.Item(1).Slides.Item(2).SiideShowTransition.SoundEffect.

ImportFromFile("C:\Program Files\NetMeeting\blip.wav");

Различные значения свойства E n t r y E f f e c t можно найти в интерфейсном модуле или справочном файле системы PowerPoint.

А теперь кратко остановимся на управлении поведением объектов при пока зе слайдов. Для управления анимацией объектов на слайдах следует исполь зовать свойство AnimationSettings объекта shape. Это свойство возвращает объект AnimationSettings, свойства которого и отвечают за анимацию дан ного объекта. Так, свойство AdvanceMode указывает, каким образом появля ется объект, а свойство AdvanceTime — через какое время после показа слайда появляется объект. Свойство TextLeveiEffeet определяет, до какого уровня текста происходит анимация объекта. И наконец, свойство Animate (принимающее значение истина или ложь) указывает, должен ли объект во обще отображаться с анимацией. Пример управления поведением объекта на слайде приведен в листинге 4.45.

г г " * " " " • лстинг4.45. Управление поведением объекта на слайде App.Presentations.Item(l).Slides.Item(3).Shapes.Item(1) AnimationSettings.AdvanceMode = 2;

App.Presentations.Item(1).Slides.Item(3).Shapes.Item(1) AnimationSettings.AdvanceTime = 1;

Использование OLE Automation App.Presentations.Item(1).Slides.Item(3).Shapes.Item (1).

AnimationSettings.TextLevelEffect = 16;

App.Presentations.Item(l).Slides.Item(3).Shapes.Item(1).

AnimationSettings.Animate = Истина;

Этот фрагмент кода устанавливает автоматическую анимацию первого объ екта на третьем слайде через одну секунду после показа слайда.

Работа с Adobe Photoshop С помощью OLE-сервера Adobe Photoshop можно автоматизировать выпол нение действий, связанных с обработкой растровых изображений.

Для создания объекта приложения Adobe Photoshop используется конструк ция, приведенная в листинге 4.46.

// Создание объекта приложения Photoshop Photoshop = Новый СОМОбъект("Photoshop.Application");

// Установка видимости окна приложения Photoshop.Visible = Истина;

// Уничтожение объекта приложения Photoshop.Quit();

Важно отметить то, что OLE-сервер Adobe Photoshop может создать только один экземпляр приложения, т. е. при попытке создать еще один объект — установится связь с открытым ранее приложением.

Для открытия существующего файла используется метод Open объекта Photoshop. В листинге 4.47 приведен пример открытия файла с последую щим его закрытием.

// Создание объекта приложения Photoshop Photoshop = Новый СОМОбъект("Photoshop.Application");

// Открытие картинки PhotoDoc = Photoshop.Open ("С:\picture.jpg");

// Закрытие документа PhotoDoc.Close();

// Уничтожение объекта приложения Photoshop.Quit();

Глава Над открытым документом можно производить различные действия, в том числе и выполнение определенных в Adobe Photoshop операций (Action).

Для выполнения операции над открытым документом необходимо вызвать метод piayAction объекта Photoshop с указанием в параметре названия вы полняемой операции. В листинге 4.48 приведен пример открытия документа Photoshop с именем "Quadrant colors", выполнение над ним операции и последующим сохранением документа.

// Создание объекта приложения Photoshop Photoshop = Новый СОМОбъект("Photoshop.Application");

// Открытие картинки PhotoDoc = Photoshop.Open("С:\picture.jpg");

// Запуск операции (Action) по имени Photoshop.PiayAction("Quadrant Colors");

// Сохранение картинки PhotoDoc.SaveTo("С:\NewPicture.psd");

// Закрытие документа PhotoDoc.Close();

// Уничтожение объекта приложения Photoshop.Quit();

Существенный недостаток данного примера состоит в том, что метод SaveTo не сохраняет автоматически документ, а открывает стандартный диалог со хранения файла. Для полной автоматизации всех действий над документом рекомендуется все операции (Action) заканчивать сохранением файла или установить отдельную операцию, которая будет сохранять документ в файл со всеми произведенными изменениями.

Помимо выполнения операции, с указанием ее имени, можно выполнить все определенные в Adobe Photoshop операции, перебрав коллекцию Actions объекта Photoshop (листинг 4.49).

// Создание объекта приложения Photoshop Photoshop = Новый СОМОбъект("Photoshop.Application");

// Открытие картинки PhotoDoc = Photoshop.Open("С:\picture.jpg");

// Перебор коллекции операций и запуск каждой из них Использование OLE Automation Для каждого Action из Photoshop.Actions Цикл КодОтвета = Вопрос("Запустить " + Action.Name + "?",РежимДиалогаВопрос.ДаНетОтмена,,,"Запустить операцию?");

Если КодОтвета = КодВозвратаДиалога.Да Тогда Action.Play();

ИначеЕсли КодОтвета = КодВозвратаДиалога.Отмена Тогда Прервать;

КонецЕсли;

КонецЦикла;

// Закрытие документа PhotoDoc.Close();

// Уничтожение объекта приложения Photoshop.Quit();

В данном примере перебираются все элементы коллекции Actions. Для каж дой операции (Action) появляется вопрос с просьбой подтвердить ее вы полнение, при утвердительном ответе она выполняется.

Глава Использование ADO Понятие ADO ADO (Microsoft ActiveX Data Objects) — это набор библиотек, содержащих СОМ-объекты. Основное их назначение — реализация прикладного про граммного интерфейса для доступа к базам данных и использование в клиентских приложениях. ADO использует библиотеки OLE DB, пре доставляющие низкоуровневый интерфейс для доступа к данным. OLE DB, со своей стороны, обеспечивают доступ к данным с помощью СОМ интерфейсов.

OLE DB и ADO являются частью универсального механизма доступа к дан ным Microsoft (Microsoft Universal Data Access), который обеспечивает высо копроизводительный доступ к различным источникам информации (вклю чая реляционные и нереляционные базы данных), в том числе к данным, хранящимся на мэйнфреймах, данным электронной почты и файловой сис темы, текстовым, графическим и др. Для многих современных приложений, которые используют различную информацию, характерно подобное разно образие ее источников. Более того, вполне очевидно, что могут появляться новые форматы данных и способы их хранения. Поэтому разумным требо ванием к универсальному механизму доступа к ним могла бы стать возмож ность поддержки не только существующих в настоящее время их форматов и источников, но и форматов данных, которые будут созданы в будущем.

Назначение универсального механизма доступа к данным фирмы Microsoft — предоставить доступ к перечисленным их источникам с помощью единой модели доступа.

Рассмотрим основные компоненты архитектуры универсального механизма доступа к данным Microsoft и обсудим их более детально.

О Microsoft ActiveX Data Objects (ADO) — представляет собой программный интерфейс для доступа к данным из приложений. С точки зрения про граммирования, ADO и его расширения являются упрощенным высоко уровневым объектно-ориентированным интерфейсом к OLE DB.

186 Глава П OLE DB — это низкоуровневый интерфейс для доступа к данным. ADO применяет OLE DB, но можно использовать OLE DB и напрямую, ми нуя ADO.

П Open Database Connectivity (ODBC) — стандартный способ доступа к ре ляционным базам данных. Этот компонент универсального механизма доступа оставлен с целью обеспечения совместимости с прежними версия ми программного обеспечения. В современных приложениях применению ODBC-драйверов предпочитают использование OLE DB-провайдеров.

Для доступа к источнику данных с помощью OLE DB требуется, чтобы на компьютере, где используется клиентское приложение, был установлен OLE DB-провайдер для данной СУБД. OLE DB-провайдер представляет собой динамическую библиотеку DLL, загружаемую в адресное пространство клиент ского приложения и используемую для доступа к источнику данных. Для каж дого типа СУБД нужен собственный OLE DB-провайдер, так как провайдеры базируются на функциях клиентских API (Application Programming Interface, программный интерфейс приложения), разных для различных СУБД.

ADO представляет собой высокоуровневый программный интерфейс для доступа к OLE DB-интерфейсам. Он позволяет манипулировать данными с помощью любых OLE DB-провайдеров, входящих как в состав Microsoft Data Access Components, так и в состав программных продуктов, разрабо танных сторонними производителями. ADO содержит набор объектов, ис пользуемых для соединения с источником информации с целью чтения, до бавления, удаления или модификации предоставляемых им данных.

П Объект connection применяется для установки связи с источником данных.

Он представляет единственную сессию. Этот объект позволяет изменить параметры соединения с базой данных, а также начать или завершить транзакцию. Используя объект connection, можно выполнять команды (например, SQL-запросы) с помощью метода Execute. Если команда воз вращает набор данных, то автоматически создается объект Recordset, ко торый возвращается в результате выполнения этого метода.

П Объект Error используется для получения сведений об ошибках, возни кающих в процессе выполнения приложения.

П Объект command представляет собой команду, которую можно выполнить в источнике данных. Команда может содержать SQL-предложение или вызов хранимой процедуры. В последнем случае для определения пара метров процедуры может быть использована коллекция Parameters объ екта Command.

П Объект Recordset — это набор записей, полученных из источника дан ных, и может быть использован для добавления, удаления, изменения, просмотра записей. Данный объект может быть открыт непосредственно ИЛИ создан С ПОМОЩЬЮ объектов Connection ИЛИ Command.

Использование ADO П Объект Field — это колонка в наборе данных, представленных объектом Recordset. Объект может быть использован для получения значений конкретного поля таблицы, его модификации, извлечения метаданных, таких как имя колонки и тип данных.

О Объект Record — представляет одну запись внутри объекта Recordset и может быть использован для работы с гетерогенными и иерархическими данными (добавлен в библиотеку ADO 2.5, являющуюся составной частью операционной системы Windows 2000).

П Объект stream представляет двоичные данные, связанные с объектом Record. Например, если объект Record представляет собой файл, то его объект stream должен содержать данные внутри этого файла (добавлен в ADO 2.5).

Соединение с источником данных Для установки связи с источником данных используется объект Connection.

Рассмотрим два варианта создания соединения — явного (листинг 5.1) и неявного (листинг 5.2).

// Создание объекта установки связи с источником данных Connection = Новый СОМОбъект("ADODB.Connection");

// Подключение к источнику данных Попытка Connection.Open(СтрокаПодключения);

Исключение Сообщить(ОписаниеОшибки() ) ;

Возврат;

КонецПопытки;

// Создание объекта выполнения команды Command = Новый СОМОбъект("ADODB.Command");

// Указание активного соединения Command.ActiveConnection = Connection;

// Определение текста команды Command.CommandText = "SELECT * FROM titles";

// Определение типа команды Command.CommandType = 1;

188 Глава // Создание объекта набора записей RecordSet = Новый СОМОбъект("ADODB.RecordSet");

// Выполнение и получение набора данных RecordSet = Command.Execute();

// Перебор данных Пока RecordSet.EOF() = 0 Цикл Сообщить(RecordSet.Fields(0).Value);

RecordSet.MoveNext();

КонецЦикла;

// После того как набор записей уже не нужен, его следует закрыть RecordSet.Close();

Connection.Close();

// Создание объекта выполнения команды Command = Новый СОМОбъект("ADODB.Command");

// Указание активного соединения без использования объекта Connection Command.ActiveConnection = СтрокаПодключения;

// Определение текста команды Command.CommandText = "SELECT * FROM titles";

// Определение типа команд Command.CommandType = 1;

// Создание объекта набора записей RecordSet = Новый СОМОбъект("ADODB.RecordSet");

// Выполнение и получение набора данных RecordSet.Open(Command);

// Перебор данных Пока RecordSet.EOF() = 0 Цикл Сообщить(RecordSet.Fields(0).Value);

RecordSet.MoveNext();

КонецЦикла;

Использование ADO /I После того как набор записей уже не нужен, его следует закрыть RecordSet.Close ();

Connection.Close();

Из приведенных примеров видно, что основное отличие явного соединения от неявного заключается в том, что в последнем случае не используется объ ект Connection. Для получения более структурированного и понятного кода рекомендуется использовать явное соединение.

В обоих примерах для описания источника данных использовалась строко вая переменная Строкаподключения. Значение данной переменной можно формировать вручную, либо с помощью программы связи с данными. Про грамма связи с данными используется для создания и управления подклю чениями между локальным компьютером и хранилищами данных OLE DB.

Запустить программу связи с данными можно двумя способами — вручную и программно.

|Щ6 Свойства связи с данными Поставщик данных Подключение j Дополнительно ] Все •!.. Для подключения к данным SQL Server укажите следующее:

1. Выберите или введите имя сервера:

Обновить MAVCOMP jj 2. Для входа в сервер использовать:

С учетные сведения Windows NT : (* следующие имя и пароль пользователя:

mav Пользователь:

Пароль:

Г* Пустой пароль ** Разрешить сохранение пароля. - 3 ( Выберите базу данных на сервере:

• JNorthwind j^J С" Подсоединить Файл с базой данных под именем:

Г Я ФаЙЛй'.

Проверить подключение Справка | | Отмена ! :,0"К " ':..

Рис. 5.1. Диалог программы связи с данными 190 Глава Для ручного запуска достаточно создать пустой текстовый файл с расшире нием UDL и в любом файловом менеджере запустить его. Этом случае от кроется диалог (рис. 5.1), в котором настраиваются параметры соединения, а после нажатия кнопки ОК сформировавшаяся строка соединения запи шется в созданный UDL-файл.

Пример программного запуска утилиты настройки связи с данными приве ден в листинге 5.3.

// Программа для формирования и редактирования строки соединения DataLinks = Новый СОМОбъект("DataLinks");

// Объекту Connection устанавливаем введенное значение строки соединения Connection.ConnectionString = СтрокаПодключения;

// Открываем диалог программы связи с данными DataLinks.PromptEdit(Connection);

// Возвращаем новое значение строки соединения СтрокаПодключения = Connection.ConnectionString;

Сообщить(СтрокаПодключения);

Важно отметить, что при программном запуске утилиты связи с данными все манипуляции со строкой соединения происходят через объект Connection. Данная особенность еще раз говорит в пользу того, что лучше использовать явное соединение с источником данных (см. листинг 5.1).

Например, для доступа к базе данных Microsoft SQL Server строка соедине ния будет выглядеть следующим образом:

"Provider=SQLOLEDB.l;

Password=erpg;

Persist Security Info=True;

User ID=mav;

Initial Catalog=Northwind;

Data Source=MAVCOMP" Если же строка соединения записана во внешнем UDL-файле, то строка соединения будет выглядеть иначе:

"FileName=C:\DataLinks\MyDataLink.udl" Рассмотрим основные свойства строки соединения.

П Provider — названия поставщика OLE DB.

П User ID — имя пользователя.

О Password — пароль пользователя.

О Persist Security Info — признак сохранения пароля в строке соединения (True/False).

П Initial Catalog — используемая база данных.

Использование ADO П Data Source — название источника данных (например, имя сервера, имя файла и т. п.);

П File Name — полное имя UDL-файла.

Все остальные свойства зависят от конкретного OLE DB-провайдера.

Продолжая рассматривать пример, приведенный в листинге 5.1, стоит оста новиться на объекте connection. Это самый важный объект ADO, отвечаю щий за связь между приложением и базой данных. У него очень много ме тодов и свойств, и одно из них, connectionstring, описанное ранее. Оно определяет собственно строку инициализации ODBC-соединения.

Рассмотрим основные свойства объекта Connection.

О ConnectionTimeout — задает время в секундах, в течение которого ожи дается установление ODBC-соединения. По умолчанию равно 15. Кон кретное значение имеет смысл устанавливать в том случае, когда сервер, вследствие своей загруженности или высокого трафика, не успевает об рабатывать запросы. Если установить значение равное 0, то сервер будет ждать установления соединения бесконечно долго.

П CommandTimeout — задает время в секундах, в течение которого ожидается исполнение запросов. По умолчанию равно 30.

П! Connectionstring — строка инициализации ODBC-соединения.

П DefauitDatabase — база данных по умолчанию для данного соединения.

П state — определяет состояние соединения (о — закрыто, 1 — открыто).

Рассмотрим основные методы объекта connection.

П open — метод открывает доступ к базе данных и имеет три необязатель ных параметра:

• Connectionstring — строка соединения с источником данных, при чем если параметр connectionstring не задан, то используется свой ство connection. Connectionstring;

• userio — имя пользователя;

• Password — пароль (обычно userio и Password задаются непосредст венно в Connectionstring, поэтому их можно не задавать).

П close — разрывает связь с базой данных, при этом закрываются также все объекты типа Recordset, связанные с данным объектом, однако па мять, отведенная под объект connection, не освобождается, т. е. в даль нейшем можно снова выполнить команду open для повторного доступа к базе данных.

О Execute — метод исполняет SQL-запрос или хранимую процедуру и воз вращает объект типа Recordset, причем возможно задание трех параметров:

• commantText — строка, содержащая SQL-запрос, имя таблицы, храни мой процедуры или прочий исполняемый текст;

192 Глава _ _ _ RecordsAf fected — переменная, в которую возвращается количество • записей в результате исполнения запроса;

• options — определяет тип параметра commandText (полезен для опти мизации исполнения запроса) и может иметь значения:

О 1 — SQL-запрос или другое текстовое выражение;

О 2 — таблица;

О 4 — хранимая процедура;

О 8 — тип параметра неизвестен.

Примечание | Важно отметить, что объект Recordset, созданный с помощью этого метода, доступен только для чтения и его сканирование может производиться только вперед по записям. Для того чтобы иметь возможность вставлять или изменять записи, а также двигаться вперед и назад по ним, необходимо непосредственно создать этот объект и задать некоторые его свойства до исполнения соответст вующего запроса.

Выполнение SQL-запросов и хранимых процедур Ранее было сказано, что выполнить SQL-запрос или хранимую процедуру можно с помощью метода Execute объекта Connection, но наиболее пра вильно для этих целей использовать специализированный объект — command. Это связано с тем, что объект command специально предназначен для обработки параметров SQL-операторов, а также хранимых процедур и при возврате объекта Recordset минимизирует количество информации, которой обмениваются поставщик данных и приложение.

Объект Command описывает команду (запрос или оператор), которая обраба тывается источником данных. Благодаря этому объекту обеспечивается про стота и эффективность работы с запросами или хранимыми процедурами.

С помощью объекта command можно определить SQL-строку, хранимую про цедуру или имя таблицы.

Как и многие другие объекты модели ADO, объект command может быть соз дан либо с помощью объекта Connection (листинг 5.1), либо независимо от него (листинг 5.2).

После того как объект command будет создан и подключен к поставщику данных, его можно использовать для выполнения процедур и SQL операторов, которые будут либо воздействовать на данные в источнике дан ных, либо возвращать объект Recordset.

Использование ADO Рассмотрим пример добавления новой записи в таблицу базы данных (лис тинг 5.4).

ТекстЗапроса"= " I INSERT I INTO Users(Parentld, IsFolder, FIO, Login, Password, Description) I VALUES (" + 2 + " " + 1 + ", " + Пользователь.Наименование + ", • +, ' '" Пользователь.Логин + "','pass','Произвольное описание')";

Command = СоздатьОбъект("ADODB.Command");

Command.ActiveConnection = Connection;

Command.CommandText = ТекстЗапроса;

.

Command.CommandType = 1;

// Выполнение запроса RecordSet = Command.Execute();

Примечание ]Д Отдельно на тексте запроса останавливаться не будем, так как подразумевает ся, что читатель знаком с языком SQL Рассмотрим основные свойства объекта Command.

П ActiveConnection — данное свойство определяет соединение, с которым работает объект Command, и содержит строку, описывающую соединение либо указывающую на открытый в данный момент объект connection.

В первом случае создается новое соединение, предназначенное специально для объекта Command и объекта Recordset, который также создается.

П CommandText — это свойство определяет SQL-оператор, имя хранимой процедуры либо имя таблицы, с которой будет работать объект command.

Как правило, оно содержит вызовы хранимых процедур или SQL операторов, кроме этого может включать и специфические команды, поддерживаемые поставщиком данных.

П commandTimeout — данное свойство предназначено для определения ин тервала времени ожидания объектом Command результатов обращения к поставщику данных. По истечении этого периода объект command отме няет попытку установить соединение и генерирует сообщение об ошибке.

Стандартное значение данного свойства равно 30 секундам. Однако оно может быть и больше, если предполагается, что процесс загрузки данных поставщиком занимает много времени.

7 Зак. Глава О commandType — данное свойство используется для оптимизации процесса обработки объекта command поставщиком данных. При указании кон кретного типа команды, определенной свойством CommandText объекта command, поставщик данных освобождается от распознавания типа вы полняемой команды. Аналогично аргументу Option метода Execute объ екта connection, данное свойство может принимать следующие значения:

• 1 — SQL-запрос или прочее текстовое выражение;

• 2 — таблица;

• 4 — хранимая процедура;

• 8 — тип параметра неизвестен.

П state — свойство возвращает множество значений сумм одной или не скольких констант objectstateEnum. Эти константы описывают — явля ется ли объект Command открыт, закрыт, в соединении и т. п. Возможные значения:

• о — объект закрыт;

• 1 — объект открыт;

• 2 — соединяется;

• 4 — выполняется;

• 8 — выбран.

Рассмотрим основные методы объекта command.

О Execute — метод исполняет SQL-запрос или хранимую процедуру. Воз вращает объект типа Recordset.

П CreateParameter — данный метод используется для создания новых объ ектов Parameter, которые добавляются в семейство Parameters объекта command до того, как будет выполнен запрос. Объект Parameter описывает параметр, передаваемый в SQL-оператор или хранимую процедуру, кото рая указана В СВОЙСТВе CommandText объекта Command.

Рассмотрим более подробно использование параметров, передаваемых в хра нимые процедуры. Для передачи параметров процедуре необходимо выпол нить следующие действия.

1. Вызвать метод CreateParameter И создать новый объект Parameter.

2. Добавить Объект В семейство Parameters объекта Command.

3. Воспользовавшись методом Execute объекта command, получить объект Recordset.

Рассмотрим пример выполнения перечисленных действий (листинг 5.5).

Использование ADO 11 Создание нового объекта Command Command = Новый СОМОбъект("ADODB.Command");

// Организация связи с поставщиком данных для объекта Command Command.ActiveConnection = Connection;

// Задание хранимой процедуры Command.CommandText = "SP_GET_AUTHOR_INFO";

// Применение метода CreateParameter объекта Command для // создания нового объекта Parameter, который будет // использован при выполнении хранимой процедуры.

Parameter = Command.CreateParameter("SUSERNAME", 200, 1, 12, "MAV"};

// Добавление в семейство Parameters объекта Command нового параметра Command.Parameters.Append(Parameter);

// Получение объекта Recordset Recordset = Command.Execute();

Метод CreateParameter применяется следующим образом:

CreateParameter(Name, Type, Direction, Size, Value).

Рассмотрим параметры этого метода.

П Name — строковое значение, определяющее имя создаваемого параметра.

П Туре — тип параметра, передаваемого в объект command. Хотя тип значе ния параметра, передаваемого методу CreateParameter, является вари антным, включение этого необязательного аргумента часто влияет на операцию, выполняемую поставщиком данных. Все возможные значения перечислены в табл. 5.1.

О Direction — если вам не приходилось использовать хранимые процедуры, то вам не известен тот факт, что они могут как принимать параметры, так и возвращать их. Например, если применяется хранимая процедура для вычисления значений, получаемых при обмене валюты, она будет возвращать результат вычислений в выходном параметре. Данный аргу мент определяет способ использования параметров хранимой процедуры:

для ввода данных, для вывода значений, или же и для того и для другого.

Все возможные значения перечислены в табл. 5.2.

П size — если объекту Parameter передаются данные переменной длины, то прежде чем добавить этот объект в семейство Parameters, нужно за дать значение его свойства size, иначе произойдет ошибка.

П value — этим аргументом устанавливается значение параметра, переда ваемого объекту Connection (ADO позволяет задавать для данного аргу Глава мента длинные двоичные значения). Например, если требуется получить значение, возвращаемое хранимой процедурой — необходимо добавить параметр С именем Return: ReturnParameter = Command. CreateParameter ("Return", 3, 4 ) • Соответственно результат, возвращенный хранимой процедурой, будет находиться в свойстве ReturnParameter.Value.

Таблица 5.1. Типы параметров, используемые в объектах ADO Значение Описание Константа ADO 8-байтовое целое со знаком adBiglnt Двоичное значение adBinary Булево значение adBoolean Символьная строка, заканчивающаяся симво adBSTR лом Null (в кодировке Unicode) adChar Строковое значение Денежная сумма (8-байтовое целое со знаком, adCurrency кратное 10000) Дата adDate 133 Дата (в формате "ггггммчч") adDBDate Время (в формате "ччммсс") adDBTime Точная дата и время (в формате "гггг_мм_ adDBTimeStamp чч_чч_мм_сс" плюс тысячные доли секунды) Десятичное число с фиксированными разме adDecimal рами целой и дробной частей Значение с плавающей точкой двойной точно adDouble сти Значение не определено adEmpty 32-битовый код ошибки adError adGUID Полностью уникальный идентификатор (QUID) Указатель на интерфейс IDispatch OLE-объекта adIDispatch 4-байтовое целое со знаком adlnteger Указатель на интерфейс lUnknown OLE-объекта adIUnknown Длинное двоичное значение (только для объек adLongVarBinary та Parameter) adLongVarChar 201 Длинное строковое значение, заканчивающее ся символом Null (только для объекта Parameter) Использование ADO Таблица 5.1 (окончание) Константа ADO Значение Описание adLongVarWChar 203 Длинное строковое значение (только для объ екта Parameter) adNumeric Десятичное число фиксированной точности adSingle Значение одинарной точности с плавающей точкой adSmalllnt 2-байтовое целое со знаком 1 -байтовое целое со знаком adTinylnt 21 8-байтовое целое без знака adUnsignedBiglnt adUnsignedlnt 4-байтовое целое без знака adUnsignedSmalllnt 2-байтовое целое без знака 17 1 -байтовое целое без знака adlnsignedTinylnt adUserDef ined Переменная, определяемая пользователем Двоичное значение (только для объекта adVarBinary Parameter) 200 Строковое значение (только для объекта adVarChar Parameter) Вариантная переменная OLE-автоматизации adVariant 202 Символьная строка Unicode, заканчивающаяся adVarWChar символом Null (только для объекта Parameter) Символьная строка Unicode, заканчивающаяся adWChar символом Null Таблица 5.2. Допустимые значения аргумента Direction метода Crea teParameter Значение Описание Константа ADO adParamUnknown Назначение параметра не определено adParamlnput Входной параметр (по умолчанию) — использу ется для передачи информации в хранимую процедуру adParamOutput Выходной параметр — применяется для полу чения данных из хранимой процедуры посред ством SQL-параметра OUTPUT adParamlnputOutput Входной и выходной параметр— используется как для передачи информации в хранимую про цедуру, так и для получения от нее значений Возвращаемое значение — применяется для пере adParamReturnValue хвата кода завершения хранимой процедуры 198 Глава Обращение к результатам запроса Ранее очень часто встречалось использование объекта Recordset. Объект типа Recordset представляет таблицу — результат запроса к базе данных.

Экземпляр объекта создается командой:

Новый СОМОбъект("ADODB.RecordSet").

Для перемещения по строкам, или записям, таблицы, объект использует курсор, указывающий на текущую запись. При открытии объекта курсор указывает на самую первую запись. Для удобства работы можно разбивать таблицу на страницы, варьируя их размер. По умолчанию, если не задано свойство CursorType, перемещаться по записям можно только вперед.

Для того чтобы определить список полей таблицы, используется коллекция Fields объекта Recordset. Каждый элемент коллекции представляет собой объект типа Field. Чтобы вывести список полей таблицы, можно использо вать следующий код (листинг 5.6).

нг 5.6. Вывод списка полей, входящих в Recordset // Создание объекта выполнения команды Command = Новый СОМОбъект("ADODB.Command");

// Указание активного соединения Command.ActiveConnection = Connection;

// Определение текста команды Command.CommandText = "SELECT * FROM titles";

// Определение типа команды Command.CommandType = 1;

// Создание объекта набора записей RecordSet = Новый СОМОбъект("ADODB.RecordSet");

// Выполнение и получение набора данных RecordSet = Command.Execute();

// Перебор полей RecordSet Для НомерКолонки = 0 По RecordSet.Fields.Count-1 Цикл Сообщить("Имя колонки" + RecordSet.Fields.Item(НомерКолонки).Name);

КонецЦикла;

Использовать данный прием очень удобно в том случае, когда заранее неиз вестен состав полей выборки.

Использование ADO Рассмотрим следующий пример, в котором демонстрируется вывод всех значений полей всех записей, причем состав полей, как и в предыдущем примере, заранее неизвестен (листинг 5.7).

// Перебор записей выборки КоличествоПолей = RecordSet.Fields.Count;

Пока RecordSet.EOF() = 0 Цикл // Перебор полей выборки Для НомерКолонки = 0 По КоличествоПолей-1 Цикл ИмяПоля = RecordSet.Fields.Item(НомерКолонки).Name;

Значение = RecordSet.Fields(ИмяПоля).Value;

Сообщить("Поле: " + ИмяПоля + " = " + Значение);

КонецЦикла;

// Переводим курсор на следующую запись RecordSet.MoveNext();

КонецЦикла;

Для большего понимания данного примера и возможностей объекта RecordSet рассмотрим свойства данного объекта.

П ActiveConnection — объект типа Connection, к которому привязан дан ный Recordset.

П source — строка-источник запроса, т. е. SQL-выражение, имя таблицы или хранимой процедуры.

П Filter — фильтр, т. е. та часть SQL-запроса, которая находится в составе WHERE.

О CursorType — тип курсора. Значениями свойства, которые можно изме нять только до открытия объекта, могут быть:

• о — является значением по умолчанию (Forward only-курсор) и позво ляет перемещаться только вперед по записям таблицы (является наи более оптимальным в тех случаях, когда нужно провести лишь единст венный проход по записям);

• i — определяет подобие динамическому курсору (Keyset-курсор) за исключением того, что вы не можете видеть записи таблицы, добав ленные другими пользователями базы данных;

• 2 — позволяет любые перемещения по таблице, а также добавление, изменение и удаление записей, которые видны всем пользователям базы данных (Динамический курсор);

200 Глава • з — позволяет производить поиск по таблице и создавать отчет (Ста тический курсор — копия таблицы), причем добавления, изменения и удаления, проведенные другими пользователями, невидимы (полезен, например, при постраничном выводе таблицы с возможностью пере мещаться вперед или назад по страницам).

П state — определяет состояние объекта:

• о — закрыт;

• 1 — открыт/ П BOF — логическая величина (истина или ложь). Определяет факт того, что курсор находится перед первой записью таблицы.

П EOF — логическая величина. Определяет, что курсор находится за по следней записью таблицы.

П EditMode — определяет состояние редактирования текущей записи (про веден ли метод update для сохранения текущих изменений). Свойство может принимать следующие значения:

• о — показывает, что редактирование не проводилось;

• 1 — показывает, что данные в текущей записи редактировались, но изменения еще не сохранены;

• 2 — показывает, что текущая запись добавлена с помощью метода AddNew, но до сих пор не сохранена.

П RecordCount — определяет количество записей в таблице (доступно, ТОЛЬКО еСЛИ CursorType = 3).

П AbsoiutePosition — перемещает курсор на новую запись под данным номером. Должен иметь значение в интервале от 1 до RecordCount (дос тупно, ТОЛЬКО еСЛИ CursorType = 3).

П Bookmark — закладка в виде числа. Никак не связана с номером записи.

^ Примечание Можно при сканировании по таблице запомнить значение Bookmark в некото рой временной переменной, а затем вернуться обратно на данную запись (дос тупно, только если CursorType = 3).

О Pagesize — задает число записей таблицы на странице. По умолчанию равен ю (доступно, только если CursorType = з).

П Pagecount — определяет количество страниц. Автоматически пересчиты вается при изменении Pagesize (доступно, только если CursorType = з);

П AbsoiutePage — перемещает курсор на начало данной страницы (доступ но, только если CursorType = 3).

Использование ADO Помимо перечисленных свойств, объект Recordset имеет ряд методов.

О Open — исполняет запрос и открывает таблицу-результат. Общий формат вызова: RecordSet.Open(Sourse, ActiveConnection, CursorType), при чем необязательные параметры Source, ActiveConnection И CursorType здесь обозначают то же, что и соответствующие свойства объекта Recordset. Кроме того, параметр ActiveConnection может быть не толь ко объектом типа Connection, но и просто строкой инициализации — ConnectionString.

О close — закрывает объект.

О Requery — заново пересчитывает таблицу. Эквивалентен последователь ному исполнению методов close и Open.

О clone — возвращает объект типа Recordset (копию исходного объекта).

Полезен в случаях, когда нужно использовать одновременно несколько записей из одной таблицы.

О MoveFirst, MoveLast, MoveNext, MovePrevious — перемещают курсор на первую, последнюю, следующую или предыдущую запись таблицы соот ветственно.

П Move — перемещает курсор на новое положение. Общий формат вызова:

Recordset.Move(NumRecords, Start), причем NumRecords здесь — КОЛИ чество записей, на которые нужно переместить курсор. Положительное значение означает перемещение вперед, отрицательное — назад по запи сям. Параметр start определяет точку отсчета, откуда нужно переместить курсор.

Примечание НЬ ЬМИ Я МММ^В^Ш ^^ ^^ МММММ— «»-| В « ^ 4Н| I Может быть либо закладкой, либо одним из возможных значений: о — значе ние по умолчанию, точка отсчета — текущая запись;

1 — отсчет идет от пер вой записи таблицы;

2 — отсчет идет от последней записи таблицы.

П AddNew — добавляет запись. Можно сначала добавить запись, затем опре делить значение полей. А можно это сделать и одной командой:

RecordSet.AddNew(Fields, Values). Здесь Fields — ИМЯ ИЛИ Массив имен полей, которые нужно определить, values — значение или массив значений этих полей (чтобы сохранить добавленную запись, необходимо ВЫПОЛНИТЬ МеТОД Update).

П Delete — удаляет текущую запись или группу записей в зависимости от параметра. Формат записи: Recordset.Delete(AffectRecords), где пара метр Af fectRecords может принимать одно из возможных значений:

• 1 — (значение по умолчанию) удаляет только текущую запись;

• 2 — удаляет записи, удовлетворяющие свойству Filter, которое долж но быть задано заранее.

202 Глава П update — сохраняет изменения в текущей записи. Изменения в записи можно произвести предварительно или непосредственно в команде:

Recordset.Update(Fields, V a l u e s ). Параметр Fields определяет здесь имя или массив имен полей, которые нужно определить, параметр values — значение или массив значений этих полей. Если курсор пере мещен с добавленной или измененной записи, сервер автоматически вы полнит метод Update.

П Canceiupdate — отменяет любые изменения или добавления записей, проведенные до использования метода update.

Работа со структурой базы данных (ADOX) Для работы со структурой базы данных существует технология ADO Exten sions for Data Definition and Security (ADOX). ADOX — представляет собой набор объектов, позволяющих манипулировать метаданными в базах данных и управлять объектами, отвечающими за безопасность.

ADOX предоставляет более универсальный способ манипуляции метадан ными, не требующий знания SQL для того, чтобы получить структуру базы данных или даже создать новые объекты.

К^ Примечание Обратите внимание на то, что ADOX работает далеко не со всеми базами дан ных— его функциональность ограничена Microsoft Access и Microsoft SQL Server, а также несколькими другими СУБД.

ADOX обладает собственной объектной моделью, состоящей из следующих объектов:

П Catalog — представляет всю схему базы данных;

П Table — представляет таблицу в базе данных;

П Column — представляет колонку в таблице;

П index — представляет индекс внутри таблицы;

П! Key — представляет первичный или внешний ключ;

П Group — представляет группу пользователей;

П user — представляет индивидуального пользователя базы данных внутри группы;

О Procedure — представляет хранимую процедуру внутри базы данных;

П view — является представлением (view) внутри базы данных.

Иерархия объектов ADOX начинается с объекта catalog. Этот объект со держит коллекции таблиц, представлений, процедур, пользователей и групп Использование ADO и может быть использован для открытия существующей базы данных (с по мощью объекта ADO Connection), а также для создания новой. Имея объект catalog, можно работать с таблицами, процедурами и представлениями.

Например, просматривая коллекцию Tables, можно узнать, какие таблицы имеются в базе данных, а также получить более детальные сведения о таб лицах, изучив коллекции Columns, indexes и Keys объекта Table. Изучая свойства объектов базы данных, можно получить сведения о метаданных и, в частности, сохранить их в отдельном файле или куда-либо перенести. Ис пользуя коллекции users и Groups, можно манипулировать правилами дос тупа к данным, создавая отдельных пользователей или группы пользовате лей базы данных.

Чтение структуры базы данных Рассмотрим пример вывода информации о таблицах, представлениях и про цедурах базы данных (листинг 5.8).

.. ~, :.

истинг 5.8. Вывод информации о таблицах, представлениях // Начальная инициализация Catalog = Новый СОМОбъект("ADOX.Catalog");

Catalog.ActiveConnection = СтрокаПодключения;

// Выводим таблицы Для НомерТаблицы = 0 По Catalog.Tables.Count-1 Цикл ИмяТаблицы = Catalog.Tables.Item(НомерТаблицы).Name;

Сообщить("Таблица: " + ИмяТаблицы);

КонецЦикла;

// Проверка текущего источника данных на поддержку коллекции Views Попытка КоличествоПредставлений = Catalog.Views.Count;

ПредставленияДоступны = Истина;

Исключение ПредставленияДоступны = Ложь;

КонецПопытки;

Если ПредставленияДоступны Тогда // Выводим представления Для НомерПредставления = 0 По Catalog.Views.Count-1 Цикл 204 Глава ИмяПредставления = Catalog.Views.^ет(НомерПредставления).Name;

Сообщить("Представление: " + ИмяПредставления);

КонецЦикла;

КонецЕсли;

// Выводим процедуры Для НомерПроцедуры = 0 По Catalog.Procedures.Count-1 Цикл ИмяПроцедуры = Catalog.Procedures.Item(НомерПроцедуры).Name;

Сообщить("Процедура: " + ИмяПроцедуры);

КонецЦикла;

В приведенном примере имеются три цикла для просмотра коллекций Tables, views и Procedures объекта Catalog. Отметим, что перед циклом просмотра коллекции views следует выполнить проверку того, доступны ли представления для текущего источника данных с помощью конструкции попытка...исключение...конецПопытки. Это делается, чтобы избежать ошибок и исключительных ситуаций, которые могут возникнуть, если ADOX не под держивает коллекцию views для текущего источника данных.

Коллекция Tables содержит один или более объектов Table, свойствами которых являются коллекции columns, indexes и Keys, и их также следует просмотреть (листинг 5.9).

// Начальная инициализация Catalog = Новый СОМОбъект("ADOX.Catalog");

Catalog.ActiveCdnnection = СтрокаПодключения;

// Выводим таблицы Для НомерТаблицы = 0 По Catalog.Tables.Count-1 Цикл Table = Catalog.Tables.Item(НомерТаблицы);

ИмяТаблицы = Table.Name;

Сообщить("Таблица: " + ИмяТаблицы);

// Выводим поля таблицы Если Table.Columns.Count > 0 Тогда Для НомерПоля = 0 По Table.Columns.Count-1 Цикл Column = Table.Columns.Item(НомерПоля);

'ИмяПоля = Column.Name;

ТипПоля = Column.Type;

Использование ADO ДлинаПоля = Column.DefinedSize;

Сообщить("Имя поля: " + ИмяПоля);

Сообщить("Тип поля: " + ТипПоля);

Сообщить("Длина поля: " + ДлинаПоля);

КонецЦикла;

КонецЕсли;

// Выводим индексы таблицы Если Table.Indexes.Count > 0 Тогда Для НомерИндекса = 0 По Table.Indexes.Count-1 Цикл Index = Table.Indexes.Item(НомерИндекса);

ИмяИндекса = Index.Name;

Сообщить("Имя индекса: " + ИмяИндекса);

КонецЦикла;

КонецЕсли;

//. Выводим ключи таблицы Если Table.Keys.Count > 0 Тогда Для НомерКлюча = 0 По Table.Keys.Count-! Цикл Key = Table.Keys.Item(HoMepKruo4a) ;

ИмяКлюча = Key.Name;

Сообщить("Имя ключа: " + ИмяКлюча);

КонецЦикла;

КонецЕсли;

КонецЦикла ;

В данном примере в цикле выборки полей таблицы свойство column.Type возвращает число, соответствующее типу, определенному в табл. 5.1. Ниже будет приведен полный список свойств объекта column.

П Attributes — содержит характеристики поля.

П DefinedSize — содержит максимальный размер поля.

П NumericScale — содержит сведения о положении десятичной точки для числового поля.

О Parentcatalog — указывает на имя каталога, к которому принадлежит поле.

П Precision — содержит максимальную точность данных в поле.

CJ ReiatedCoiumn — для ключевых полей содержит имя связанного поля.

П Sortorder — указывает порядок сортировки в данных для поля.

П туре — содержит тип данных, хранящихся в поле.

206 Глава Объект index содержит следующие свойства.

П clustered — указывает, является ли индекс кластерным.

П indexNuiis — указывает, как обрабатываются значения Null.

П PrimaryKey — указывает, реализует ли данный индекс первичный ключ.

О unique — указывает, должен ли быть уникальным ключ, реализованный в данном индексе.

И наконец, рассмотрим список свойств объекта Key.

П DeieteRuie — указывает, каким образом обрабатывается удаление запи си, содержащей первичный ключ.

П RelatedTable — для внешнего ключа указывает имя связанной таблицы.

О туре - содержит тип ключа.

П updateRuie — указывает, как производится обновление записи, содер жащей первичный ключ.

Создание баз данных и их объектов Первый шаг при создании новой базы данных — создание нового экземп ляра объекта Catalog. Это позволяет определить не только тип создаваемой базы данных (с помощью OLE D В-провайдера), но и местоположение файла базы данных. В листинге 5.10 показано, как это можно сделать для базы данных Microsoft Access.

// Описание переменных подключения ИмяФайла = "C:\demo.mdb";

СтрокаПодключения = "Provider=Microsoft.Jet.OLEDB.4.О;

Data Source=" + ИмяФайла;

// Создадим экземпляр объекта ADOX Catalog Catalog = Новый СОМОбъект("ADOX.Catalog");

// Создадим новый MDB-файл Catalog.Create(СтрокаПодключения);

В приведенном выше примере создается новая база данных заданного типа в заранее заданном каталоге. Затем можно добавить в эту базу данные таблиц и поля. Чтобы сделать это, необходимо:

1. Создать новый экземпляр объекта Table и добавить его в коллекцию Ta bles объекта Catalog.

2. Создать новый экземпляр объекта Column и добавить его в коллекцию Columns объекта Table.

Использование ADO Следующий пример (листинг 5.11) показывает, как можно реализовать эту последовательность действий.

// 1. Создать новый экземпляр объекта Table Table = Новый СОМОбъект("ADOX.Table");

// Имя новой таблицы ИмяТаблицы = "NewTable";

Table.Name = ИмяТаблицы;

// Добавление новой таблицы Catalog.Tables.Append(Table);

// 2. Создать новый экземпляр объекта Column // Имя новой колонки ИмяПоля = "NewColumn";

// Добавление нового поля (3-adInteger) Catalog.Tables(ИмяТаблицы).Columns.Append(ИмяПоля, 3);

Теперь рассмотрим работу с индексами и ключами. Для того чтобы создать ключ, используется объект лоох.кеу. Под объектами Key подразумеваются первичные (Primary key) И внешние (Foreign key) КЛЮЧИ.

Приведем пример созданий внешнего ключа (листинг 5.12).

ForeignKey = Новый СОМОбъект("ADOX.Key");

ForeignKey.Name = "CustOrder";

ForeignKey.Type = 1;

// adKeyForeign // Далее указывается ссылка на связанную таблицу ForeignKey.RelatedTable = "Customers";

// Определяем имя ключевого поля ForeignKey.Columns.Append("Customerld");

// Определяем имя поля в связанной таблице ForeignKey.Columns("Customerld").RelatedColumn = "Customerld" // Определяем правила контроля за каскадными обновлениями ForeignKey.UpdateRule = adRICascade;

// Добавляем ключ в коллекцию ключей Catalog.Tables("NewTable").Keys.Append(ForeignKey);

\ 208 Глава В данном примере свойство ForeignKey.Type может принимать следующие значения:

П 1 (adKeyPrimary) — первичный ключ;

П 2 (adKeyForeign) — внешний КЛЮЧ;

П 3 (adKeyUnique) — уникальный КЛЮЧ.

Свойство ForeignKey.updateRule может принимать следующие значения:

П о (adRiNone) — никаких действий каскадно не производится (использует ся по умолчанию);

П 1 (adRicascade) — произвести каскадное обновление поля;

О 2 (adRisetNuii) — значение внешнего ключевого поля выставляется в Null;

П з (adRisetDefauit) — значение внешнего ключевого поля выставляется в значение по умолчанию.

Подобным же образом осуществляется работа с управлением индексами.

^ Примечание Можно особо отметить следующую особенность — у таблицы есть коллекция индексов, а уже у каждого индекса есть коллекция полей, входящих в этот ин декс. Для простых индексов, состоящих из одного поля, в коллекции колонок содержится одна колонка, для составных индексов в коллекции колонок индек са содержатся колонки, входящие в этот индекс.

Приведем пример добавления к таблице составного индекса, состоящего из двух полей: Fieldl И Filed2 (ЛИСТИНГ 5.13).

Листинг 5.13. Создание составного индекса Index = Новый СОМОбъект("ADOX.Index");

// Зададим параметры индекса Index.Name = "Indexl" Index.Columns.Append("Fieldl");

Index.Columns.Append("Field2");

// Добавляем индекс в коллекцию Catalog.Tables("NewTable").Indexes.Append(Index);

Удаление объектов базы данных Для удаления объектов базы данных используется метод Delete. Приведем пример удаления индекса, ключа, поля и таблицы (листинг 5.14).

Использование ADO ИмяТаблицы = "NewTable";

// Удаление индекса Catalog.Tables(ИмяТаблицы).Indexes.Delete(ИмяИндекса);

// Удаление ключа Catalog.Tables(ИмяТаблицы).Keys.Delete(ИмяКлюча);

// Удаление поля Catalog.Tables(ИмяТаблицы).Columns.Delete(ИмяПоля);

// Удаление таблицы Попытка Catalog.Tables.Delete(ИмяТаблицы);

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

В данном примере удаление таблицы взято в операторные скобки попытка...

исключение...КонецПопытки для исключения системных ошибок, связанных с невозможностью удаления таблицы. Подобная ошибка может появиться при попытке удалить таблицу, содержащую внешний ключ. Вообще говоря, удаление любых объектов баз данных рекомендуется обрамлять конструкци ей Попытка...Исключение...КонецПопытки.

Доступ к данным Microsoft Excel через OLE DB Достаточно часто требуется сформировать отчет и вывести его не только на печать, но и выгрузить в таблицу Microsoft Excel. Также иногда возникает необходимость импортировать данные Excel в систему "1С:Предприятие".

Этого можно добиться двумя способами, либо используя технологию OLE Automation, описание и примеры использования которой рассматривались в главе 4, либо через объекты ADO.

Использование технологии ADO, при работе с таблицами Microsoft Excel, практически ничем не отличается от доступа к другим источникам данных.

Для подключения к Excel можно использовать код:

Provider=Microsoft.Jet.OLEDB.4.0;

Data Source=C:\file.xls;

Extended Properties="Excel 8.0;

HDR=NO;

".

210 Глава Параметр HDR здесь обозначает наличие заголовка в первой строке таблицы, причем YES — определяет присутствует заголовока;

NO — нет.

Для выгрузки данных в таблицы Microsoft Excel необходимо создать файл с расширением XLS. Это можно сделать вручную, либо программно с по мощью технологии ADOX. Рассмотрим пример создания файла Microsoft Excel через объекты ADOX (листинг 5.15).

ние MS Excel файла средствами ADOX // Определение имени файла и строки соединения ИмяФайла = "C:\ExcelDemoFile.xls";

СтрокаПодключения = "Provider=Microsoft.Jet.OLEDB.4.0;

Data Source» ИмяФайла + " Extended Properties=""Excel 8.0;

HDR=NO;

' ;

;

// Начальная инициализация Catalog = Новый СОМОбъект("ADOX.Catalog");

Catalog.ActiveConnection = СтрокаПодключения;

// Создание новой таблицы Table = Новый СОМОбъект("ADOX.Table");

// Имя таблицы Table.Name = "TestTable";

Для Ном = 1 По 5 Цикл // Создание новой колонки Column = Новый СОМОбъект("ADOX.Column");

// Имя колонки Column.Name = "Col" + Ном;

// Тип данных колонки Если Ном = 2 Тогда Column.Туре = 202;

// adVarWChar Иначе Column.Type =5;

// adDouble КонецЕсли;

// Присоединение колонки к таблице Table.Columns.Append(Column);

Column = Неопределено;

КонецЦикла;

// Присоединение созданной таблицы (листа) к книге Excel Catalog.Tables.Append(Table);

Использование ADO В данном примере создается файл C:\ExcelDemoFile.xls, в который добавля ется лист с именем TestTabie и инициализируются пять колонок. Свойство Туре объекта column определяет тип колонки. Для источника данных Microsoft Excel это свойство может принимать всего шесть значений, опи санных в табл. 5.3.

Таблица 5.3. Допустимые значения свойства туре объекта Column для MS Excel Константа ADO Значение Описание adDouble 5 Значение с плавающей точкой двойной точности adDate 7 Дата adCurrency 6 Денежная сумма (8-байтовое целое со знаком, кратное 1 0 000) adBoolean 11 Булево значение adVarWChar 202 Символьная строка Unicode, заканчивающаяся СИМВОЛОМ Null adLongVarWChar 203 Длинное строковое значение После того как файл Excel создан, можно выполнять действия по добавле нию данных в какой-либо лист книги Excel. Данные действия можно вы полнять двумя способами, либо через метод AddNew объекта Recordset (лис тинг 5.16), либо через SQL-запросы, используя конструкцию INSERT (листинг 5.17).

...

Листинг 5.16. Запись данных в лист MS // Создание соединения ADO для работы с книгой Excel ConnectionExcel = Новый СОМОбъект("ADODB.Connection");

ConnectionExcel.Open(СтрокаПодключения);

// Создание объекта набора записей RecordsetExcel = Новый СОМОбъект("ADODB.Recordset");

RecordsetExcel.Open("Select * from TestTabie", ConnectionExcel, 1, 3) Для Ном = 1 По 10 Цикл // Добавление новой записи RecordsetExcel.AddNew();

RecordsetExcel.Fields(0).Value = 11;

RecordsetExcel.Fields(1).Value = "Строка №" + Ном;

212 Глава RecordsetExcel.Fields(2).Value = 2.30;

RecordsetExcel.Fields(3).Value = Ном;

RecordsetExcel.Fields(4).Value = Ном * 2.2;

// Обновление изменений в книге Excel RecordsetExcel.UpDate();

КонецЦикла;

// Закрываем соединение ConnectionExcel.Close();

ConnectionExcel = Неопределено;

В данном примере метод AddNew добавляет очередную строку в лист Excel.

Важно отметить, что в один лист невозможно добавить более 65 000 строк — это ограничение приложения Microsoft Excel. Еще одна важная особенность добавления информации в ячейки листа заключается в том, что Excel не поддерживает автопреобразование типов значений ячеек. То есть, если с помощью свойства туре объекта Column для колонки соответствующей ячейки был определен числовой тип, то при попытке записать в эту ячейку строку — возникнет ошибка. Так же нельзя использовать для записи колонки, которые не были созданы, т. е. если было создано всего пять колонок, то можно записывать информацию только в первые пять колонок, хотя при открытии таблицы в приложении Microsoft Excel пользователю будут видны большое количество колонок.

Рассмотрим пример добавления записей, используя SQL-запросы (листинг 5.17).

, --—, _ _ _ _ „.

1нг 5.17. Запись данных в лист MS Excel через SQL-запросы // Создание объекта установки связи с источником данных Connection = Новый СОМОбъект("ADODB.Connection");

// Подключение к источнику данных Попытка Connection.Open(СтрокаПодключения);

Исключение Сообщить(ОписаниеОшибки() ) ;

Возврат;

КонецПопытки;

// Создание объекта выполнения команды Использование ADO Command = Новый СОМОбъект("ADODB.Command");

// Указание активного соединения Command.ActiveConnection = Connection;

// Определение текста команды Command.CommandText = "INSERT INTO TestTable VALUES(20, 'Новая строка', 33.3, 44.4, 55.5)";

// Определение типа команды Command.CommandType = 1;

// Выполнение запроса Command.Execute();

// Закрываем соединение Connection.Close();

Command = Неопределено;

Данный пример аналогичен примеру, приведенному в листинге 5.4, за ис ключением того, что в конструкции запроса INSERT нельзя указать имена колонок.

Для чтения данных из листа Excel необходимо выполнить ряд стандартных действий. Пример такой выборки приведен в листинге 5.18.

| Листинг 5.18. Чтение данных MS Excel средствами ADO L^i^L;

_—. :-i^_-_ :^j_L ^_._ -_--;

_-— i. i._^_—. :_:_—..^_-_i_-.-._-l.^ „ // Чтение данных // Создание объекта установки связи с источником данных Connection = Новый СОМОбъект("ADODB.Connection");

// Подключение к источнику данных Попытка Connection.Open(СтрокаПодкгаочения);

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки ;

// Создание объекта выполнения команды Command = Новый СОМОбъект("ADODB.Command");

// Указание активного соединения Command.ActiveConnection = Connection;

214 Глава I/ Определение текста команды Command.CommandText = "SELECT * FROM TestTable";

// Определение типа команды Command.CommandType = 1;

// Создание объекта набора записей RecordSet = Новый СОМОбъект("ADODB.RecordSet");

// Выполнение и получение набора данных RecordSet = Command.Execute() ;

// Перебор данных Пока RecordSet.EOF() = 0 Цикл Сообщить("Строка: " + Recordset.Fields(1).Value);

Сообщить("Число: " + Recordset.Fields(4).Value);

RecordSet.MoveNext();

КонецЦикла;

( // После того как набор записей уже не нужен, его следует закрыть RecordSet.Close();

Connection.Close ();

Доступ к данным Microsoft Project через OLE DB Для доступа к данным Microsoft Project можно использовать объекты ADO.

Общие принципы, применяемые для доступа к данным MS Project, такие же, что и для других источников данных, но есть некоторые особенности и ограничения.

Некоторые аспекты использования средства доступа OLE DB для Microsoft Project уникальны и должны быть приняты во внимание во избежание не желательных результатов.

П Существует четыре типа данных:

• text — текстовый;

number — ЧИСЛОВОЙ;

• • boolean — логический;

• date — дата-время (в том виде, как они отображаются в интерфейсе, например 27.12.1999 10:30).

Использование ADO П Поля длительности возвращают число минут, умноженное на 10 (напри мер, 8 часов — это 4800), а поля трудозатрат — число минут, умножен ное на 1000 (8 часам соответствует 480 000).

П Даты, отображающиеся в интерфейсе как NA (нет данных), возвращают ся как значение о.

П Формула в настраиваемом поле, которая в интерфейсе привела бы к ре зультату #ERROR, возвращает значение по умолчанию для данного поля.

П Настраиваемое поле, для которого не установлено никакого значения, возвращает значение, принимаемое по умолчанию.

G Поле индикатора настраиваемого поля в случае, когда индикатор не ус тановлен, возвращает значение -i.

П Значения трудозатрат для материальных ресурсов выражаются в едини цах, определенных в интерфейсе, а не числом минут, умноженным на 1000.

О Оператор SELECT без предложения WHERE возвращает пустые строки таб лиц ресурсов и задач. Если задать предложение WHERE, эти строки уже не будут возвращены, даже если они подходят по всем остальным условиям.

В реализации средства доступа OLE DB для Microsoft Project 2002 действует ряд ограничений.

П Не поддерживается доступ для чтения и записи.

П Не поддерживаются запросы сразу к нескольким таблицам. Для каждой таблицы, к которой требуется доступ, необходимо использовать отдель ный запрос.

П Доступ к OLE DB осуществляется с помощью курсоров (наборов запи сей) последовательного доступа. Наборы записей с последовательным доступом не поддерживают такие методы, как MovePrevious, MoveFirst или MoveLast. Кроме того, наборы записей с последовательным доступом не поддерживают использование свойства Recordcount.

П Объединения не поддерживаются, однако аналогичные возможности предоставляют сформированные наборы записей, устанавливающие ра нее не существовавшие отношения между ключами, полями или набора ми строк. Можно также создавать иерархические наборы записей в таб личном формате.

П Не поддерживаются операторы — ANY, LIKE и is NOT.

П Не поддерживаются статистические функции — Sum, Avg, Min, мах, count И StDev.

П Средство доступа OLE DB снабжено механизмом контроля времени, ко торый сигнализирует, когда следует выгружать файлы, но делает это не раньше, чем произойдет событие загрузки. Если в поле TimeBeforeUnioad установлено значение 1, то не проверяется — имеется ли открытый файл, 216 Глава до попытки открыть другой. В итоге этот файл блокируется для чтения.

Во избежание возникновения данной ситуации надо создать фиктивный файл, чтобы заставить средство доступа, после завершения работы над текущим проектом, загружать некий несуществующий файл. Таким обра зом, файл, который был в работе, будет выгружен, а блокировка чтения будет установлена на фиктивный файл.

Среда ADO обеспечивает доступ к OLE DB с использованием набора объек тов, событий, методов и свойств. Возможны два способа использования ADO:

П доступ к поставщику данных на локальном компьютере;

П доступ к поставщику с сервера Microsoft Project Server.

В листинге 5.19 показан доступ к файлу Microsoft Project на локальном ком пьютере, а также отображаются некоторые сведения о проекте.

нг 5.19. Подключение к проекту и вывод« // Определение параметров соединения Провайдер = "Microsoft.Project.OLEDB.10.О";

ИмяФайла = "C:\example.mpp";

// Если файл не защищен, то в строке подключения параметры // User ID (пользователь) и Password (пароль) указывать не обязательно Пользователь = " ;

" Пароль = " ;

" // Установка соединения с проектом Попытка Connection = Новый СОМОбъект("ADODB.Connection");

Connection.Open("Provider=" + СокрЛП(Провайдер) + ";

Project Name=" + СокрЛП(ИмяФайла) + ";

User ID=" + СокрЛП(Пользователь) + ";

Password=" + СокрЛП(Пароль));

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

// Запрос к проекту Command = Новый СОМОбъект("ADODB.Command");

Command.ActiveConnection = Connection;

Command.CommandText = "SELECT * FROM Project";

Использование ADO RecordSet = Новый СОМОбъект("ADODB.RecordSet");

, RecordSet = Command.Execute();

// Получение свойств проекта Название = RecordSet.Fields("ProjectTitle").Value;

ДатаНачала = RecordSet.Fields("ProjectStartDate").Value;

ДатаКонца = RecordSet.Fields("ProjectFinishDate").Value;

// Вывод свойств проекта Сообщить("Название проекта: " + Название);

Сообщить("Дата начала: " + ДатаНачала);

Сообщить("Дата завершения: " + ДатаКонца);

В данном примере происходит подключение к файлу проекта C:\example.mpp и выводится название проекта, даты начала и завершения проекта из таблицы Project (проект). Эта таблица обеспечивает доступ к па раметрам уровня проекта.

Таблица Project имеет большое количество полей. Основные из них приве дены в табл. 5.4.

Таблица 5.4. Основные поля таблицы Project Тип Описание Имя поля данных Project (Проект) Название проекта, отображаемое как путь к text его расположению на диске, например C:\example.mpp ProjectUniqueID number Уникальный идентификатор проекта (Уникальный идентифика тор проекта) ProjectAuthor text Имя автора проекта. Используется для груп (Автор) пировки аналогичных проектов ProjectCompany text Название организации, создавшей проект;

(Организация) используется для группировки аналогичных проектов ProjectCreationDate date Дата создания проекта (Дата создания) ProjectStartDate date Дата и время запланированного начала проекта (Дата начала) Дата и время запланированного завершения ProjectFinishDate date (Дата окончания) проекта Глава Таблица 5.4 (окончание) Имя поля Тип Описание данных ProjectLastSaved date Дата последнего сохранения проекта (Дата сохранения) ProjectManager text Руководитель проекта. Используется для (Руководитель) группировки проектов, имеющих одного руко водителя ProjectRevision text Текущий номер версии файла проекта (Версия) ProjectSubject text Тема проекта. Используется для группировки (Тема) аналогичных проектов ProjectTitle text Название проекта. Используется для группи (Название) ровки аналогичных проектов Все остальные поля таблицы Project и их типы можно вывести с помощью объектов ADOX (листинг 5.20).

// Определение параметров соединения Провайдер = "Microsoft.Project.OLEDB.10.0";

ИмяФайла = "C:\example.mpp";

// Начальная инициализация Catalog = Новый СОМОбъект("ADOX.Catalog") ;

Catalog.ActiveConnection = "Provider=" + CoкрЛЩПровайдер) + ";

Project Name=" + СокрЛП(ИмяФайла);

.

Table = Catalog.Tables.Item("Project");

// Выводим поля таблицы Если Table.Columns.Count > 0 Тогда Для НомерПоля = 0 По Table.Columns.Count-1 Цикл Column = Table.Columns.Item(НомерПоля);

ИмяПоля = Column.Name;

ТипПоля = Column.Type;

ДлинаПоля = Column.DefinedSize;

Сообщить("Имя поля: " + ИмяПоля);

Сообщить("Тип поля: " + ТипПоля);

Использование ADO Сообщить("Длина поля: " + ДлинаПоля);

КонецЦикла;

КонецЕсли;

Основная таблица, в которой хранятся сведения о задачах, включенных в проект, имеет идентификатор — Tasks, основные поля которой перечис лены в табл. 5.5.

Таблица 5.5. Основные поля таблицы Tasks Тип Описание Имя поля данных TaskUniquelD number Уникальный идентификатор задачи (Уникальный идентификатор) date Tas kActual Start Дата и время фактического начала задачи (Фактическое начало) date Tas kActual Finish Дата и время фактического завершения за (Фактическое дачи окончание) TaskActualWork number Объем трудозатрат, которые уже выполнены (Фактические назначенными задаче ресурсами трудозатраты) date TaskStart Дата и время запланированного начала выполне (Начало) ния задачи вычисляется автоматически, если у за дачи есть предшественник. TaskFinish — дата и время запланированного завершения выпол нения задачи TaskContact text Имя человека, являющегося ответственным за (Контактное лицо) выполнение задачи TaskName (Название) Название задачи text Введенные заметки о задаче TaskNotes (Заметки) text TaskOutlineLevel number Число, определяющее уровень задачи в иерар хической структуре проекта (Уровень структуры) TaskOutlineNumber text Точная позиция задачи в структуре. Например, номер 7.2 означает, что данная задача являет (Номер в структуре) ся второй подзадачей седьмой суммарной за дачи верхнего уровня TaskPercentComplete number Текущее состояние задачи, выраженное в виде завершенной части работы в процентах по от (Процент завершения) ношению к общей длительности задачи Глава К задачам обычно привязан один или несколько ресурсов. В таблице Assignments содержатся данные о необходимых ресурсах для выполнения всех задач. Основные поля таблицы Assignments приведены в табл. 5.6.

Таблица 5.6. Основные поля таблицы Assignments Тип Описание Имя поля данных TaskUniquelD (Уникальный number Указатель на действительный идентифи катор в таблице Tasks идентификатор задачи) AssignmentUniquelD number Уникальный идентификатор назначения (Уникальный идентификатор) AssignmentResourcelD number Указатель на действительный идентифи (Идентификатор ресурса) катор в таблице Resources AssignmentActualStart date Дата и время фактического начала на (Фактическое начало) значения AssignmentActualFinish date Дата и время фактического завершения (Фактическое окончание) назначения AssignmentActualWork number Объем работы, которая уже выполнена (Фактические трудозатраты) ресурсом задачи AssignmentStart (Начало) date Запланированная дата и время начала работы назначенного ресурса AssignmentFinish date Запланированная дата и время заверше (Окончание) ния использования ресурса по задаче AssignmentFinishVariance number Разница между датой окончания назначе (Отклонение окончания) ния по базовому плану и запланирован ной датой окончания AssignmentNotes (Заметки) text Заметки о назначении AssignmentUnits (Единицы) number Число единиц,' на которое ресурс назна чается задаче. Выражается в процентах от максимального числа единиц ресурса AssignmentWork number Общий запланированный объем трудоза (Трудозатраты) трат, которые ресурс должен выполнить по задаче AssignmentResourceName text Название ресурса, связанного с назначе (Название ресурса) нием AssignmentResourceType number Тип ресурса: 0 — трудовой (люди и обо (Тип ресурса) рудование, назначается по умолчанию);

1 — материальный (расходные материа лы, например, сталь, бетон или грунт) Использование ADO Рассмотрим пример вывода дерева задач с указанием использованных ре сурсов для системы "1C:Предприятие" версии 8.0 (листинг 5.21).

Ш;

5.21. Вывод дерева задач с указанием использованных ресурсов'...

,., ——..^-..„..-.....,.-гг-...-:-,........ —-р-;

~ Г"'----"' — —- """""" ] стинг | для версии 8. // Переводит номер задачи из формата ххх.хх.х в ххх.хх Функция ПолучитьКодРодителя(Знач НомерЗадачи) Числобхождений = СтрЧислоВхождений(НомерЗадачи, " " ;

.) Поз = 0;

Если ЧислоВхождений = 0 Тогда Возврат "О";

Иначе Для Ном = 1 По ЧислоВхождений Цикл Поз = Поз + Найти(Сред(НомерЗадачи, Поз +1), ".");

КонецЦикла;

Возврат Лев(НомерЗадачи, Поз - 1);

КонецЕсли;

КонецФункции // Формирует дерево задач Процедура СформироватьДерево() Провайдер = "Microsoft.Project.OLEDB.10.0";

ИмяФайла = "C:\example.mpp";

Пароль = " ;

" Состояние("Соединение с проектом. Пожалуйста ждите...");

Попытка Connection = Новый СОМОбъект("ADODB.Connection");

Connection.Open("Provider=" + CoкрЛП(Провайдер) + ";

Project Name=" + СокрЛП(ИмяФайла) + ";

Password=" + СокрЛП(Пароль));

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

// Запрос к задачам Command = Новый СОМОбъект("ADODB.Command");

222 Глава Command.ActiveConnection = Connection;

Command.CommandText = "SELECT TaskName,TaskType,TaskUniquelD,TaskOutlineLevel,TaskOutlineNumber, TaskStart,TaskFinish,TaskPercentComplete FROM Tasks";

RecordSet = Новый СОМОбъект("ADODB.RecordSet");

RecordSet = Command.Execute();

// Перебор данных Пока RecordSet.EOF() = 0 Цикл // Тип записи: 1-группа, 0-задача ТипЗадачи = RecordSet.Fields("TaskType").Value;

// Имя задачи или группы ИмяЗадачи = RecordSet.Fields("TaskName").Value;

// Уникальный идентификатор задачи или группы ИдентификаторЗадачи = RecordSet.Fields("TaskUniquelD").Value;

// Уровень задачи УровеньЗадачи = RecordSet.Fields("TaskOutlineLevel").Value;

// Номер задачи в формате хх.х.х НомерЗадачи = RecordSet.Fields("TaskOutlineNumber").Value;

ДатаНачала = RecordSet.Fields("TaskStart").Value;

ДатаКонца = RecordSet.Fields("TaskFinish").Value;

ПроцентВыполнения = RecordSet.Fields("TaskPercentComplete").Value;

Если НомерЗадачи = 0 Тогда СтрокаТПБазовая = ТабличноеПоле;

Иначе // Поиск родительской задачи Результат = ТабличноеПоле.Строки.Найти(ПолучитьКодРодителя(НомерЗадачи), "Ид", Истина);

Если Результат = Неопределено Тогда СтрокаТПБазовая.= ТабличноеПоле;

Иначе СтрокаТПБазовая = Результат;

КонецЕсли;

КонецЕсли;

// Добавляем параметры задачи в дерево СтрокаТП = СтрокаТПБазовая.Строки.Добавить();

Использование ADO СтрокаТП.Ид = НомерЗадачи;

СтрокаТП.Задача = ИмяЗадачи;

СтрокаТП.ДатаНачала = ДатаНачала;

СтрокаТП.ДатаКонца = ДатаКонца;

Ресурсы = " ;

" Если ТипЗадачи = 0 Тогда // Это задача // Запрос по ресурсам Command = Новый СОМОбъект("ADODB.Command");

Command.ActiveConnection = Connection;

Command.CommandText = "SELECT AssignmentUnits, AssignmentResourceName FROM Assignments WHERE AssignmentResourcelD > 0 AND TaskUniquelD = " + ИдентификаторЗадачи;

RecordSetResource = Новый СОМОбъект("ADODB.RecordSet");

RecordSetResource = Command.Execute();

// Перебор данных Пока RecordSetResource.EOF() = 0 Цикл ИмяРесурса = RecordSetResource.Fields("AssignmentResourceName"). Value;

ПроцентЗагрузки = RecordSetResource.Fields("AssignmentUnits"). Value * 100;

Ресурсы = Ресурсы + ?(Ресурсы="","",";

") + СокрЛП(ИмяРесурса) + " ( + ПроцентЗагрузки + "%)";

" RecordSetResource.MoveNext();

КонецЦикла;

, RecordSetResource.Close();

КонецЕсли;

СтрокаТП.Ресурсы = Ресурсы;

// Переход к следующей задачи RecordSet.MoveNext();

КонецЦикла;

RecordSet.Close();

КонецПроцедуры В данном примере подразумевается, что на форме обработки имеется эле мент — табличное поле с идентификатором табличноеполе. Это табличное поле имеет четыре созданных на форме текстовых поля:

О ид — скрытое поле, предназначенное для хранения идентификатора задачи;

Глава П задача — название задачи;

П датаНачала — запланированная дата начала выполнения задачи;

П датаКонца — запланированная дата окончания задачи;

П Ресурсы — строка, содержащая список используемых ресурсов и их за грузку.

Результат вывода дерева задач произвольного проекта показан на рис. 5.2.

i-r • Microsoft Project ADO Demo vl.0 © MAV 2004 _ПX Имя Файла: | C:\eitample.mpp j-^| OLEDB провайдер: [Microsoft.PrQiect.OLEDB.10. Дата начала : Дата окончания ^Ресурсы.

B-Deveioprnent 25.05.2004 9:00:00 20.07.2004 9:52: ф-Подготовительные действия 25.05.20049:00:00 03.06.200410:30: В-Разработка продукта 01.06.200416:44:59 20.07.20043:52: ^•••Техническая реализация 01.06.200416:44:59 20.07.20049:52: | Анализ списка требова... 01.06,200416:44:59 03.06.200414:24:06 Михайлов (1002);

Ко...;

| Разработка концептуал... 03.06.200414:24:06 06.06.20049:52:48 Михайлов (100%);

Ко... \ ' Разработатехническое, 06.06.20049:52:48 09.06.200415:22:48 Михайлов (100%}: Це...;

Разработка продукта 09.06.200415:22:48 06.07.200417:50:06 Центр разработок (1..J Тестирование 06.07.200417:50:06 13.07.200411:06:30 Центр разработок П..Л Ввод корректировок 13.07.200411:06:30 19.07.200415:22:54 Центр разработок (1...J Создание поставки 19.07.200415:22:54 20.07.20049:52:54 Михайлов (50^);

Цен... = И-Разработка коммерческих... 02.06.200410:30:00 07.06.200413:44: В-Технологическая подготовка 09.06.2004 15:22:48 16.06.200415:22: Подготовка методологии 09.06.200415:22:48 16.06.200415:22:48 Михайлов (100Х);

Це...;

Закрыть Выполнить Рис. 5.2. Результат вывода дерева задач проекта Помимо основных, ранее описанных таблиц (project, Tasks и Assignments), существуют и другие, не менее важные таблицы, подробное описание которых в данной книге приводиться не будет. Рассмотрим их состав и назначение.

П Availability — таблица обычно используется вместе с таблицей для по лучения сведений о доступности ресурсов.

П BaseiineTaskSpiits — в этой таблице сохраняются базовые сведения о прерывании для конкретной задачи.

П caiendarData и caiendarExceptions — в этих таблицах хранятся все кален дарные данные, имеющиеся в средстве доступа Microsoft Project OLE DB.

П Calendars — календари, используются для определения стандартного ра бочего и нерабочего времени. В проекте необходимо иметь один базовый Использование ADO календарь. У задач и ресурсов могут быть свои собственные календари, но все они должны строиться на основе базового календаря. В этой таб лице хранятся основные календарные данные.

П CostRates — таблица обычно используется вместе с таблицей Resources для отображения содержимого таблиц норм затрат, относящихся к ресур су. Кроме того, данную таблицу можно использовать совместно с табли цей Assignments для получения сведений о таблице норм затрат, исполь зуемой назначением.

П CustomFieidGraphicaiindicators — таблица обычно используется вместе с таблицей CustomFieids для получения параметров настраиваемых по лей, для которых предусмотрены графические индикаторы.

П CustomFieids (настраиваемые поля) — данная таблица используется для получения всех параметров настраиваемого поля. Для изменения этих полей необходимо извлечь глобальный корпоративный шаблон.

П CustomFieidVaiueList — эта таблица используется для получения значе ний таблицы подстановок для настраиваемых полей, имеющих список значений.

О CustomOutlineCodeFieids (поля кодов структуры) — в этой таблице со держится маска для каждой таблицы подстановки настраиваемого кода структуры.

П GustomOutiineCodeLookupTabies (таблицы подстановки) — таблица дан ного типа используется для получения списка значений таблиц подста новки, связанных с полями настраиваемых кодов структуры.

П Predecessors (предшественники) — таблица обычно используется вместе с таблицей Tasks для отображения подробных сведений о задачах предшественниках.

П Resources — в этой таблице содержатся сведения, относящиеся к ресурсам.

П Successors — таблица обычно используется вместе с таблицей Tasks для отображения подробных сведений о задачах-последователях.

П TaskSpiits — в этой таблице хранятся даты начала и окончания преры вания задачи.

П WBS (структурная декомпозиция работ) — в этой таблице хранятся опре деления кода СДР, а также параметры кода СДР для проекта.

8 Зак. Глава Использование SQL-DMO Понятие SQL-DMO SQL-DMO (SQL Distributed Management Objects) — это предоставляемая Microsoft SQL Server объектная модель, которая основана на СОМ-техно логии.

SQL-DMO скрывает детали структуры языка Transact-SQL и используется при написании административных приложений и сценариев для Microsoft SQL Server. Поставляемые с Microsoft SQL Server графические средства ад министрирования написаны с применением именно SQL-DMO, которая не является моделью интерфейса данных и не применяется для написания стандартных приложений баз данных.

SQL-DMO позволяет клиентскому приложению манипулировать такими объектами базы данных, как таблицы, процедуры и свойства сервера через интерфейс СОМ. Модель предоставляет приложению следующие возможности:

П управление таблицами (просмотр, создание, удаление, модификация);

П управление списком доступных серверов;

О управление правами доступа к серверам;

G управление списком баз данных на каждом сервере;

П управление сценариями таблиц базы данных;

П создание SQL-скриптов (таблиц, представлений, хранимых процедур, пользователей и их ролей);

П выполнение SQL-запросов.

Для того чтобы объекты SQL-DMO можно было использовать на конкрет ном компьютере, необходимо установить на нем клиентскую часть Microsoft SQL Server, который устанавливает библиотеку Microsoft SQL OLE Object Library. Данная библиотека представляет собой ActiveX-интерфейс к объек там SQL-DMO. Посредством SQL-DMO можно получать данные из таблиц SQL Server.

228 Глава.

Особенно эффективно данную модель могут применять разработчики, ис пользующие Microsoft SQL Server Desktop Engine (MSDE), который постав ляется вместе с Access 2000. Этот сервер баз данных представляет собой промежуточный вариант SQL Server и был создан специально для сопряже ния с более ранними версиями SQL Server. Хотя MSDE обладает меньшими возможностями, чем SQL Server, он поставляется бесплатно в составе Microsoft Office 2000. Однако версия MSDE, которая поставляется вместе с Microsoft Office 2000, не включает Enterprise Manager. В результате пользо ватели MSDE не могут оценить все преимущества графического интерфейса при управлении объектами базы данных.

В этой главе будут рассмотрены некоторые подходы к организации работы с объектами SQL Server (далее — SQL-сервер) при помощи SQL-DMO.

Получение списка доступных серверов Для получения атрибутов SQL-сервера предназначен объект SQLDMO. SQLServera.

В листинге 6.1 приведен пример вывода списка доступных серверов.

списка доступных серверов Попытка // Создаем объект SQLServer // SQLServer2 - предназначен для получения атрибутов MS SQL Server oSQLServer2 = СоздатьОбъект("SQLDMO.SQLServer2");

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

oSQLServer2.LoginTimeout = 10;

oSQLServer2.ODBCPrefix = 0;

// Вывод имен общих SQL-серверов ServerNameList = oSQLServer2.Application.ListAvailableSQLServers();

Для Ном = 1 По ServerNameList.Count Цикл Сообщить(ServerNameList.Item(HoM));

КонецЦикла;

// Вывод локальных общих SQL-серверов InstanceNameList = oSQLServer2.Listlnstalledlnstances();

Использование SQL-DMO Для Ном = 1 По InstanceNameList.Count Цикл Сообщить(InstanceNameList.Item(Ном)) ;

КонецЦикла;

В приведенном примере свойство oSQLServera. LoginTimeout предназначено для определения числа секунд, во время которого будут происходить попыт ки подключиться. Свойство oSQLServera.ODBCPrefix управляет выводом ошибок.

Перечисление спецификаций баз данных Для того чтобы работать с объектами SQL-DMO, необходимо подключиться к выбранному серверу (листинг 6.2).

// Создаем экземпляр объекта сервера и подсоединиться к нему SQLServer = СоздатьОбъект("SQLDMO.SQLServer");

SQLServer.LoginTimeout = -1;

Попытка Если ИспользоватьЫТАвторизацию = 1 Тогда // Использовать авторизацию WinNT SQLServer.LoginSecure = 1;

// При разрыве соединения - автоматически повторно не соединяться SQLServer.AutoReConnect = 0;

// Подключение к серверу SQLServer.Connect(ИмяСервера);

Иначе // Использовать SQL Server авторизацию SQLServer.LoginSecure = 0;

// При разрыве соединения - автоматически повторно не соединяться SQLServer.AutoReConnect = 0;

// Подключиться с использованием SQL Security SQLServer.Connect(ИмяСервера, СокрЛП(Пользователь), СокрЛП(Пароль));

КонецЕсли;

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

230 Глава В приведенном примере после объявления объекта SQLServer, из библиоте ки SQL-DMO, программа генерирует экземпляр этого объекта и подсоеди няет его к серверу ИмяСервера. В листинге 6.2 приведена программа, реали зующая два варианта подключения к SQL-серверу — с помощью NT авторизации, и без нее. Для соединения с SQL-сервером используется метод connect, в который передается имя сервера, а в случае подключения с по мощью SQL Security, еще имя и пароль пользователя. Как правило, при разработке с применением SQL-DMO необходимо пользоваться именем пользователя и паролем, которые предоставляют широкие полномочия, по скольку SQL-DMO используется для программирования административных функций.

При определении времени подключения к серверу в свойстве SQLServer.LoginTimeout установлено значение -1, которое обозначает стан дартное время завершения по истечении 60 секунд.

После того как произошло соединение, можно вывести спецификации всех существующих на сервере баз данных (листинг 6.3).

Листинг 6.3. Перечисление спецификаций баз данных Для iCount = 1 По SQLServer.Databases.Count Цикл // Выводим только НЕ системные БД Если SQLServer.Databases.Item(iCount).SystemObject = 0 Тогда ВазаДанных = SQLServer.Databases.Item(iCount);

Сообщить("База данных:" + БазаДанных.Name);

Сообщить("Дата создания:" + БазаДанных.CreateDate);

Сообщить("Количество таблиц:" + БазаДанных.Tables.Count);

Сообщить("Количество представлений:" + БазаДанных.Views.Count);

Сообщить("Количество процедур:" + БазаДанных.StoredProcedures.Count);

КонецЕсли;

КонецЦикла;

Приведенный код выводит список, в котором для каждой базы данных ука зывается дата ее создания, а также количество имеющихся в ней таблиц, представлений и хранимых процедур. После подключения к SQL-серверу в цикле примера просматриваются все базы данных и выводится сводная информация о них.

Получение списка таблиц и спецификаций полей Чтобы получить доступ к спецификации каждой таблицы базы данных, необходимо создать объект SQLDMO.Tabie, который позволяет манипулиро Использование SQL-DMO вать со структурой конкретной таблицы. Элементы типа Table содержатся в коллекции Database.Tables. Для того чтобы перебрать все элементы кол лекции, существует два способа. Первый — в цикле, с помощью метода item, получать элементы коллекции, указывая в параметре порядковый но мер таблицы (листинг 6.4). Свойство Database.Tables.Count возвращает количество таблиц в базе данных. Второй — с помощью конструкции для каждого...из...Цикл...конецЦикла, которую можно использовать только в вер сии 8.0 системы "1С:Предприятие".

// Объект базы данных Database = СоздатьОбъект("SQLDMO.Database");

Database = SQLServer.Databases(ИмяБазыДаных);

Для Ном = 1 По Database.Tables.Count Цикл // Выводим только НЕ системные таблицы Если Database.Tables.Item(Ном).SystemObject = 0 Тогда Сообщить(Database.Tables.Item(Ном).Name);

КонецЕсли;

КонецЦикла;

В программном коде, показанном в листинге 6.4, выводятся имена всех таб лиц базы данных. С помощью свойства Systemobject объекта Table отсека ются системные таблицы.

Зная имена таблиц, можно получить спецификацию каждого ее поля — имя, тип, длина поля, признак первичного ключа, признак возможности содер жать пустые значения. Для этих целей у объекта Table существует коллек ция columns, которая содержит сведения о каждом поле таблицы.

Рассмотрим пример, в котором, помимо имен таблиц, выводятся названия полей и их спецификация (листинг 6.5).

дификации полей табг // Объект базы данных Database = СоздатьОбъект("SQLDMO.Database");

Database = SQLServer.Databases(ИмяБазыДаных);

// Объект таблица Table = СоздатьОбъект("SQLDMO.Table");

232 Глава Для Ном = 1 По Database.Tables.Count Цикл // Выводим только НЕ системные таблицы Если Database.Tables.Item(Ном).SystemObject = 0 Тогда // Выводим имя таблицы ИмяТаблицы = Database.Tables.Item(HoM).Name;

Сообщить("Имя таблицы:" + ИмяТаблицы);

Table = Database.Tables(ИмяТаблицы);

// Цикл по полям Для НомерПоля = 1 По Table.Columns.Count Цикл Column = Table.Columns.Item(НомерПоля);

Сообщить("Имя поля: " + Column.Name);

Сообщить("Тип данных: " + Column.DataType);

Сообщить("Длина данных: " + Column.Length);

Сообщить("Это первичный ключ: " + ?(Column.InPrimaryKey = -1, " а, "Нет"));

Д" Сообщить("Может принимать пустые значения: " + ?

(Column.AllowNulls = -1, "Да", "Нет"));

КонецЦикла;

КонецЕсли;

КонецЦикла;

Листинг 6.5 демонстрирует, как производится выборка элементов коллекции таблиц Tables внутри базы данных. Объекты Table, в свою очередь, обладают иерархически организованными коллекциями объектов и отдельными объек тами. Каждая таблица обязательно имеет коллекцию столбцов Columns, но у любой таблицы может иметься единственный объект PrimaryKey, соответст вующий первичному ключу. Коллекция Keys ключей таблицы содержит ссыл ки на все ограничения первичного ключа таблицы и внешних ее ключей.

Объект Column имеет следующие основные свойства:

П Name — ИМЯ ПОЛЯ;

П DataType — строковое представление типа значений для поля (например, varchar, int И Т. П.);

П Length — максимально допустимая длина значения;

П InPrimaryKey — признак первичного ключа (-1 — обозначает, что данное поле является первичным ключом, о — нет);

П AllowNulls — признак возможности содержать пустые значения (-1 — поле может принимать пустые значения, о — не может).

Использование SQL-ОЛЮ Получение списка представлений С помощью коллекции views объекта Database можно получить доступ к представлениям, которые определены в базе данных. Для обхода элемен тов коллекции views можно воспользоваться все тем же свойством count, которое возвращает общее количество представлений, и методом item, ко торый получает объект view (представление) по его номеру (листинг 6.6). Так же допустим просмотр элементов коллекции с помощью конструкции Для каждого...из...Цикл...КонецЦикла.

// Объект базы данных Database = СоздатьОбъект("SQLDMO.Database");

Database = SQLServer.Databases(ИмяВазыДаных);

Для Ном = 1 По Database.Views.Count Цикл // Выводим только НЕ системные представления Если Database.Views.Itern(Ном).SystemObject = 0 Тогда Сообщить(Database.Views.Item(HoM).Name);

КонецЕсли;

КонецЦикла;

Данный пример выводит список имен всех представлений базы данных.

Получение списка хранимых процедур Получение списка хранимых процедур производится методом аналогичным тому, который использовался и для таблиц. Исключением здесь является то, что коллекция, которая содержит элементы свойств хранимых процедур, называется storedProcedures (листинг 6.7).

// Объект базы данных Database = СоздатьОбъект("SQLDMO.Database");

Database = SQLServer.Databases(ИмяБазыДаных);

Для Ном = 1 По Database.StoredProcedures.Count Цикл // Выводим только НЕ системные процедуры О Тогда Если Database.StoredProcedures.Item(Ном).SystemObject 234 Глава // Выводим имя хранимой процедуры Сообщить(Database.StoredProcedures.Itern(Ном).Name);

КонецЕсли;

КонецЦикла;

Изменение структуры баз данных Создание и удаление баз данных Для добавления новой базы данных на SQL-сервер предназначен все тот же объект SQLDMO.Database. При этом затрагиваются еще два дополнительных объекта:

П SQLDMO.DBFile — объект физического файла базы данных;

П SQLDMO.LogFile — объект физического файла транзакций.

Для регистрации новой базы данных на сервере необходимо сначала создать физический файл базы данных и файл транзакции.

Рассмотрим пример создания новой базы данных с именем NewDB (лис тинг 6.8).

// Объект базы данных Database = СоздатьОбъект("SQLDMO.Database");

// Объект файла базы данных DBFileData = СоздатьОбъект("SQLDMO.DBFile");

// Объект файла транзакций LogFile = СоздатьОбъект("SQLDMO.LogFile");

// Имя новой БД ИмяНовойБазыДанных = "NewDB";

// Установить имя новой БД Database.Name = ИмяНовойБазыДанных;

// Определяем свойства файла БД DBFileData.Name = ИмяНовойБазыДанных;

DBFileData.PhysicalName = SQLServer.Registry.SQLDataRoot + "\DATA\" + ИмяНовойБазыДанных + ".mdf";

Использование SQL-DMO DBFileData.PrimaryFile = 1;

DBFileData.Size = 2;

DBFileData.FileGrowth = 1;

// Добавим файл базы данных Database.FileGroups("PRIMARY").DBFiles.Add(DBFileData);

// Определяем свойства файла транзакций LogFile.Name = ИмяНовойБазыДанных + "Log";

LogFile.PhysicalName = SQLServer.Registry.SQLDataRoot + "\DATA\" + LogFile.Name + ".Idf";

LogFile.Size = 2;

// Добавим файл транзакций базы данных Database.TransactionLog.LogFiles.Add(LogFile);

// Создадим БД Попытка SQLServer.Databases.Add(Database);

Исключение Сообщить(ОписаниеОшибки());

Возврат;

КонецПопытки;

Из приведенного выше кода видно, что сначала создаются объекты базы данных Database, физического файла DBFiieData и файла транзакций LogFile. Затем, С ПОМОЩЬЮ СВОЙСТВ Database. FileGroups ("PRIMARY").DBFiles И Database.TransactionLog. LogFiles, добавляются соответственно объекты файла базы данных и файла транзакций. Только после этого база данных регистрируется на сервере.

Рассмотрим основные свойства объекта DBFile.

О Name — имя файла.

П PhysicalName — физическое местонахождение файла.

П PrimaryFile — признак основного файла базы данных.

П s i z e — начальный размер файла в мегабайтах (необязательное свойство).

П FileGrowth — признак, определяющий, что необходимо хранить в базе данных (таблицу, индекс, или регистрационные данные).

Рассмотрим основные свойства объекта LogFile.

П Name — ИМЯ файла.

Глава 238 Глава Попытка Database.Tables(ИмяТаблицы).Remove();

Исключение КонецПопытки;

// Добавляем новую таблицу Database.Tables.Add(Table);

Pages:     | 1 | 2 || 4 | 5 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.