WWW.DISSERS.RU

БЕСПЛАТНАЯ ЭЛЕКТРОННАЯ БИБЛИОТЕКА

   Добро пожаловать!

Pages:     | 1 || 3 | 4 |   ...   | 5 |

«Электронная библиотека “Либрус” ( ) Научно-техническая библиотека электронных книг. Первоначально задуманная как хранилище компьютерной литературы, в настоящий момент библиотека содержит книжные издания по ...»

-- [ Страница 2 ] --

Администрирование Windows средствами WMI Определение разрешения экрана Для определения разрешения экрана используются свойства ScreenWidth (ширина) И ScreenHeight (высота) класса Win32_DesktopMonitor (ЛИС ТИНГ 2.20).

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2".

Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_DesktopMonitor");

Для каждого Item Из Items Цикл Сообщить("Разрешение: " + Item.ScreenWidth + " x " + Item.ScreenHeight);

КонецПикла;

Список элементов автозагрузки Для определения списка программ, которые загружаются при запуске опе рационной системы Windows, предназначен класс win32_startupcommand (листинг 2.21).

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_StartupCommand");

Для каждого Item Из Items Цикл Сообщить("Команда: " + Itern.Command);

Сообщить("Описание: " + Item.Description);

Сообщить("Путь: " + Item.Location);

Сообщить("Имя: " + Item.Name);

Сообщить("Пользователь: " + Item.User);

КонецЦикла;

Активизация копии Windows XP/Server Для активации операционной системы Windows XP или Windows Server используется метод ActivateOnline () класса Win32_WindowsProductActivation (листинг 2.22).

78 Глава ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2' Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_WindowsProductActivation");

Для каждого Item Из Items Цикл Item.ActivateOnline();

КонецЦикла;

Просмотр учетных записей и доменов Для работы с учетными записями и доменами обычно используются сле дующие классы:

О win32_ComputerSystem — содержит системную информацию компьютера;

П win32_Group — содержит данные о пользовательских группах;

О win32_Account — содержит данные о группах и пользователях системы.

Рассмотрим основные свойства класса win32_ComputerSystem:

П Description — описание объекта;

О Domain — имя домена, в котором зарегистрирован компьютер;

П DomainRole — роль компьютера;

П inf raredSupported — признак поддержки работы с инфракрасным портом;

П Manufacturer — производитель компьютера;

П Model — название компьютера;

П NumberOfProcessors — количество процессоров;

П userName — имя пользователя, работающего в настоящее время с системой;

П workgroup — имя рабочей группы.

Класс Win32_ComputerSystem имеет важный метод Rename (строка), который может изменять сетевое имя компьютера. Метод имеет один параметр — строка, содержащий новое имя компьютера.

Так как классы win32_Group и win32_Account довольно простые, поэтому подробно они рассматриваться не будут.

Определение домена компьютера Для определения домена, в котором находится компьютер, необходимо про читать СВОЙСТВО Domain класса Win32_ComputerSystem (ЛИСТИНГ 2.23).

Администрирование Windows средствами WMI ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Computers = ServicesSet.ExecQuery("Select * from Win32_ComputerSystem");

Для каждого Computer Из Computers Цикл Сообщить("Имя: " + Computer.Name);

Сообщить("Домен: " + Computer.Domain);

КонецЦикла;

Для определения домена так же можно использовать свойство DNSDomain класса Win32_NetworkAdapterConfiguration.

Определение роли компьютера Для определения роли компьютера, т. е. является ли компьютер сервером или рабочей станцией, используется свойство DomainRoie класса win32_computersystem. Данное свойство может возвращать одно из следую щих значений:

П о — самостоятельная рабочая станция (Standalone Workstation);

П 1 — член рабочей станции (Member Workstation);

П 2 — самостоятельный сервер (Standalone Server);

П з — рядовой сервер, т. е. сервер, не имеющий статуса контроллера в кон кретном домене (Member Server);

П 4 — резервный контроллер домена, т. е. компьютер в домене Windows NT, который содержит копию политики безопасности домена и его базы данных, а также служит резервом на случай, если главный контроллер домена недоступен (Backup Domain Controller);

П 5 — главный контроллер домена, т. е. компьютер в домене, который хра нит главную копию базы данных учетных записей домена, проводит аутентификацию пользователей, а также может работать как файл-сервер, принт-сервер и сервер приложений (Primary Domain Controller).

Пример определения сетевой роли компьютера показан в листинге 2.24.

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Computers = ServicesSet.ExecQuery("Select * from Win32_ComputerSystem");

Для каждого Computer Из Computers Цикл 80 Глава Массив = Новый Массив();

Массив.Добавить("Standalone Workstation");

Массив.Добавить("Member Workstationn");

Массив.Добавить("Standalone Server");

Массив.Добавить("Member Server");

Массив.Добавить("Backup Domain Controller");

Массив.Добавить("Primary Domain Controller");

Сообщить("Роль компьютера: " + Массив[Computer.DomainRole]);

КонецЦикла;

Определение имени текущего пользователя Для определения имени пользователя, который в настоящее время подключен К компьютеру, используется СВОЙСТВО UserName класса Win32_ComputerSystem (листинг 2.25).

j Листинг 2.25. Определение имени текущего пользователя ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Computers = ServicesSet.ExecQuery("Select * from Win32_ComputerSystem");

Для каждого Computer Из Computers Цикл Сообщить("Пользователь: " + Computer.UserName);

КонецЦикла;

Определение локальных групп компьютера Для определения только локальных групп компьютера используется класс Win32_Group С условием, ЧТО СВОЙСТВО LocalAccount равно True (Истина).

Пример определения локальных групп приведен в листинге 2.26.

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQueryt"Select * from Win32_Group Where LocalAccount = True");

Для каждого Item Из Items Цикл Сообщить("Локальная запись: " + Item.LocalAccount);

Администрирование Windows средствами WMI Сообщить ("Имя группы: " + Item.Name) ;

Сообщить("Идентификатор: " + Item.SID);

Сообщить("Тип: " + Itera.SIDType);

Сообщить("Статус: " + Item.Status);

КонецЦикла;

Определение списка пользователей и групп Для получения полного списка пользователей и групп используется класс win32_Account. Данный класс имеет свойство зютуре, которое может при нимать следующие значения:

П 1 — если объект представляет свойства пользователя;

О 2 — группы пользователей;

П з — домена;

П 4 — псевдонима;

П 5 — общие группы;

П б — удаленной учетной записи;

П 7 — ошибочной учетной записи;

П 8 — неизвестной учетной записи;

П 9 — компьютера.

Ниже приведен пример вывода только пользователей и групп (листинг 2.27).

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.InstancesOf("Win32_Account");

Для каждого Item Из Items Цикл Если Item.SIDType = 1 Тогда Сообщить("Пользователь: " + Item.Caption);

ИначеЕсли (Item.SIDType = 2) или (Item.SIDType = 4) или (Item.SIDType = 5) Тогда Сообщить("Группа: " + Item.Caption);

КонецЕсли;

КонецЦикла;

Важно отметить, что объекты данного класса имеют разные наборы свойств в зависимости от значения свойства зютуре.

82_ Глава Работа с системной датой и временем Для работы с датой и временем в WMI используется класс win32_LocaiTime.

Подробно останавливаться на нем не будем, т. к. он довольно простой.

Определение даты и времени Приведем пример определения даты и времени, установленные на конкрет ном компьютере с помощью класса win32_LocaiTime (листинг 2.28).

! Листинг 2.28. Определение даты и времени ( „'^^ _. ^ ^„„^^ iL— _„_„„—_— „—-. :_i.:.:_*_„ ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQueryf"Select * from Win32_LocalTime");

Для каждого Item Из Items Цикл Сообщить("День: " + Item.Day);

Сообщить("Месяц: " + Item.Month);

Сообщить("Год: " + Item.Year);

Сообщить("Час: " + Item. Hour);

Сообщить("Минута: " + Item.Minute);

Сообщить("Секунда: " + Item.Second);

КонецЦикла;

Определение временной зоны Для определения временной зоны, установленной на компьютере, использу ется класс win32_TimeZone (листинг 2.29). В данном классе имеется два свойства: для отображения имени временной зоны, соответствующей летне му Времени (DaylightName), И стандартное ИМЯ (standardName), которое СО ответствует временной зоне зимнего времени.

Класс win32_TimeZone имеет следующие свойства для определения данных летнего времени:

П DaylightName — ИМЯ Временной ЗОНЫ;

П DayiightDayOfWeek — день недели (i — воскресенье, 2 — понедельник и т. д., 7 — суббота);

П DaylightHour — час ДНЯ;

П DaylightMinute — Минута;

П DaylightSecond — секунда;

Администрирование Windows средствами WMI CJ DaylightDay — день;

CD DaylightMonth — месяц;

П DaylightYear — ГОД.

Для временной зоны зимнего времени существует такой же набор свойств, ТОЛЬКО префикс Daylight заменен на Standard.

ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQueryf"Select * from Win32_TimeZone");

Для каждого Item Из Items Цикл Сообщить("Временная зона (светлое время суток): " + Item.DaylightNaine);

Сообщить("Время: " + Item.DaylightHour + " " + Item.DaylightMinute + :

" " + Item.DaylightSecond) ;

:

Сообщить("Временная зона (стандартное имя): " + Item.StandardName);

Сообщить("Время: " + Item.StandardHour + " " + Item.StandardMinute + :

" " + Item.StandardSecond);

:

КонецЦикла;

Работа с журналами событий Для работы с журналами событий в WMI существуют два класса:

О win32_NTEventLogFiie — работа с файлами журналов событий;

CJ win32_NTLogEvent — просмотр записей журналов.

Класс win32_NTEventLogFiie имеет следующие свойства:

П compressed — признак сжатия файла журнала событий;

П compressionMethod — метод сжатия файла;

П Description — описание объекта;

О Drive — имя логического диска, на котором располагается файл;

П Encrypted — признак криптования файла;

П EncryptionMethod — метод криптования файла;

П FiieName — имя файла;

О Fiiesize — размер файла в байтах;

П NumberOfRecords — количество записей в журнале.

Класс win32_NTEventLogFiie имеет следующие методы:

П Copy (FiieName) — копирует файл журнала в имя, указанное в параметре FiieName;

84 Глава О Rename (FiieName) — переименовывает файл журнала. Новое имя файла задается в параметре FiieName;

О Delete ( ) — удаляет файл журнала;

П compress о — сжимает (архивирует) файл;

П Uncompress о — разархивирует файл журнала;

П ciearEventLog ( ) — очистка записей журнала.

Свойства класса win32_NTLogEvent рассматриваться не будет, т. к. их до вольно немного и все предназначены только для просмотра журнала собы тий. Пример просмотра журнала событий показан в листинге 2.32.

Получение информации о журнале событий Приведем пример просмотра количества записей журнала "System", макси мально допустимого размера и имени файла (листинг 2.30).

гт~" 7 г ~" т -—— г" ^1"1!Э1^г""~~~" : ~ ™ " ^ ---—-.- т :

ие информации о журнале событий ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_NTEventLogFile where LogFileName='System" 1 ) ;

Для каждого Item Из Items Цикл Сообщить("Количество записей в журнале: " + Item.NumberOfRecords);

Сообщить("Максимальный размер файла: " + Item.MaxFileSize) ;

Сообщить("Имя файла журнала: " + Item.Name);

КонецЦикла;

В запросе данного кода происходит фильтрация объектов по условию — ме тод LogFiieName (имя журнала) равен строке 'system'.

Копирование и очистка журнала Иногда бывает необходимо сделать копию журнала событий, после чего очистить его. Для этих целей предназначены методы сору и ciearEventLog класса Win32_NTEventLogFile (ЛИСТИНГ 2.31).

I Листинг 2.31. Копирование и очистка журнала событий ServicesSet = Locator.ConnectServer(ИмяКомпьютера, "root\cimv2".

Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_NTEventLogFile where Администрирование Windows средствами WMI LogFileName='Application'");

Для каждого Item Из Items Цикл Item.Copy("с:\application.evt");

// Копирование журнала Item.ClearEventLogO;

// Очистка журнала от записей КонецЦикла;

Просмотр записей журнала Для просмотра записей журнала используется класс win32_NTLogEvent.

Приведем пример просмотра записей журнала "System" (листинг 2.32).

ServicesSet - Locator.ConnectServer(ИмяКомпьютера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from Win32_NTLogEvent where Logfile='System"1 );

Для каждого Item Из Items Цикл Сообщить("Category: " + Item.Category);

Сообщить("ComputerName: " + Item.ComputerName);

Сообщить("Message: " + Item.Message);

Сообщить("RecordNumber: " + Item.RecordNumber);

Сообщить("TimeWritten: " + Item.TimeWritten);

Сообщить("User: " + Item.User);

Сообщить (" ") ;

КонецЦикла;

Работа с файлами и папками Для работы с файлами обычно применяется класс ciM_DataFiie. Основные свойства класса:

П Name — полное имя файла;

П Path — путь к файлу;

П Archive — признак архивного файла;

П system — признак системного файла;

П compressed — признак сжатого файла;

П Drive — символ (идентификатор) логического диска, на котором записан файл;

86 Глава О Extension — расширение файла;

П FileSize — размер файла;

П EightDotThreeFiieName — DOS-совместимое имя файла (например, c:\progra~l).

Основные методы класса:

О Compress о — сжимает файл;

П Copy(FileName) — копирует файл (новое имя файла определяется пара метром FileName);

П Delete о — удаляет файл;

О Rename (FileName) — переименовывает файл (новое имя файла определя ется параметром FileName).

В листингах 2.33 и 2.34 приведены примеры работы со свойствами и мето дами данного класса.

Переименование файлов Приведем пример переименования файла ReadMe.txt, который находится в папке c:\Program Files\lCv77 (листинг 2.33).

| Листинг 2.33. Переименование файлов ServicesSet = ПолучитьСОМОбъект("winmgmts:!\\" + ИмяКомпьютера + "\root\cimv2");

Items = ServicesSet.ExecQuery("Select * from Cim_Datafile where Name 'c:\\Program Files\\lCv77\\ReadNe.txt'");

Для каждого Item Из Items Цикл Результат = Item.Rename("с:\\Program Files\\lCv77\\ReadMe.bak");

КонецЦикла;

Поиск всех файлов по расширению Для того чтобы найти все файлы пользователя по расширению, использует ся запрос к классу ciM_DataFiie с условием по расширению (свойство Extension). Пример поиска всех файлов с расширением МРЗ приведен в листинге 2.34.

f.,. „_,..„,,....».„_.. _ „_| | Листинг 2.34. Поиск всех файлов по расширению ServicesSet = Locator.ConnectServer(ИмяКомпыотера, "root\cimv2", Пользователь, Пароль);

Items = ServicesSet.ExecQuery("Select * from CIM_DataFile where Extension = 'mp3'");

Администрирование Windows средствами WMI Для каждого Item Из Items Цикл Сообщить("Имя файла: " + Item.Name);

КонецЦикла;

Открытие общего доступа к папке Для управления доступом к папкам в WMI используется класс win32_share.

Для создания доступа к папке предназначен метод Create, который имеет следующие параметры:

П Path — путь к папке;

П Name — имя общего ресурса;

П туре — тип общего ресурса (о — папка или диск, i — принтер, 2 — какое-либо устройство);

П махimumAilowed — максимальное количество подключений;

П Description — описание.

Для удаления доступа предназначен метод Delete без параметров.

Пример создания общего доступа к папке C:\Program Files приведен в лис тинге 2.35).

i Листинг 2.35. Открытие общего доступа к пап FILE_SHARE = 0;

MAXIMUM_CONNECTIONS = 25;

ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпыотера + "\root\cimv2");

NewShare = ServicesSet.Get("Win32_Share");

Попытка Результат = NewShare.Create("С:\Program Files", "Share4You", FILE_SHARE, MAXIMUM_CONNECTIONS, "Общий доступ.");

Исключение Сообщить("Ошибка. Невозможно открыть доступ.");

КонецПопытки;

Работа с принтерами Для работы с принтерами используется класс win32_printer.

Рассмотрим основные свойства данного класса:

О Name — имя принтера;

О Comment — комментарий к принтеру;

Глава П Default — признак принтера по умолчанию;

П Description — описание;

П DriverName — название драйвера принтера;

О Local — признак локального принтера;

П Network — признак сетевого принтера;

П shared — признак наличия общего доступа к принтеру;

О PortName — имя порта принтера;

П Printerstatus — текущий статус принтера (i — прочий, 2 — неизвест ный, з — ожидает, 4 — печатает, 5 — подготавливается, 6 — остановлен, 7 — выключен).

Класс win32_printer имеет следующие методы:

О AddPrinterConnection(Name) — добавить новый сетевой принтер с сете вым именем Name;

П setDefauitPrinter () — установить принтер по умолчанию;

П CancelAlUobs о — отменить все задания;

О Pause () — приостановить печать;

П Resume ( ) — возобновить печать;

О PrintTestPage о — распечатать тестовую страницу;

CJ RenamePrinter (NewPrinterName) — переименовать принтер (новое ИМЯ принтера задается в параметре NewPrinterName).

Добавление нового сетевого принтера Приведем пример добавления сетевого принтера с сетевым именем "\\OfficeServer\MainOfficePrinter" (листинг 2.36).

инг 2.36. Добавление нового сетевого принтег ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера + "\root\cimv2");

NewPrinter = ServicesSet.Get("Win32_Printer");

Попытка Результат = NewPrinter.AddPrinterConnection ("\\OfficeServer\MainOfficePrinter");

Исключение Сообщить("Ошибка. Невозможно добавить принтер.");

КонецПопытки;

Администрирование Windows средствами WMI Установка принтера по умолчанию Пример установки принтера по умолчанию приведен в листинге 2.37.

Г " """""Г™."""•-——--- — ---— i Листинг 2.37. Установка принтера по умолчанию ИмяПринтера = "MainOfficePrinter";

ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel= impersonate}!\\" + ИмяКомпыотера + "\root\cimv2");

Printers = ServicesSet.Get("Win32_Printer");

Items = ServicesSet.ExecQuery("Select * from Win32_Printer Where Name = ' + ИмяПринтера + " " ;

" ')' Для каждого Item Из Items Цикл Item.SetDefaultPrinter();

КонецЦикла;

В данном примере, в запросе, используется конструкция where для фильт рации объектов коллекции по имени (свойство Name).

Работа с заданиями планировщика Для работы с заданиями планировщика используется класс win32_scheduledjob.

Основные свойства данного класса определены на примере просмотра зада ний (листинг 2.38).

Класс win32_scheduiedJob имеет два метода.

О create — добавить задание. Метод имеет следующие параметры:

• Command — путь к программе, которая будет запускаться;

• startTime — время запуска в UTC-формате (Universal Time Coordinated — универсальное синхронизированное время), при этом общее представление формата можно записать в виде — "YYYYMMDDHHMMSS.MMMMMM(+-)OOO", где "YYYYMMDD" можно заменить на "********•• (например, дата "******** 123000.000000 420" означает запуск в 12:30 после полудня;

• RunRepeatedly — признак многократного выполнения;

• Daysofweek — день недели (1 — понедельник, 2 — вторник, 4 — среда, 8 — четверг, 16 — пятница, 32 — суббота, 64 — воскресенье);

• DaysOfMonth — число месяца;

• interactwithDesktop — признак взаимодействия с рабочим столом;

• Jobid — идентификационный номер задания.

О Delete () — удалить задание.

90 Глава Просмотр заданий в планировщике Рассмотрим пример просмотра всех заданий планировщика (листинг 2.38).

эосмотр задании в планировщике ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel= impersonate)!\\" + ИмяКомпьютера + "\root\cimv2");

Items = ServicesSet.ExecQuery("Select * from Win32_ScheduledJob");

Для каждого Item Из Items Цикл Сообщить("Заголовок: " + Item.Caption);

Сообщить("Команда: " + Item. Command) ;

Сообщить("День месяца: " + Item.DaysOfMonth);

Сообщить("День недели: " + Item.DaysOfWeek);

Сообщить("Описание: " + Item.Description);

Сообщить("Продолжительность: " + Item.ElapsedTime);

Сообщить("Дата инсталляции: " + Item.InstallDate);

Сообщить("Имя: " + Item.Name);

Сообщить("Оповещение: " + Item.Notify);

Сообщить("Приоритет: " + Item.Priority);

Сообщить("Время старта: " + Item.StartTime);

Сообщить("Статус: " + Item.Status);

Сообщить("===================—=========");

КонецЦикла;

Создание заданий Для создания задания используется метод create. Приведем пример ежеме сячного запуска программы "Блокнот" (notepad.exe) каждого второго числа месяца в 23:30 (листинг 2.39).

Перем Номер;

ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel= impersonate}!\\" + ИмяКомпьютера + "\root\cimv2");

ObjectSet = ПолучитьСОМОбъект("WinMgmts:Win32_ScheduledJob");

ObjectSet.Create("notepad.exe", "********123000.000000 420",True,1,2,True,Номер);

Сообщить("Заданию присвоен номер: " + Номер);

Администрирование Windows средствами WMI Работа с системным реестром Для работы с системным реестром предназначен класс stdRegProv, принад лежащий пространству имен root\default. Данный класс совсем не имеет свойств, все действия и значения ключей доступны только через методы.

П CreateKey(DefKey, SubKeyName) — создание нового ключа. Параметры метода могут принимать значения:

• DefKey — идентификатор корневого имени раздела, определяется зна чениями:

О 2147483648-HKEY_CLASSES_ROOT;

О 2147483649-HKEY_CURRENT_USER;

О 2147483650 - HKEY_LOCAL_MACHINE;

О 2147483651- HKEYJJSERS;

О 2147483653- HKEY_CURRENT_CONFIG;

О 2 1 4 7 4 8 3 6 5 4 - HKEY_DYN_DATA;

• SubKeyName — имя создаваемого ключа (раздела).

О DeieteKey(DefKey, SubKeyName) — удаление раздела. Параметры метода аналогичны Методу CreateKey.

П DeleteValue(DefKey, SubKeyName, ValueName) — удаление параметра.

Параметры DefKey и SubKeyName аналогичны параметрам метода create Кеу, параметр ValueName задает имя удаляемого параметра.

П GetDWORDValue(DefKey, SubKeyName, ValueName, Value) — Получение значения параметра типа DWORD. Параметры DefKey, SubKeyName и ValueName аналогичны параметрам метода DeleteValue. В параметр value возвраща ется значение ключа ValueName.

П GetStringValue(DefKey, SubKeyName, ValueName, Value) — Получение строкового параметра. Все параметры аналогичны параметрам метода GetDWORDValue.

О GetExpandedStringValue(DefKey, SubKeyName, ValueName, Value) получение значения расширяемого строкового параметра. Все параметры аналогичны параметрам метода Getstringvaiue.

П SetDWORDValue(DefKey, SubKeyName, ValueName, V a l u e ) — создание нового параметра типа DWORD. Здесь параметр value задает значение клю ча, остальные аналогичны параметрам метода Getstringvaiue.

П SetStringValue(DefKey, SubKeyName, ValueName, Value) — создание строкового параметра. Все параметры аналогичны параметрам метода SetDWORDValue.

Глава П SetExpandedStringValue(DefKey, SubKeyName, ValueName, Value) — создание параметра расширяемого строкового типа. Все параметры ана логичны параметрам метода setowoRovaiue.

Чтение значений ключей реестра Для чтения значений ключей реестра используются методы GetstringValue, GetExpandedStringValue И GetstringValue, В зависимости ОТ Типа значения параметра.

Рассмотрим пример чтения значения параметра с именем "HistoryBuf fersize", находящимся в разделе HKEY_CURRENT_USER\ Console (листинг 2.40).

Перем Значение;

HKEY_CURRENTJJSER = 2147483649;

ПутъККлючу = "Console";

ИмяПараметра = "HistoryBufferSize";

Reg = ПолучитьСОМОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера + "\root\default:StdRegProv");

Reg.GetDWORDValue(HKEY_CURRENT_USER, ПутьККлючу, ИмяПараметра, Значение);

Сообщить("Значение: " + Значение);

Создание нового раздела Приведем пример создания нового раздела с помощью класса StdRegProv (листинг 2.41).

а раздела HKEY_LOCAL_MACHINE = 2147483650;

Reg = ПолучитьСОМОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера + "\root\default:StdRegProv");

ПутьККлючу = "SOFTWARE\NewKey";

Reg.CreateKey(HKEY_LOCAL_MACHINE, ПутьККлючу);

В приведенном примере создается раздел HKEY_LOCAL_MACHINE\ SOFTWARE\ NewKey.

Администрирование Windows средствами WMI Создание нового параметра Рассмотрим пример создания нового параметра реестра (листинг 2.42).

В примере создается параметр "Форум для вопросов" со значением "http://forum.erpg.ru" в разделе HKEY_LOCAL_MACHINE\ SOFTWARE\ NewKey.

| ние нового параметра реестра HKEY_LOCAL_MACHINE = 2147483650;

ПутьККлючу = "SOFTWARE\NewKey";

Reg = ПолучитьСОМОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера + "\root\default:StdRegProv");

ИмяПараметра = "Форум для вопросов";

Значение = "http://forum.erpg.ru";

Reg.SetExpandedStringValue(HKEY_LOCAL_MACHINE, ПутьККлючу, ИмяПараметра, Значение);

Работа с сетью Для работы с сетью в WMI предназначены два основных класса:

Win32_NetworkAdapterConfiguration И Win32_NetworkAdapter. Перечислять все свойства и методы не имеет смысла, т. к. их огромное количество. Назначение многих очень специфичные и будут понятны только сетевым администраторам.

Рассмотрим только некоторые из них.

Отключение сетевого соединения Если вы используете протокол динамической конфигурации хоста (DHCP, Dynamic Host Configuration Protocol), то отключить сетевое соединение можно методом ReleaseDHCPLease класса Win32_NetworkAdapterConfiguration (листинг 2.43). Иначе, с помощью WMI, это выполнить невозможно. Для возобновления соединения используется метод RenewDHCPLease.

4ёние сетевого соединения ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel= impersonate}!\\" + ИмяКомпьютера + "\root\ci_mv2");

Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapterConfiguration Where IPEnabled = True");

Для каждого Item Из Items Цикл Item.ReleaseDHCPLease();

КонецЦикла;

94 Глава ^ Определение MAC- и IP-адресов Для определения IP'^aflpeca, который назначен данному сетевому компьюте ру, необходимо сначала определить его МАС-адрес, используя класс Win32_NetworkAdapter. А затем, ИСПОЛЬЗуя класс Win32_NetworkAdapterConfiguration, найти IP-адрес, соответствующий данному МАС-адресу. Пример реализации такого механизма поиска приведен в листинге 2.44.

Листинг 2.44. Определение MAC- и IP-адресов MACAddress = " ;

" ServicesSet = ПолучитьСОМОбъект("winmgmts:{impersonationLevel= impersonate}!\\" + ИмяКомпьютера + "\root\cimv2");

Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapter");

Для каждого Item Из Items Цикл MACAddress = Item.MACAddress;

КонецЦикла;

Если MACAddress о " Тогда " Сообщить("MAC адрес: " + MACAddress);

Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapterConfiguration");

Для каждого Item Из Items Цикл Если Item.MACAddress = MACAddress Тогда Для каждого IPAddress Из Item.IPAddress Цикл Сообщить("IP адрес: " + IPAddress);

КонецЦикла;

КонецЕсли;

КонецЦикла;

КонецЕсли;

Использование команды Ping Для проверки доступности адресата путем передачи ему специального сиг нала можно использовать программу ping.exe. Средствами WMI это можно сделать с помощью проверки значения свойства statusCode класса Win32_PingStatus (ЛИСТИНГ 2.45).

В качестве значения свойства Address, в запросе, может использоваться как имя компьютера (Hostname), так и IP-адрес.

Администрирование Windows средствами WMI зание команды Ping //IPAddress = "172.20.129.102";

// IP-адрес IPAddress = "MAVCOMP";

// Hostname ServicesSet = ПолучитьСОМОбъект("winmgmts:\\" + ИмяКомпьютера + "\root\cimv2");

Items = ServicesSet.ExecQuery("Select * From Win32_PingStatus where Address = ' + IPAddress + " " ;

" ') Для каждого Item Из Items Цикл Если (Item.StatusCode = NULL) или (Item. StatusCode <> 0) Тогда Сообщить("Компьютер не отвечает.");

Иначе Сообщить("Компьютер ответил.");

КонецЕсли;

КонецЦикла;

Глава Использование скриптов WSH Что такое WSH Windows Script Host (WSH) — это стандартный компонент операционной системы Windows, который позволяет без предварительной компиляции непосредственно в операционной системе запускать сценарии, написанные на любых языках, ибддерживающих технологию СОМ. Собственная объект ная модель WSH/ позволяет из сценариев работать с файловой системой, системным реестром, специальными папками и ярлыками Windows, ресур сами локальной сети, а также запускать процессы и контролировать ход их выполнения. Кроме этого, в самих сценариях WSH можно использовать лю бые серверы автоматизации (СОМ-объекты), зарегистрированные в системе.

^ Примечание WSH встроена в операционные системы Microsoft Windows 98/ME/NT/2000/XP/ Server 2003. Для Windows 95 Windows Script Host можно загрузить с сайта Microsoft — http://msdn.microsoft.com/scripting.

Объектная модель WSH Для того чтобы воспользоваться всеми возможностями, которые представля ет эта технология, нужно разобраться в ее структуре. Windows Script Host состоит из целого ряда объектов.

О wscript — это главный объект WSH, который содержит информацию о сервере сценариев WSH и позволяет создавать СОМ-объекты, выдавать сообщения в операционную систему, вводить данные с клавиатуры и т. п.

Так как данный объект позволяет выполнять все те базовые действия, ко торые без особых трудностей можно выполнить в среде "1С:Предприятие", то рассматривать этот объект в контексте данной книги будет не уместно.

4 Зак. 98 Глава П WshArguments, WshNamed И WshUnnamed — объекты, обеспечивающие ДОС туп к параметрам командной строки запущенного сценария Windows.

Данные объекты используются исключительно во время запуска скрип тов из операционной системы, поэтому их рассмотрение в рамках данной книги бессмысленно.

П wshshell — объект, который позволяет запускать независимые процессы, создавать ярлыки, работать с переменными среды, системным реестром и специальными папками Windows.

П wshSpeciaiFolders — объект, обеспечивающий доступ к специальным папкам Windows.

П wshshortout — объект, который обеспечивает работу с ярлыками Windows.

О wshurishortout — объект, предназначенный для работы с ярлыками се тевых ресурсов.

П wshEnvironment — объект, предназначенный для работы с переменными среды (для просмотра, изменения и удаления переменных среды).

О wshNetwork — объект, использующийся при работе с локальной сетью.

Он содержит сетевую информацию для локального компьютера, а также позволяет подключать сетевые диски и принтеры.

П wshScriptExec — объект, позволяющий запускать консольные приложе ния в качестве дочерних процессов. Обеспечивает контроль этих прило жений и доступ к их стандартным входным и выходным потокам.

П wshController — объект, управляющий запуском сценариев на удален ных машинах.

О wshRemote — объект, позволяющий управлять сценарием, запущенным на удаленной машине.

П wshRemoteError — объект, используемый для получения информации об ошибке, возникшей в результате выполнения сценария, запущенного на удаленной машине.

CJ FileSystemObject — дополнительный объект, обеспечивающий доступ к файловой системе компьютера.

Запуск произвольного VB-скрипта (VBS) В настоящее время очень распространены VB-скрипты, которые пришли на замену пакетным файлам (bat). Очень часто возникает необходимость в запуске того или иного скрипта из системы "1,С:Предприятие". Однако времени, а зачастую и возможности переводить код из одного языка про граммирования в другой, нет. Как раз для такой ситуации и используется Использование скриптов WSH дд СОМ-объект — Msscriptcontroi, который позволяет запустить произвольный скрипт из контекста "ЮПредприятия". Объект Msscriptcontroi не входит в объектную модель WSH, но часто применяется в "скриптовых" языках.

Рассмотрим пример запуска VB-скрипта и вывода его результата в окно со общений системы "1С:Предприятие" (листинг 3.1).

// Произвольный скрипт ТекстСкрипта = "Function VBSFunction(} I GetDefaultPrinter = vbNullString I Set objWMIService = GetObject(""winmgmts:"" & ""{impersonationLevel= impersonate}!\\.\root\cimv2"") I Set colInstalledPrinters = objWMIService.ExecQuery(""Select * from Win32_Printer"") I For Each objPrinter in colInstalledPrinters I If objPrinter.Attributes and 4 Then I VBSFunction=obj Printer.Name I Exit For I End If I Next I End Function";

// Создание объекта scrptCtrl = Новый СОМОбъект("MSScriptControl.ScriptControl");

scrptCtrl.Language="vbscript";

// Указание языка // Добавление исполняемого кода scrptctrl.Addcode(ЭлементыФормы.ПолеТекстовогоДокумента.ПолучитьТекст());

// Запуск функции по имени и вывод результата Сообщить(scrptCtrl.run("VBSFunction"));

На самом скрипте останавливаться не будем, т. к. это тема другой главы.

Здесь только следует отметить, что он возвращает имя принтера, используе мого в системе по умолчанию. Вообще в переменную ТекстСкрипта можно записать любую функцию на VB-скрипте, а потом выполнить эту функцию, выполнив метод run объекта Msscriptcontroi.ScriptControl с указанием имени запускаемой функции.

Примечание Рассмотренный выше код для версии 7.7 будет аналогичным, за исключением создания СОМ-объекта.

100 Глава Выполнение операций с файловой системой Для работы с файловой системой из сценариев WSH предназначен объект FileSystemObject. С помощью этого объекта можно выполнить следующие основные действия:

П создавать каталоги;

П создавать или открывать текстовые файлы;

П копировать или перемещать файлы и каталоги;

П удалять файлы и каталоги;

П создавать объекты Drive, Folder и File для доступа к конкретному дис ку, каталогу или файлу соответственно.

С помощью свойств объектов Drive, Folder и File можно получить деталь ную информацию о тех элементах файловой системы, с которыми они ассо циированы. Объекты Folder и File также предоставляют методы манипули рования файлами и каталогами (создание, удаление, копирование, перемещение);

эти методы в основном копируют соответствующие методы объекта FileSystemObject.

Кроме того, имеются три объекта-коллекции: Drives, Folders и Files. Кол лекция Drives содержит объекты Drive для всех имеющихся в системе дис ков, Folders — объекты Folder для всех подкаталогов заданного каталога, Files — объекты File для всех файлов, находящихся внутри определенного каталога.

Наконец, из сценария можно читать информацию текстовых файлов и запи сывать в них данные. Методы для этого предоставляет объект Textstream.

С помощью объекта FileSystemObject можно очень просто написать некое подобие файлового менеджера "Проводник". Рассмотрим основные опера ции с файловой системой.

Получение сведений о дисках Для получения сведений об определенном диске предназначен объект Drive. Данный объект позволяет получить информацию о типе файловой системы, метки тома, общем объеме и количестве свободного места и т. д.

Сам объект Drive создается с помощью метода GetDrive объекта FileSystemObject. Приведем пример вывода всех доступных свойств диска (листинг 3.2).

Использование скриптов WSH // Создаем массив типов дисков ТипыДисков = Новый Массив();

ТипыДисков.Добавить("Неизвестно");

ТипыДисков.Добавить("Съемный");

ТипыДисков.Добавить("Постоянный");

ТипыДисков.Добавить("Сетевой");

ТипыДисков.Добавить("CD-ROM");

ТипыДисков.Добавить("RAM-диск");

// Создаем объект FileSystemObject FS© = Новый СОМОбъект("Scripting.FileSystemObject");

// Получаем ссылку на объект Drive = FSO.GetDriveC'C") ;

// Выводим свойства диска Сообщить("Информация о диске С:");

Сообщить("Метка диска: " + Drive.VolumeName);

Сообщить("Размер диска: " + Drive.TotalSize/1024 + " Кбайт' Сообщить("Свободно: " + Drive.FreeSpace/1024 + " Кбайт");

Сообщить("Буква диска: " + Drive.DriveLetter);

Сообщить("Тип: " + ТипыДисков[Drive.DriveType]);

Сообщить("Файловая система: " + Drive.FileSystem);

Сообщить("Готов к чтению: " + Drive.IsReady);

Сообщить("Путь: " + Drive.Path);

Сообщить("Начальная папка: " + Drive.RootFolder);

Сообщить("Серийный номер: " + Drive.SerialNumber);

Сообщить("Сетевое имя: " + Drive.ShareName);

// Изменяем метку диска Drive.VolumeName = "www.erpg.ru";

Из всех используемых в коде свойств только VolumeName доступно как для чтения, так и для записи, т. е. с помощью этого свойства можно изменять метку диска.

102 Глава Получение сведений о папках и файлах Для получения сведений о папках и файлах используются объекты Folder.и File. Данные объекты позволяют определить дату создания или последнего обращения к папке или файлу, их размер, атрибуты и т. д. Сами объекты соз даются С ПОМОЩЬЮ методов GetFolder И GetFile объекта FileSystemObject.

Рассмотрим пример вывода всех доступных свойств папки (листинг 3.3).

// Функция возвращает строку с атрибутами файла File.

// Вызывается из основного кода при получении сведений о папке или файле Функция ВернутьАтрибутыФайла(File) Attr = ПереводИзЮ(File.Attributes, 2);

// Функция ПереводИзЮ переводит число из 10 системы счисления // в произвольную, в данном случае - двоичную.

Если Attr = 0 Тогда Возврат "Обычный";

КонецЕсли;

Стр = " ;

" Если (Сред(Attr,СтрДлина(Attr}-4,1) = "1") и (СтрДлина(Attr) > 4) Тогда Стр = Стр + "Папка " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr),1) = "1") и (СтрДлина(Attr) > 0) Тогда Стр = Стр + "Только чтение " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-!,!) = "1") и (СтрДлина(Attr) > 1) Тогда Стр = Стр + "Скрытый " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-2,1) = "1") и (СтрДлина(Attr) > 2) Тогда Стр = Стр + "Системный " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-3,1) = "1") и (СтрДлина(Attr) > 3) Тогда Стр = Стр + "Метка " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-5,1) = "1") и (СтрДлина(Attr) > 5) Тогда Стр = Стр + "Архивный " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-10,1) = "1") и (СтрДлина(Attr) > 10) Тогда Стр = Стр + "Синоним " КонецЕсли;

Если (Сред(Attr,СтрДлина(Attr)-11,1) = "1") и (СтрДлина(Attr) > 11) Тогда Стр = Стр + "Сжатый " КонецЕсли;

Использование скриптов WSH Возврат Стр;

КонецФункции // Основная часть кода.

// Создаем объект FileSystemObject FSO = Новый СОМОбъект("Scripting.FileSystemObject");

// Получаем ссылку на объект Folder = FSO.GetFolder ("с: \Program FilesV) ;

// Выводим свойства папки Сообщить("Информация о папке c:\Program FilesV );

Сообщить("Атрибуты: " + ВернутьАттрибутыФайла(Folder));

Сообщить("Дата создания: " + Folder.DateCreated);

Сообщить("Дата последнего доступа: " + Folder.DateLastAccessed);

Сообщить("Дата последнего изменения: " + Folder.DateLastModifled);

Сообщить("Признак корневой папки: " + Folder.IsRootFolder);

Сообщить("Имя: " + Folder.Name);

//!!

Сообщить("Родительская папка: " + Folder.ParentFolder);

Сообщить("Путь: " + Folder.Path);

Сообщить("Короткое имя: " + Folder.ShortName);

Сообщить("Короткий путь: " + Folder.ShortPath);

Сообщить("Размер: " + Folder.Size);

Сообщить("Доступ к дочерним папкам: " + Folder.SubFolders);

Сообщить("Туре: " + Folder.Type);

Объект File имеет подобный набор свойств.

Е^ Примечание Свойство Name доступно для записи, т. е. с помощью его можно переименовать файл или папку.

Отдельного внимания заслуживает свойство SubFolders, которое предостав ляет доступ к дочерним папкам. Данное свойство возвращает коллекцию Folders, которая содержит объекты Folder. Элементы коллекции системы "1С:Предприятие" в версии 8.0 можно получить с помощью конструкции Для каждого...из...Цикл...конецЦикла. Для версии 7.7 это можно сделать только с помощью внешней компоненты или СОМ-объекта (пример такого СОМ объекта был рассмотрен в главе 2).

Глава Проверка существования определенного диска, каталога или файла Для проверки существования определенного диска, каталога или файла предназначены методы DriveExists, FoiderExists и FileExists объекта FileSystemObject.

Данные методы возвращают Истина (в версии 7.7 метод возвращает -1), если диск, папка или файл, переданный в качестве параметров найден, иначе — ложь (в версии 7.7 метод возвращает 0).

Обычно данные методы применяются перед какими-либо действиями над дисками, файлами или папками, чтобы удостовериться, что они реально су ществуют и дальнейшая работа с ними не вызовет ошибок.

Приведем простой пример проверки наличия файла (листинг 3.4).

: Листинг 3.4. Проверка на наличие файла ИмяФайла = "c:\Program Files\lcv8\bin\lcv8.exe";

FSO = Новый СОМОбъект("Scripting.FileSystemObject");

Если FSO.FileExists(ИмяФайла) Тогда Сообщить("Файл существует!");

Иначе Сообщить("Файл не найден!");

КонецЕсли;

Копирование файлов и папок Для копирования файлов и папок предназначены методы copyFile и CopyFolder объекта FileSystemOb]ect, а также методы File.Copy И Folder.Copy.

Рассмотрим простой пример копирования файла и папки (листинг 3.5).

Листинг 3.5. Копирование < FSO = Новый СОМОбъект{"Scripting.FileSystemObject");

// Копирование файла FSO.CopyFile("с:\Program Files\lCv77\ReadMe.txt", "с:\");

// Копирование папки FSO.CopyFolder("c:\lc", "c:\2c");

Использование скриптов WSH Метод copyFiie имеет важную особенность — в качестве первого параметра можно задавать маску копируемых файлов. Например, чтобы скопировать все файлы с расширением doc, необходимо вызвать метод следующим обра зом: CopyFiie("с:\*.doc", " d : \ " ).

Перемещение файлов и папок Для перемещения файлов и папок предназначены методы Movefile и MoveFolder объекта FileSystemObject, ИЛИ МСТОДЫ File.Move И Folder.Move.

Рассмотрим пример перемещения файлов (листинг 3.6).

Листинг 3.6. Перемещение файлов FSO = Новый СОМОбъект("Scripting.FileSystemObject");

// Перемещение файлов FSO.MoveFile("c:\Program Files\lcv8\*.htm", "c:\");

В приведенном коде перемещаются все файлы с расширением htm.

Удаление файлов и папок Для удаления файлов и папок применяются методы DeieteFile и DeleteFolder объекта FileSystemObject, ИЛИ методы File.Delete И Folder.Delete.

Рассмотрим пример удаления файлов (листинг 3.7).

FSO = Новый СОМОбъект("Scripting.FileSystemObject");

// Удаление файлов FSO.DeleteFile("c:\*.htm");

Приведенный выше код осуществляет удаление всех файлов с расширением htm.

" Создание папок Для создания папок предназначены методы FileSystemObject.CreateFolder и Folders.Add. Перед созданием вложенной папки необходимо удостове 106 Глава риться, что существует папка верхнего уровня, иначе появится ошибка.

То есть данные методы не предназначены для создания группы вложенных папок.

Ниже приведен пример последовательного создания группы вложенных па пок (листинг 3.8).

FSO = Новый СОМОбъект("Scripting.FileSystemObject");

Корень = "c:\test\";

FSO.CreateFolder(Корень);

// Создаем группу папок Для Ном! = 1 По 5 Цикл FSO.CreateFolder(Корень + "folder" + Ном!);

Для Ном2 = 1 По 5 Цикл FSO.CreateFolder(Корень + "folder" + Ном! + "\subfolder" + Ном! + "_" + Ном2) ;

КонецЦикла;

КонецЦикла;

Работа с текстовыми файлами С помощью WSH можно создавать текстовые файлы. Для этого предусмот рены методы FileSystemObj ect. CreateTextFile И Folders. CreateTextFile.

Данные методы возвращают ссылку на объект Text stream и имеют три па раметра:

П Filename — ИМЯ файла;

О overwrite — признак замены существующего файла (параметр является не обязательным);

П Unicode — признак создания файла в формате Unicode, иначе создается в формате ANSI (параметр является не обязательным).

С помощью методов writeLine и WriteBiankLines полученного объекта Textstream можно добавлять строки в файл.

Рассмотрим пример создания файла в формате ANSI и записи в него несколь ких строк (листинг 3.9).

Использование скриптов WSH FSO = Новый СОМОбъект("Scripting.FileSystemObject") ;

// Получаем объект TextStream File = FSO.CreateTextFile("С:ХПример создания файла.txt", Истина, Ложь);

File.WriteLine("Дата создания: " + РабочаяДата);

File.WriteBlankLines(2);

// Добавляем 2 пустые строки File.WriteLine("Добро пожаловать на сайт автора: www.erpg.ru");

File.WriteLine("Copyright (С) Андрей Михайлов aka MAV 2004");

File.Close ();

В WSH нельзя создавать файлы, отличные от текстовых.

Для открытия текстового файла, с целью чтения, записи или добавления НОВЫХ записей, Предназначены методы FileSystemObject.OpenTextFile И File.openTextstream. Данные методы имеют ряд параметров.

П! Filename — ИМЯ файла.

П lomode — режим открытия файла. Параметр может принимать следующие значения:

• 1 — только для чтения;

• 2 — для записи;

• 8 — открытие файла и добавления строк в конец.

П Create — признак создания нового файла.

П Format — формат открываемого файла. Параметр может принимать сле дующие значения:

• -2 — используется формат, принятый по умолчанию в системе;

• -1 — Unicode;

• о - ASCII.

Для чтения всего текста из файла используется метод ReadAiK). Для по строчного чтения— ReadLineO. Рассмотрим пример открытия и чтения файла (листинг 3.10).

ИмяФайла = "С:ХПример создания файла.txt";

FSO = Новый COM06beKT("Scripting.FileSystemObject");

// Проверяем, существует ли необходимый файл на диске 108 Глава Если FSO.FileExists(ИмяФайла) Тогда File = FSO.OpenTextFile(ИмяФайла, 1, Ложь, 0);

Сообщить(File.ReadAll());

Иначе Сообщить("Файл не найден!");

КонецЕсли;

Получение списка всех доступных дисков, папок и файлов Для получения списка всех доступных дисков у объекта FileSystemObject суще ствует коллекция Drives, содержащаяся В свойстве FileSystemObject. Drives.

Для папок, в этом случае, имеется коллекция Folders, содержащаяся в свойстве Folder.SubFoiders. Для файлов— коллекция Files, содержа щаяся В свойстве Folder.Files.

Рассмотрим примеры вывода списка всех дисков (листинг 3.11) и списка всех файлов и папок (листинг 3.12).

FSO = Новый СОМОбъект("Scripting.FileSystemObject"} // Выборка объектов из коллекции Drives Для каждого Диск Из FSO.Drives Цикл Стр = flncK.DriveLetter;

Если flncK.DriveType = 3 Тогда Стр = Стр + " -." + flHCK.ShareName;

ИначеЕсли Диск.IsReady Тогда Стр = Стр + " - " + flncK.VolumeName;

Иначе Стр = Стр + " - [Диск не найден]";

КонецЕсли;

Сообщить(Стр);

КонецЦикла;

FSO = Новый СОМОбъект("Scripting.FileSystemObject") Folder = FSO.GetFolder("C:\");

// Выборка всех папок Использование скриптов WSH Ю Для каждого Папка Из Folder.SubFolders Цикл Сообщить("[" + ВРег(Папка.Name) + " " ;

]) КонецЦикла;

// Выборка всех файлов Для каждого Файл Из Folder.Files Цикл Сообщить(НРег(Файл.Name));

КонецЦикла;

В листинге 3.12 приведен пример вывода списка только папок и файлов од ного уровня, находящихся в корневом каталоге диска С:. Для построения дерева папок и файлов можно использовать данный пример, который дол жен находиться в функции, вызываемой рекурсивно.

Чтение свойств МРЗ-файлов Как уже было показано ранее, с помощью объекта FileSystemObject можно обращаться к файлам.

Рассмотрим следующую задачу. Допустим необходимо прочитать теги (IDvl) МРЗ-файла. Тегами обычно называют свойства МРЗ-файла, включающими в себя информацию об авторе, названии, размере файла и т. п. Для решения данной задачи необходимо выполнить следующие действия:

1. Создать объект FileSystemObject для доступа к файлам.

2. Проверить наличие необходимого файла на диске.

3. Получить ссылку на объект File с помощью метода GetFiie.

4. Прочитать размер файла с помощью метода F i l e. s i z e и проверить, что бы он был не менее 128 байт.

5. Открыть файл для чтения. Метод Fiie.openAsTextstream(i) возвращает объект Stream.

6. Получить строку, содержащую последние 128 байт, в которых и хранятся теги МРЗ-файла.

7. Проверить наличие в начале полученной строки символов "TAG".

8. Выделить из строки нужные теги согласно спецификации МРЗ-файлов.

Рассмотрим пример чтения тегов МРЗ-файла (листинг 3.13).

„„„-„ „ 3.13. Чтение тегов МРЗ-файлг // Переменная ИмяФайла должна содержать строку, содержащую путь к МРЗ-файлу Если (ИмяФайла = Неопределено) или СокрЛП(ИмяФайла = "") Тогда Сообщить("Не указано имя файла!");

110 Глава Возврат;

КонецЕсли;

// Создание объекта FileSystemObject Попытка FSO = Новый СОМОбъект("Scripting.FileSystemObject");

Исключение Сообщить("Ошибка создания объекта! ") ;

Возврат;

КонецПопытки;

// Проверка на наличие файла Если НЕ FSO.FileExists(Имяфайла) Тогда Сообщить("Файл не найден!");

Возврат;

КонецЕсли;

// Получаем размер файла и проверяем, чтоб он был не менее минимально допустимого File = FSO.GetFile(Имяфайла);

FileLength = File.Size;

Если FileLength <= 128 Тогда Сообщить("Файл малого размера!");

Возврат;

КонецЕсли;

// Открываем файл для чтения (параметр = 1) Попытка Stream = File.OpenAsTextStream(l);

Исключение Сообщить("Невозможно открыть файл!");

Возврат;

КонецПопытки;

// Считываем строку с информацией (IDSvl) Stream.Skip(FileLength - 128);

Попытка Data = Stream.Read(128);

Использование скриптов WSH Щ Исключение Сообщить("Невозможно прочитать файл!");

Возврат;

КонецПопытки;

// Закрываем поток и удаляем объекты Stream.Close() ;

File = Неопределено;

FSO = Неопределено;

// Проверяем полученную строку на корректность Если Лев(Data, 3) <> "TAG" Тогда Сообщить("Неверный формат файла! ") ;

Возврат;

КонецЕсли;

// Перечисляем все жанры, встречающиеся в спецификации к МРЗ-файлам Жанры = Новый Массив();

Жанры.Добавить("Blues");

Жанры.Добавить("Classic Rock");

// и т.д...

Жанры.Добавить("JPop");

Жанры.Добавить("Synth Pop");

// Выделяем из строки нужные поля Название = СокрЛП(Сред(Data, 4, 30));

Артист = СокрЛП(Сред(Data, 34, 30));

Альбом = СокрЛП(Сред(Data, 64, 30));

Год = СокрЛП(Сред(Data, 94, 4));

Комментарий = СокрЛП(Сред(Data, 98, 30));

Трек = КодСимвола(Сред(Data, 127, 1));

НомерЖанра = КодСимвола(Сред(Data, 128, 1));

Если НомерЖанра < Жанры.Количество() Тогда Жанр = Жанры[НомерЖанра];

Иначе Жанр = " ;

" КонецЕсли;

112 Глава // Выводим теги Сообщить("Название: " + Название);

Сообщить("Артист: " + Артист);

Сообщить("Альбом: " + Альбом);

Сообщить("Год: " + Год);

Сообщить("Комментарий: " + Комментарий);

Сообщить("Трек: " + Трек);

Сообщить("Жанр: " + Жанр);

Файлы МРЗ хранятся в формате Unicode. Однако, к сожалению, версия 7. системы "1С:Предприятие" не позволяет работать с такими форматами.

В связи с этим, напрямую в версии 7.7 теги МРЗ-файлов прочитать не уда ется. Для чтения тегов в данном случае нужно использовать внешние ком поненты или объект Msscriptcontroi.scriptcontroi, вынося весь код в VB-скрипт.

Специальные папки Бывают ситуации, когда необходимо записать какой-либо файл в специаль ную папку (на рабочий стол, в избранное, включить в автозагрузку и т. п.).

В английской версии Windows существует папка Startup (Автозагрузка), и если вы, например, укажите путь C:\WINDOWS\DiaBHoe меню\Программы\ Автозагрузка, то эта запись сработает только в русской версии Windows и нигде больше. Чтобы избежать этих проблем, был создан список специаль ных папок. Чтобы получить доступ к какой-либо специальной папке, можно воспользоваться методом speciaiFoiders объекта wshSheii. Данный метод имеет один параметр — строку, описывающую имя специальной папки.

Рассмотрим возможные параметры метода SpeciaiFoiders:

П AiiusersDesktop — рабочий стол (для всех пользователей);

П AiiusersstartMenu — меню Старт (для всех пользователей);

П AiiusersPrograms — меню Программы (для всех пользователей);

О Aiiusersstartup — Автозагрузка (для всех пользователей);

О Desktop — рабочий стол;

П Favorites — Избранное;

П Fonts — шрифты;

П MyDocuments — Мои документы;

О NetHood — папка NetHood;

П FrintHood — папка PrintHood;

Использование скриптов WSH П Programs — меню Программы;

О Recent — последние запуски;

П sendTo — меню Отправить;

П startMenu — меню Старт;

П startup — Автозагрузка;

О Templates— шаблоны.

Рассмотрим пример вывода некоторых специальных папок в системе "1С:Предприятие" версии 7.7 (листинг 3.14).

лстинг 3.14. Вывод специальных папок в версии 7. -.i,_l_ — -^—_.

-- 1 _„_, „_,._..-_.i_i._.:...

......_: -,«..

WSHShell = СоздатьОбъект("WScript.Shell");

Сообщить("Автозагрузка: " + WshShell.SpecialFolders("Startup"));

Сообщить("Программы: " + WshShell.SpecialFolders("Programs"));

Сообщить("Мои документы: " + WshShell.SpecialFolders("MyDocuments"));

Сообщить("Шрифты: " + WshShell.SpecialFolders("Fonts"));

Сообщить("Меню 'Старт': " + WshShell.SpecialFolders("StartMenu"));

В версии 7.7 все довольно просто и прозрачно. А вот в 8.0, по непонятным причинам, данный код вызывает ошибку. Чтобы обойти эту ошибку, можно использовать объект MSScrlptControi. Scriptcontfbi, в котором и получать путь, указывающий местоположение специальных папок, после чего воз вращать их в контекст системы "Ю.Предприятие". Рассмотрим пример по лучения специальных папок через VB-скрипт (листинг 3.15).

Г " ""ШННННННИ i Листинг 3.15. Вывод специальных папок в версии 8. // Функция возвращает путь к системной папке, указанной в параметре <Имя> Функция ПолучитьСистемнуюПапку(Имя) Попытка Ctrl = Новый COMO6beKT("MSScriptControl.ScriptControl");

// Указываем язык скрипта (VBS) Ctrl.Language = "vbscript";

// Добавляем код на VBS Ctrl.AddCode(" I Function SpecialFolders(Name) I Set Shell = CreateObject(""Wscript.Shell"") |SpecialFolders = Shell.SpecialFolders(Name) 114 Глава I End Function");

// Запускаем функцию SpecialFolders с 'параметром <Имя> ИмяПапки = Ctrl.Run("SpecialFolders", Имя);

Исключение //В случае неудачного выполнения возвращаем — Неопределено ИмяПапки = Неопределено;

• КонецПопытки;

Возврат ИмяПапки;

КонецФункции Сообщить("Рабочий стол: " + ПолучитьСистемнуюПапку("Desktop"));

Сообщить("Мои документы: " + ПолучитьСистемнуюПапку("MyDocuments"));

Сообщить("Избранное: " + ПолучитьСистемнуюПапку("Recent"));

Работа с ярлыками Windows С помощью WSH можно создавать ярлыки для файлов и адресов сайтов в Интернете (URL). Для этого используется объект Wshshell.

Создание ярлыков для файлов Для создания ярлыка используется метод Createshortcut объекта Wshshell, который имеет единственный параметр — полное имя файла для ярлыка.

Приведем пример создания ярлыка для запуска системы SQL-версии "1С:Предприятие 7.7" (листинг 3.16).

г 3.16. Создание ярлыка для файла Shell = Новый СОМОбъект("WScript.Shell"};

DesktopPath = ПолучитьСистемнуюПапку("Desktop");

Link = Shell.Createshortcut(DesktopPath + "\test.lnk");

Link.Arguments = "1 2 3";

Link.Description = "Тестовый пример";

Link.HotKey = "CTRL+ALT+SHIFT+X";

Link.IconLocation = "Icv7s.exe,!";

Link.TargetPath = "c:\Program Files\lCv77\BIN\lcv7s.exe";

Link.WindowStyle = 3;

Link.WorkingDirectory = "c:\Program Files\lCv77\BIN\";

Link.Save();

Использование скриптов WSH В данном примере метод Createshortcut возвращает ссылку на объект Link.

Для описания параметров ярлыка сначала заполняются основные свойства объект Link. После этого он сохраняется с помощью метода save о.

Объект Link имеет следующие свойства:

П Arguments — описание параметров запуска файла;

О Description — текстовое описание к ярлыку;

П HotKey — комбинация клавиш для быстрого запуска ярлыка;

П iconLocation — файл с иконкой;

П TargetPath — полное имя запускаемого файла;

П windowstyle — способ запуска программы, причем свойство может при нимать следующие значения:

• з — при запуске окно программы будет развернуто на весь экран;

• 4 — устанавливает стандартный размер окна;

• 7 — окно будет свернуто в значок на панели задач;

П workingoirectory — рабочая папка.

Копирование, перемещение и удаление ярлыков Для копирования, перемещения и удаления ярлыков применяются такие же методы, что и для работы с файлами. А именно CopyFile, Move File и DeleteFile (листинг 3.17).

ННШННВи.

эпирование, перемещение и удаление ярш Shell = Новый COM06beKT("WScript.Shell");

FSO = Новый СОМОбъект("Scripting.FileSystemObject");

DesktopPath = ПолучитьСистемнуюПапку("Desktop") + "\test.lnk";

NewPath = "C:\\";

// Копирование ярлыка FSO.CopyFile(DesktopPath, NewPath);

// Перемещение ярлыка MyDocumentsPath = ПолучитьСистемнуюПапку("MyDocuments") + "\test.lnk";

FSO.MoveFile(NewPath, MyDocumentsPath);

// Удаление ярлыка FSO.DeleteFile(MyDocumentsPath);

116 Глава Создание ярлыков для URL-адресов Помимо ярлыков для файлов, WSH позволяет создавать ярлыки для запуска Web-страниц. В этом случае применяется все тот же метод createShortcut, но в качестве аргумента необходимо использовать файл с расширением URL и в свойстве TargetPath указывать адрес интернет-страницы.

Рассмотрим пример создания на рабочем столе ярлыка для запуска форума, посвященного системе "1С:Предприятие" (листинг 3.18).

Shell = Новый СОМОбъект("WScript.Shell");

DesktopPath = ПолучитьСистемнуюПапку("Desktop");

URL = Shell.CreateShortcut(DesktopPath + "\ERP Group.url");

URL.TargetPath = "http://www.erpg.ru";

URL.Save();

URL = Shell.CreateShortcut(DesktopPath + "\Ваш форум.url");

URL.TargetPath = "http://forum.erpg.ru";

URL.Save () ;

Работа с системным реестром Windows Понятие реестра Реестр — это база данных операционной системы, содержащая данные о текущей конфигурации программных и аппаратных средств вычислительной системы. Физически вся информация реестра разбита на два файла:

SYSTEM.DAT и USER.DAT, находящиеся в каталоге Windows.

Чему действительно необходимо уделить внимание, так это структуре реест ра. Он содержит шесть корневых разделов (ветвей), на которых ниже оста новимся подробнее. Каждый из них включает подразделы, отображаемые в левой части окна в виде значка папки. Конечным элементом дерева реест ра являются ключи или параметры, делящиеся на три типа:

О строковые (например, "C:\Windows");

О двоичные (например, 10 82 АО 8F), причем максимальная длина такого ключа 16 Кбайт;

Использование скриптов WSH П типа DWORD, которые занимают по 4 байта и отображаются в шестнад цатеричном и в десятичном виде (например, 0x00000020 (32), причем в скобках указано десятичное значение ключа).

Рассмотрим корневые разделы раздела, точнее, какая информация в них содержится.

П HKEY_CLASSES_ROOT. В этом разделе содержится информация о заре гистрированных в Windows типах файлов, что позволяет открывать их по двойному щелчку мыши, а также информация об OLE-серверах (подроб нее о технологии OLE см. в главе 4).

П HKEY_CURRENT_USER. Здесь содержатся настройки оболочки пользова теля (например, "Рабочего стола", меню Пуск и т. п.), вошедшего в среду Windows. Они дублируют содержимое подраздела HKEY_USER\name, где name — имя пользователя, вошедшего в среду Windows. Если на компью тере работает один пользователь и используется обычный вход в среду операционной системы, то значения раздела берутся из подраздела HKEY_USERS\.DEFAULT.

О HKEY_LOCAL_MACHINE. Этот раздел содержит информацию, относя щуюся к компьютеру: драйверы, установленное программное обеспече ние и его настройки.

П HKEY_USERS. Содержит настройки оболочки Windows для всех пользо вателей. Как было сказано выше, именно из этого раздела информация копируется в раздел HKEY_CURRENT_USER. Все изменения в HKCU (сокращенное название раздела HKEY_CURRENT_USER) автоматически переносятся в HK.U.

П HKEY_CURRENT_CONFIG. В этом разделе содержится информация о конфигурации устройств Plug-and-Play и сведения о конфигурации компьютера с переменным составом аппаратных средств.

П HKEY_DYN_DATA. Здесь хранятся динамические данные о состоянии различных устройств, установленных на компьютере. Именно сведения этой ветви отображаются в окне Система | Устройства | Свойства, вызы ваемого из Панели управления. Данные этого раздела изменяются самой операционной системой, так что редактировать что-либо вручную не же лательно.

Запись, чтение и удаление ветвей реестра С помощью Windows Script Host возможно в "невидимом" режиме добавлять какую-либо информацию в реестр. Также возможно считывать информа цию, создавать и удалять разделы и параметры. Пользователь может даже не подозревать, что на его компьютере выполняются какие-то работы. Очевид но, что многим администраторам такая возможность придется по душе.

Глава Для работы с реестром в WSH предусмотрены методы Regwrite, RegRead и RegDelete объекта WshShell.

Метод Regwrite предназначен для создания ветвей реестра и записи в них параметров. Метод содержит три аргумента.

П Name — полное имя ветви или параметра. Если в конце имени стоит об ратный слэш (\), то аргумент является ветвью, иначе — параметром;

П Value — значение параметра или значение по умолчанию в случае созда ния ветви;

П туре — тип значения (REG_SZ — строковый параметр, REG_EXPAND_SZ — расширяемый строковый параметр, REG_DWORD — числовой параметр, REG_BINARY - двоичный параметр).

Метод RegRead предназначен для чтения значения параметра и имеет один параметр — полное имя ветви или параметра реестра. В случае указания имени ветви (с обратным слэшем на конце) метод возвращает значения па раметра по умолчанию.

Метод RegDelete предназначен для удаления ветви или параметра реестра и имеет один параметр — полное имя ветви или параметра.

Рассмотрим пример работы с системным реестром (листинг 3.19).

4стинг 3.19. Работа с системным реестром Windows Shell = Новый СОМОбъект("WScript.Shell");

Key = "HKEY_CURRENT_USER\";

// Создание ветки HCU\TestKey\ Shell.RegWrite(Key + "TestKeyV, "testkeydefault");

// Создание строкового параметра stringl Shell.RegWrite(Key + "TestKeyXstringl", "testkeystring") // Создание параметра типа DWORD Shell.RegWrite(Key + "TestKeyXint", 123, "REG_DWORD");

// Чтение созданных параметров Сообщить(Shell.RegRead(Key + "TestKeyV'));

Сообщить(Shell.RegRead(Key + "TestKeyXstringl"));

Сообщить(Shell.RegRead(Key + "TestKeyXint"));

// Удаление ветки HCUXTestKeyX Shell.RegDelete(Key + "TestKeyX");

Использование скриптов WSH цд Работа с сетевыми ресурсами Для работы с сетевыми ресурсами в WSH предназначен объект wshNetwork.

Данный объект позволяет решать такие задачи, как подключения к сети, ин сталляцию принтеров, назначение буквенных обозначений сетевым дискам, получение информации об имени пользователя или компьютера и так далее.

Рассмотрим основные свойства объекта W s h N e t w o r k :

П ComputerName — возвращает имя компьютера;

П userDomain — возвращает имя домена, в котором зарегистрирован поль зователь;

П userName — возвращает имя пользователя.

Рассмотрим основные методы объекта W s h N e t w o r k :

П MapNetworkDrive — присваивает назначенную пользователем букву сете вому диску;

П EnumNetworkDrives — возвращает список подключенных сетевых дисков;

П RemoveNetworkDrive — ОТКЛЮЧаеТ Сетевой ДИСК;

П AddwindowsPrinterConnection — позволяет установить новый принтер в Windows, т. е. указать путь к принтеру и инициировать установку драй веров;

П AddPr interconnect ion — подключает сетевой принтер;

П RemovePrinterConnection — отключает сетевой принтер;

П setDefauitprinter — задает принтер по умолчанию;

П EnumPrinterConnections — возвращает список подключенных принтеров.

Получение информации о сетевой идентификации Для начала разберемся, как работают методы ComputerName, UserDomain И UserName объекта WshNetwork.

Рассмотрим небольшой пример, в котором выводятся сведения об имени пользователя, имени компьютера и домене (листинг 3.20).

_.

. - — ;

—.

г вод информации об имени пользователя, имени компьютера Network = Новый СОМОбъект("WScript.Network");

Сообщить("Имя пользователя: " + Network.UserName);

Сообщить("Имя компьютера: " + Network.ComputerName);

Сообщить("Имя домена: " + Network.UserDomain);

120 Глава В данном примере использовались свойства объекта wshNetwork: userName, ComputerName И UserDomain. С ИХ ПОМОЩЬЮ была Получена информация о подключившемся пользователе. Эта информация может понадобиться, на пример, если на компьютере работает несколько пользователей и им нужен доступ к разным сетевым дискам. Таким образом, можно обеспечить авто матическое подключение этих дисков в зависимости от того, какой пользо ватель сейчас работает.

Работа с сетевыми дисками Перед тем как подключать какой-либо сетевой диск, необходимо сначала определить — подключен ли уже нужный диск или нет. Рассмотрим пример вывода информации о том, какие сетевые диски в данный момент времени уже подключены (листинг 3.21).

1иска подключенных сетевых дисков Network = Новый СОМОбъект("WScript.Network");

// Получаем коллекцию сетевых дисков Drives = Network.EnumNetworkDrives();

Для каждого Диск Из Drives Цикл Сообщить(Диск);

КонецЦикла;

Для подключения и отключения сетевых дисков существуют методы MapNetworkDrive И RemoveNetworkDrive соответственно. Рассмотрим пример подключения сетевого диска (листинг 3.22).

Net = Новый СОМОбъект("WScript.Network");

Попытка Net.MapNetworkDrive("М:", "\\Server\DATA\CRM");

Исключение Сообщить("Невозможно произвести подключение!");

КонецПопытки;

В данном примере в методе MapNetworkDrive используются только первые два параметра: буква, на которую будет подключаться диск, и, собственно, путь к сетевому диску. Третий параметр (истина или ложь) указывает, осу ществлять или нет подключение этого диска при следующем входе пользо Использование скриптов WSH вателя. Четвертый и пятый параметры определяют имя пользователя и его пароль, с которыми может подключаться диск. Лучше организовать доступ к диску нужным пользователям на сервере средствами самой ОС. Тогда по сторонние люди не смогут узнать пароль для работы с этим ресурсом.

При отключении сетевого диска используется метод RemoveNetworkDrive, который имеет три параметра. Обязателен только первый параметр — буква отключаемого диска. Второй параметр — отключает диск (если истина) даже если он в этот момент используется. Третий параметр сохраняет настройки для следующих входов пользователя.

Работа с сетевыми принтерами В wshNetwork реализовано несколько методов сетевого доступа к принтерам.

Чтобы явно установить связь принтера с портом, следует использовать ме тод AddPrinterConnection. Для соединения с принтерами в среде Windows (и автоматической установки драйверов на машинах с операционными сис темами Windows 2000/XP/NT и Server 2003) нужно применить метод AddwindowsPrinterConnection, который представлен в листингах 3.23 и 3.24.

Метод SetDefauitPrinter назначает компьютеру принтер, связь с которым устанавливается по умолчанию.

Листинг 3.23. Подключение сетевого принтера в Windows NT/2000/XP/Server Network = Новый СОМОбъект{"WScript.Network");

Попытка Network.AddwindowsPrinterConnection("\\ServerName\PrinterName");

Network.SetDefauitPrinter("\\ServerName\PrinterName");

Исключение Сообщить("Невозможно произвести подключение!");

КонецПопытки;

•jgp-j-тт- — —.--.- ючение сетевого принтера в Windows 9x/ME Network = Новый СОМОбъект("WScript.Network");

Попытка Network.AddwindowsPrinterConnection("\\ServerName\ PrinterName", " Lexmark Optra S 1650");

Network.SetDefauitPrinter("\\ServerName\PrinterName");

Исключение Сообщить("Невозможно произвести подключение!");

КонецПопытки;

•\22 Глава Данные примеры подключают сетевой принтер с именем PrinterName, на ходящийся на сервере ServerName и устанавливают его в качестве принтера, используемого по умолчанию.

Для отключения сетевого принтера используется метод RemovePrinterConnection, который имеет три параметра:

П первый параметр — буква отключаемого диска;

П второй параметр — (если истина) отключает принтер, даже если он в этот момент времени используется;

П третий параметр — признак сохранения настройки для следующих входов пользователя.

Обязательным является только первый параметр.

Как и в случае с сетевыми дисками, объект WshNetwork позволяет определить список подключенных сетевых принтеров. Для этого используется метод EnumPrinterConnections, который возвращает коллекцию принтеров. Дан ную коллекцию, как и любую другую, в системе "1C:Предприятие" 8.0 мож но перебрать С ПОМОЩЬЮ КОНСТРУКЦИИ Для...каждого из...Цикл...КонецЦикла.

В версии 7.7 системы "1C:Предприятие" — с помощью объекта coMServices.

Управление программами Под управлением программ будем понимать: запуск программ;

активизацию их окон;

имитацию нажатия, в границах этих окон, различных клавиш кла виатуры. Для решения перечисленных задач нужны всего три функции.

О sendKeys (string) — имитируется нажатие клавиши или последователь ности клавиш на клавиатуре, указанных в единственном параметре.

О AppActivate (Title) — активизирует приложение по заголовку окна или по идентификатору процесса.

П Run (Command, WindowStyle, WaitOnReturn) — запускает Приложение ПО командной строке. Параметры функции имеют следующее назначение:

• первый параметр (command) — определяет запускаемое приложение;

• второй параметр (WindowStyle) — определяет стиль окна и может принимать значения:

О о — запускать программу в скрытом окне;

^ Примечание Если вы попытаетесь запустить приложение с таким значением второй пере менной, то окно программы будет невидимым и кнопка на панели задач не бу дет создана. Удостовериться, что приложение действительно запустилось, можно в диспетчере задач, который вызывается по комбинации клавиш ++.

Использование скриптов WSH О 1 — запустить программу в оригинальном размере и положении окна;

О 2 — запустить программу минимизированной;

О з — запустить программу максимизированной (на полный экран);

О 4 — запустить программу с последним использованным размером и положением окна на экране;

О 5 -— запустить программу с текущими размером и позицией окна на экране;

О б — запустить программу минимизированной (при этом активным будет следующее окно в последовательности окон активных при ложений Windows);

• третий параметр (значения — истина или ложь) указывает на необхо димость дождаться завершения выполнения приложения.

В качестве параметра метода sendKeys можно указывать как алфавитно цифровые символы, так и символы специальных клавиш, например, , , ...,, , и т. п. В табл. 3.1 при ведены специальные обозначения для этих клавиш.

Таблица 3.1. Обозначения специальных клавиш Клавиша Обозначение {BACKSPACE}, {BS}, или {BKSP} {BREAK} {CAPSLOCK} или {DELETE} или {DEL} {DOWN} {END} {ENTER}или ~ {ESC} {HELP} {HOME} {INSERT} или {INS} {LEFT} {NUMLOCK} {PGDN} {PGUP} Глава Таблица 3,1 (окончание) Обозначение Клавиша {PRTSC} {RIGHT} {SCROLLLOCK} {TAB} {UP} {F1} {F2} {F3} {F4} {F5} {F6} {F7} {F8} , {F9} {F10} {F11} {F12} Для указания клавиш, , существуют специальные коды:

П - "+";

-" Л ";

П а •-"%".

Например, если вы хотите передать нажатие нескольких клавиш с нажатой клавишей , надо выполнять команду wshsheii.sendKeys ( " + ( д в с ) " ), если только одной клавиши (первую, указанную в последовательности кла виш) — команду WshShell.SendKeys("+ABC").

Примечание Д Необходимо заметить, что такие символы, как "+", "Л" и "%", зарезервированы под обозначение специальных клавиш, так что просто так передать эти (и неко торые другие) символы не удастся. Для этого надо заключить их в фигурные скобки, например, "{+}", "{%}" и т. д. Вот полный список символов, которые не обходимо заключать в фигурные скобки: +, Л, %, ~, (,), {,}, [, ].

Использование скриптов WSH Если вы хотите передать несколько нажатий подряд одной клавиши, то вовсе не обязательно все их набирать в скрипте. Можно просто указать количество повторений. Так, строка wshsheii.sendKeys ( " { А ю о } " ) экви валентна сотне нажатий клавиши "А". Правда, есть ограничение на коли чество возможных повторений нажатия клавиш. Это значение лежит где то между 8150 и 8180 раз. При превышении этого значения будет выдана ошибка.

Управление калькулятором В листинге 3.25 приведен код, демонстрирующий, как запустить калькуля тор и рассчитать значение произведения чисел 2 и 3.

._т-..

„ —_—_ -„ —— „,.^_,. т,_ _, _ _ _ _ _ _ _ _ _ _.т, - -. _- _,—- _-, нг 3.25. Управление калькулятором _;

_„...*...: :. ;

', _ !

WshShell = Новый СОМОбъект("WScript.Shell");

// Запускаем калькулятор WshShell.Run("calc");

// Ждем пока калькулятор загрузится (для русской версии ОС) Пока Не WshShell.AppActivate("Калькулятор") Цикл КонецЦикла;

.

// Эмулируем нажатие клавиш WshShell.SendKeys("!{+}");

WshShell.SendKeys("2");

WshShell.SendKeys("~");

WshShell.SendKeys("*3");

WshShell.SendKeys("~") ;

Приведенный пример запускает калькулятор, ждет пока он зафузится и по сле активации его окна эмулирует последовательное нажатие клавиш. В ре зультате выполнения в окне калькулятора появится цифра 9.

Управление Microsoft Word Рассмотрим еще один интересный пример, в котором запускается Microsoft Word и в нем печатается некоторый текст (листинг 3.26).

126 Глава явление Microsoft Word WshShell = Новый СОМОбъект("WScript.Shell");

Если WshShell.AppActivate("Word") Тогда WshShell.SendKeys("Welcome to http://www.erpg.ru");

WshShell.SendKeys("~");

// Enter WshShell.SendKeys("%");

// Alt // Спускаемся на 4 пункта вниз WshShell.SendKeys("{DOWN}{DOWN}{DOWN}{DOWN}");

WshShell.SendKeys("~");

// Enter WshShell.SendKeys("c:\test.doc");

WshShell.SendKeys("~");

// Enter Иначе Сообщить("Microsoft Word не запущен!");

КонецЕсли;

Реализация примера подразумевает, что у вас уже запущен MS Word с пус той страницей. В результате выполнения в документе напечатается текст и будет сохранен под именем c:\test.doc, но только в том случае, если пункт меню Сохранить находится четвертым сверху.

Запуск встроенного калькулятора В системе "1C:Предприятие" (в версиях 7.7 и 8.0) существует встроенный калькулятор, который вызывается при нажатии комбинации клавиш + или через пункт меню Сервис | Калькулятор. С помощью ме тода SendKeys объекта W s h S h e l l можно программно вызвать встроенный калькулятор (листинг 3.27).

нг 3.27. Запуск встроенного калькулятора WshShell = Новый СОМОбъект("WScript.Shell");

WshShell.SendKeys("A{F2}");

// Ctrl+F Закрытие окна сообщений в системе "1С:Предприятие" В системе "1С:Предприятие" (в версиях 7.7 и 8.0) при вызове оператора сообщить появляется окно сообщений. Часто бывает ситуация, когда необ Использование скриптов WSH ходимо программно закрыть это окно. Оно закрывается при нажатии ком бинации клавиш ++. Приведем пример закрытия окна со общений (листинг 3.28).

//С помощью вывода текста показываем окно сообщений Для Ном = 1 По 100 Цикл Сообщить("Текст " + Ном);

КонецЦикла;

WshShell = Новый СОМОбъект("WScript.Shell");

// Закрываем.окно сообщений WshShell.SendKeys("л+(z)");

// ++ WshShell.SendKeys("л+(я)");

// для русской раскладки Глава Использование OLE Automation Понятие OLE Automation OLE — это аббревиатура названия технологии Object Linking and Embedding (связывание и внедрение объектов). Она указывает на способность работать с составными объектами, созданными в других приложениях (например, рисунками, документами и т. п.). Основные термины, с которыми оперирует данная технология, — это OLE-объект, сервер приложения и контейнер приложения.

OLE-объектом называют объект, созданный в другом приложении и сохра нивший связь с этим приложением. Точечный рисунок, созданный в редак торе Paint, электронные таблицы в формате Excel или диаграмма из MS Graph — все они могут быть OLE-объектами, если будут вставлены в доку мент соответствующим образом. Если не вставлять их как OLE-объект, то связь с оригинальным приложением отсутствует.

Контейнером приложения OLE называют приложение, в котором создается составной документ, содержащий OLE-объект, позволяя обрабатывать его в исходном приложении (например, таком как Paint или Excel), которое ис пользовалось для создания этого объекта.

Сервером приложения OLE (OLE Sewer Application) называют приложение, создающее объекты, которые можно поместить в документ-контейнер.

Программы — "1С:Предприятие", Microsoft Word и Excel являются прило жениями, которые могут выступать и как OLE-сервер, и как OLE контейнер. Другими словами, эти приложения могут создавать новые OLE объекты, а такжет хранить OLE-объекты, созданные в других приложениях.

Первоначально механизм OLE был задуман как технология интеграции программных продуктов, входящих в комплект Microsoft Office, в другие приложения. Первое воплощение OLE (OLE 1) представляло собой меха низм создания и работы с составными документами (compound documents).

5 Зак. 130 Глава С точки зрения пользователя, составной документ выглядит единым набо ром информации, но фактически содержит элементы, созданные двумя или несколькими разными приложениями. С помощью OLE 1 пользователь мог, например, объединить электронную таблицу, созданную Microsoft Excel, с текстовым документом Microsoft Word. Идея состояла в том, чтобы доку менто-ориентированная (document-centric) модель работы с компьютером позволила бы пользователю больше думать об информации и меньше о при ложениях, ее обрабатывающих. Как следует из слов "связывание и внедре ние", составные документы можно создать, либо связав их, либо полностью внедрив один документ в другой.

OLE 1, как и большинство первых версий программных продуктов, была несо вершенна. Архитекторам следующей версии предстояло улучшить первоначаль ный проект. Вскоре они поняли, что составные документы это лишь частный случай более общей проблемы — как разные программные компоненты должны предоставлять друг другу сервисы? Для решения этой проблемы архитекторы OLE создали группу технологий, область применения которых гораздо шире составных документов. Основу OLE 2 составляет важнейшая из этих техноло гий — "Модель многокомпонентных объектов" (Component Object Model или СОМ). Новая версия OLE не только обеспечивает поддержку составных доку ментов лучше, чем первая, но и несомненно идет куда дальше простого объеди нения документов, созданных в разных приложениях. OLE 2 позволяет по новому взглянуть на взаимодействие любых типов программ.

Электронные таблицы, текстовые процессоры и другие программы предос тавляют множество полезных возможностей. Почему бы не обеспечить дос туп к ним и другому программному обеспечению? Чтобы это стало возмож ным, приложения должны предоставлять свои сервисы не только человеку, но и программам, т. е. они должны быть программируемыми. Обеспечение программируемое™ и является целью "Автоматизации" (Automation, перво начально называлась OLE-автоматизацией).

Приложение можно сделать программируемым, обеспечив доступ к его сер висам, через обычный СОМ-интерфейс. Однако так поступают редко. Вме сто этого доступ к сервисам приложений осуществляется через диспинтер фейсы (dispinterface). Они очень похожи на интерфейсы (имеют методы, клиенты осуществляют к ним доступ через указатели интерфейса и т. д.).

Однако диспинтерфейсы имеют и существенные отличия. В частности, их методы гораздо проще вызывать клиентам, написанным на простых языках типа встроенного языка системы "1С:Предприятие".

Использование системы "1С:Предприятие" в качестве OLE Automation сервера Методы работы с OLE-объектами существенно отличаются в разных версиях системы "1С:Предприятие". Поэтому их рассмотрение будет происходить по отдельности, для каждой версии системы.

Использование OLE Automation Использование OLE Automation сервера в версии 7. Для запуска системы "1С:Предприятие", в качестве OLE Automation сервера, из внешнего приложения, выполняется следующая последовательность дей ствий:

1. Создается объект с OLE идентификатором:

• vicEnterprise.Application — версия независимый ключ;

• V77.Application — версия зависимый ключ;

• V77S.Application — версия зависимый ключ, SQL-версия;

• V77L.Application — версия зависимый ключ, локальная версия;

• V77M.Application — версия зависимый ключ, сетевая версия.

2. Выполняется инициализация системы "1С:Предприятие" методом Initialize().

3. Вызываются атрибуты и методы системы "1С:Предприятие", как OLE Automation сервера.

"1С:Предприятие", в качестве OLE Automation сервера, имеет 4 метода:

1. initialize о — выполняет инициализацию системы "1С:Предприятие".

2. createobject о — создает объект агрегатного типа данных системы "ЮПредприятие" и возвращает ссылку на него.

3. EvaiExprO — вычисляет выражение системы.

4. ExecuteBatchO — выполняет последовательность операторов.

Подключение к базе данных Для открытия и инициализации базы данных системы "1С:Предприятие" (версии 7.7) предназначен метод i n i t i a l i z e d, который имеет следующие параметры:

П имя объекта.RMTrade — имя переменной и ключевое слово RMTrade;

П команднаяСтрока.— командная строка, в которой можно прописать путь к базе данных, имя пользователя и пароль;

О ПоказыватьЗаставку — Либо пустая строка, Либо — "NO_SPLASH_SHOW", чтобы не показывать заставку при загрузке.

Для того чтобы открыть базу через OLE, необходимо создать объект с иден тификатором OLE, выполнить инициализацию базы и проверить успеш ность ее выполнения. Если в методе initialize указать только первый па раметр, то при открытии базы открывается окно выбора, в котором предлагается выбрать пользователя и ввести пароль (листинг 4.1).

132 Глава БазаОЬЕ = СоздатьОбъект("V77.Application");

Открыта = БазаОЬЕ.Initialize(БазаОЬЕ.RMTrade,,);

Если Открыта = 0 Тогда // True=-l, False= Сообщить("Не удалось открыть базу данных!");

Возврат;

КонецЕсли;

Доступ к объектам базы данных Для доступа к объектам агрегатных типов предназначен метод createobject о, который имеет единственный параметр— строковое выражение, значение которого содержит имя агрегатного типа данных, заданного в конфигураторе. Например: "Справочник, номенклатура", "Документ.ПриходнаяНакладная" И Т. П.

Этот метод создает объект агрегатного типа данных системы "1С:Предприятие" и возвращает ссылку на него.

Для доступа к константам, перечислениям и видам субконто достаточно ис пользовать свойства глобального контекста Константа, Перечисление ИЛИ видыСубконто сервера приложения (листинг 4.2).

^.... -—_.._,...-.„..-..,.-._...-,.. _т...., I Листинг 4.2. Доступ к константам, перечислениям и видам субконто I Сообщить(БазаОЬЕ.Константа.ДатаЗапретаРедактирования);

Сообщить(БазаОЬЕ.Перечисление.КатегорияКонтрагента.Поставщик);

Сообщить(БазаОЬЕ.ВидСубконто.Контрагенты);

Для сравнения перечислений или видов субконто разных баз данных (OLE и местной) необходимо сначала получить строковое или числовое представ ление данного перечисления или вида субконто с помощью методов иден тификатор или ЗначениеПоНомеру в местной базе, а затем найти соответст вующее ему значение в OLE-базе (листинг 4.3).

Листинг 4.3. Поиск вида субконто в OLE ВыбранныйВидСубконтоИд = ВыбранныйВидСубконто.Идентификатор();

ВыбранныйВидСубконтоОЬЕ = БазаОЬЕ.ВидСубконто.ЗначениеПоИдентификатору (ВыбранныйВидСубконтоИд));

Использование OLE Automation В данном примере переменная ВыбранныйВидСубконто содержит значение типа "ВидСубконто", которое определено вне данного кода, например, на форме.

Для доступа к справочникам и документам необходимо использовать метод CreateObject. После создания объекта справочника или документа к нему применимы все методы, касающиеся соответствующего объекта в среде "1С:Предприятие" (листинг 4.4).

СправочникОЬЕ = БазаОЬЕ.CreateObject("Справочник.Фирмы");

СправочникОЬЕ.ВыбратьЭлементы();

Пока СправочникОЬЕ.ПолучитьЭлемент() Цикл Сообщить(СправочникОЬЕ.Наименование);

КонецЦикла;

В данном примере в операторе сообщить для вывода наименования элемен та справочника необходимо использовать именно конструкцию СправочникОЬЕ.Наименование, а НС СправочникОЬЕ.ТекущийЭлемент(). Ина че вместо строкового или числового представления этого элемента програм ма выдаст просто "OLE". По аналогии также не будет работать метод текущийдокумент ( ). Тем не менее через OLE-объект можно использовать методы: Н о в ы й ( ), Записать ( ) И Др.

Доступ к документам производится так же, как и к справочникам (листинг 4.5).

// Поиск контрагента в OLE-базе CnpaB04HHKOLE = BasaOLE.CreateObject("Справочник.Контрагенты");

СправочникОЬЕ.НайтиПоКоду(ВыбКонтрагент.Код, 0);

// Создание нового документа ДокументОЬЕ = БазаОЬЕ.CreateObject("Документ.Контакт");

flOKyMeHTOLE.Новый();

// Заполнение реквизита Контрагент из OLE-базы flOKyMeHTOLE.Контрагент = CnpaBO4HHKOLE.ТекущийЭлемент();

ДокументОЬЕ.Тема = "Пример";

ДокументОЬЕ.Записать();

Если ДокументОЬЕ.Провести()=0 Тогда Сообщить("Ошибка! Документ не проведен.");

КонецЕсли;

Глава Важно отметить тот факт, что нельзя сравнивать или присваивать два или несколько элементов справочника или документов, находящихся в разных базах. Для поиска соответствующего элемента или документа в OLE-базе необходимо ИСПОЛЬЗОВать методы: НайтиПоКоду, НайтиПоНаименованию И Т. П.

В листинге 4.5 для заполнения контрагента в документе контакт использу ется элемент базы OLE, предварительно найденный по коду, соответствую щему коду контрагента в местной базе. Это же касается и объектов типа "Счет".

Для доступа к регистрам используется тот же метод CreateObject (листинг 4.6).

РегистрОЬЕ = БазаОЬЕ.CreateObject("Регистр.Касса");

РегистрОЬЕ.ВыбратьИтоги();

Пока РегистрОЬЕ.ПолучитьИтог()=1 Цикл Сообщить("Остаток в кассе " + РегистрОЬЕ.Касса.Наименование " = " + РегистрОЬЕ.Сумма);

КонецЦикла;

Вычисление выражений Для вычисления выражений, написанных на встроенном языке системы "1C:Предприятие", предназначен метод EvaiExpr, который возвращает ре зультат вычисления. Результатом выражения может быть число, строка, дата или значение любого агрегатного типа данных. Результат с неопределенным типом данных преобразуется к строковому типу. Так же с помощью метода EvaiExpr можно выполнять экспортируемые функции глобального модуля (листинг 4.7).

| Листинг 4.7. Вычисление выражений // Выполнение функции глобального модуля ФорматированноеИмяПользователя = БазаОЬЕ.EvaiExpr С'глДополнитьСтрокуП ( + ИмяПользователя + " " ", 255)");

","" СуммаПрописью = БазаОЬЕ.EvaiExpr("глСуммаПрописью(" + Сумма + " " +, Валюта + " " ;

)) // Вычисление выражения используя стандартные функции СуммаПрописью = БазаОЬЕ.EvaiExpr("Цел(Лог(2.2)) * 5м);

Во второй строке данного примера в функцию глСуммаПрописыо, в качестве параметра валюта, необходимо передавать строку, т. к. данная функция Использование OLE Automation / будет исполняться внутри подключаемого OLE-сервера, т. е. внешней под ключаемой базы данных.

Выполнение операторов Для выполнения последовательности операторов в OLE-базе используется метод ExecuteBatch, единственным параметром которого является строка, опи сывающая текст программы на встроенном языке системы "1С:Предприятие".

Метод ExecuteBatch возвращает значение логического типа (true — если последовательность операторов выполнена успешно;

false — если нет).

В OLE Automation значения true и false представляются соответственно значениями -1 (минус единица) и о.

Ниже приведен пример выполнения процедур в OLE-базе (листинг 4.8).

эние операторов СправочникОЬЕ = BasaOLE.EvalExpr("СоздатьСправочникФирмы()");

СправочникОЬЕ.ВыбратьЭлементы();

Пока СправочникОЬЕ.ПолучитьЭлемент() Цикл Сообщить(СправочникОЬЕ.Наименование);

КонецЦикла;

// Выполнение процедур БазаОЬЕ.ExecuteBatch("ПроцедураРегл!();

ПроцедураРегл2()");

Использование OLE Automation сервера в версии 8. Система "Ю.Предприятие 8.0" может использоваться внешними приложе ниями в качестве OLE Automation сервера.

Обычно в этих целях "Ю.Предприятие" используют для управления конфи гурациями системы программ "1С:Предприятие" из других приложений и выполнения действий аналогичным интерактивным действиям пользователя (например, построение отчетов).

Для запуска системы "1С:Предприятие" в качестве OLE Automation серве ра из внешнего приложения выполняется следующая последовательность действий:

1. Создается OLE объект с идентификатором "vs.Application".

2. Выполняется инициализация системы "1С:Предприятие" методом Connect.

3. Вызываются свойства и методы системы "1С:Предприятие" как OLE Automation сервера.

Глава Приведем пример доступа к данным информационной базы посредством OLE Automation сервера системы "1С:Предприятие 8.0" из Visual Basic скрипта (листинг 4.9).

' Подключение к БД средствами OLE Automation Set cc = CreateObject("v8.Application") cc.Connect("File=C:\Progra~l\lcv8\Db\Trade;

изг=Иванов") ' Установка видимости приложения cc.Visible = True Задаем текст запроса Text = "ВЫБРАТЬ * ИЗ Справочник.Контрагенты" ' Создаем объект Запрос Set Query = cc.NewObject("Запрос") Query.Text = Text ' Выполнение запроса Set Result = Query.Execute() Set Choose = Result.Choose() ' Выборка результата выполнения запроса Do While Choose.Next() ' Пример вывода сообщения в OLE-базе cc.Message(Choose.Description) Loop ' Пример вывода предупреждения в OLE-базе cc.DoMessageBox "Форум для вопросов http://forum.erpg.ru", 10, "Внимание!!!" Данный пример последовательно выполняет все три перечисленные действия.

Некоторые версии внешних программ, в том числе и Visual Basic Script, об ращающихся к программе "1С:Предприятие" посредством OLE Automation, могут неправильно интерпретировать русские идентификаторы объектов.

Примечание Для обращения к свойствам и методам агрегатных типов данных системы "1С:Предприятие" из внешних приложений рекомендуется использовать их анг лоязычные синонимы.

Использование OLE Automation При работе в качестве OLE Automation сервера "1С:Предприятие" предос тавляет доступ ко всем свойствам и методам своего глобального контекста, а также позволяет включать и выключать пользовательский интер фейс (главное окно приложения). Поэтому объект OLE-сервер системы "1С:Предприятие" в качестве своих свойств может использовать: системные перечисления, значения констант, перечислений, справочников, документов и т. п., а также переменные, объявленные в модуле приложения с ключевым СЛОВОМ Экспорт.

Кроме того, OLE Automation сервер имеет одно дополнительное свойство и два метода с целью выполнения действий, специфичных для работы в ре жиме OLE Automation.

Единственное свойство visible имеет значение логического типа и позво ляет управлять видимостью пользовательского интерфейса системы "1С:Предприятие". По умолчанию свойство имеет значение ложь.

Объект OLE-сервер системы "1С:Предприятие" в качестве своих методов может использовать системные процедуры и функции, а также процедуры и функции модуля приложения и общих модулей, объявленные с ключевым словом Экспорт. Кроме того, OLE-сервер системы "Ю.Предприятие" имеет два дополнительных метода: Connect и Newobject.

Метод connect выполняет инициализацию системы "ЮПредприятие" и имеет единственный параметр — строку, используемую для соединения с информационной базой. Метод возвращает истина, если инициализация прошла успешно, или ложь, если нет.

Существует два варианта подключения к OLE-серверу системы "ЮПредприятие", которые зависят от варианта использования информацион ной базы (файловый или клиент-серверный варианты). Приведем пример под ключения файловой и клиент-серверной версии системы "1С:Предприятие" (листинг 4.10).

• • • • •нннннннннк • • • • нннннннннн ""' " "" | Листинг 4.10. Варианты подключения к OLE-серверу Подключение к БД файлового варианта Set FileDb = CreateObject("v8.Application") FileDb.Connect("File=C:\Progra~l\lcv8\Db\Trade;

Озг=Иванов;

Pwd=super") ' Подключение к БД клиент-серверного варианта Set ServerDb = CreateObject("v8.Application") ServerDb.Connect("Srvr=ServerlC;

Ref=Trade;

изг=Иванов;

Pwd=super") Рассмотрим параметры подключения к базе данных в файловом варианте.

О File — указывает на каталог базы данных.

138 Глава П us r — имя пользователя, под которым будет происходить авторизация.

П Pwd — пароль пользователя.

Для подключения к базе данных в клиент-серверном варианте используются четыре параметра.

П Srvr — указывает имя сервера, на котором работает сервер приложений системы "1С:Предприятие";

CD Ref — указывает имя базы данных на сервере приложений;

П Us r — определяет имя пользователя, под которым будет происходить ав торизация;

П Pwd — пароль пользователя.

Второй специальный метод OLE-сервера системы "1C:Предприятие" — Newobject, который создает объект агрегатного типа данных системы "1С:Предприятие" и возвращает ссылку на него. Единственный параметр метода — строковое выражение, значение которого содержит имя агрегат ного типа данных, объявленного в конфигураторе.

В листинге 4.9 используется метод Newobject для создания объекта типа запрос.

Поскольку система "1С:Предприятие" может создавать и использовать OLE Automation серверы, то из системы "1C:Предприятие" можно обращаться к другим информационным базам.

В последующем материале книги будут показаны примеры использования OLE Automation сервера системы "1С:Предприятие 8.0" из среды "1С:Предприятия".

Доступ к объектам базы данных Как уже было сказано ранее, для создания объектов агрегатного типа ис пользуется метод Newobject, но для доступа к константам и перечислениям достаточно использовать свойства глобального контекста константы и перечисления сервера приложения (листинг 4.11).

i и перечислениям База = Новьм СОМОбъект("V8.Application");

База.Connect(СтрокаПодкгаочения);

// Доступ к константам Сообщить(База.Константы.ОсновнаяВалюта.Получит().Наименование) // Доступ к перечислениям Сообщить(База.Перечисления.Периодичность.День);

Использование OLE Automation Для доступа к справочникам и документам можно использовать метод NewObject. Однако можно использовать и свойства глобального контекста Справочники (листинг 4.12) и документы (листинг 4.13). После создания объ екта справочника или документа к нему применимы все методы, касающие ся соответствующего объекта в среде "1 (^Предприятие".

База = Новый СОМОбъект("V8.Application");

База.Connect(СтрокаПодключения);

// Доступ к справочникам СправочникОЬЕ = База.Справочники.Контрагенты;

Выборка = СправочникОЬЕ.Выбрать();

// Обход выборки элементов справочника Пока Выборка.Следующий() Цикл Если Не Выборка.ЭтоГруппа Тогда Сообщить(Выборка.Наименование);

КонецЕсли;

КонецЦикла;

// Создание нового элемента справочника СправочникОЬЕ = База.Справочники.Контрагенты;

НовыйЭлемент = СправочникОЬЕ.СоздатьЭлемент();

НовыйЭлемент.Наименование = "Михайлов Андрей";

НовыйЭлемент.Комментарий = "Создан автоматически.";

НовыйЭлемент.Записать();

Доступ к документам производится так же, как и к справочникам.

5. Доступ к документам База = Новый СОМОбъект("V8.Application");

База.Connect(СтрокаПодключения);

// Поиск контрагента в OLE-базе СправочникОЬЕ = База.Справочники.Контрагенты;

СпрЭлемент = СправочникОЬЕ.НайтиПоНаименованию("Михайлов Андрей");

// Создание нового документа 140 Глава ДокументОЬЕ = База.Документы.ПоступлениеТоваров.СоздатьДокумент();

ДокументОЬЕ.Дата = ТекущаяДата();

ДокументОЬЕ.Контрагент = СпрЭлемент;

ДокументОЬЕ.УстановитьНовыйНомер();

ДокументОЬЕ.Записать();

Так же, как и в версии 7.7 системы "1С:Предприятие", в объектах OLE-базы данных можно использовать только ее же объекты. В примере, рассмотрен ном выше (листинг 4.13), для заполнения реквизита документа контрагент используется элемент справочника контрагенты той же OLE-базы. Это пра вило касается не только объектов агрегатных типов (справочников, доку ментов, регистров и т. п.), но и универсальных коллекций значений, таких как массивы, структуры, списки значений и т. п.

Рассмотрим пример вывода курса доллара из регистра сведений (листинг 4.14).

Листинг 4.14. Доступ к регистрам сведений База = Новый СОМОбъект("VS.Application"};

База.Connect(СтрокаПодключения);

// Доступ к регистрам сведений // Поиск элемента справочника с наименованием "USD" СправочникОЬЕ = База.Справочники.Валюты;

СпрЭлемент = СправочникОЬЕ.НайтиПоНаименованию("USD");

// Создаем структуру в OLE-базе Структура = База.NewObject("Структура");

Структура.Вставить("Валюта", СпрЭлемент);

// Получаем курс доллара на текущую дату РегистрСвденийОЬЕ = База.РегистрыСведений.КурсыВалют;

Структура = РегистрСведенийОЬЕ.ПолучитьПоследнее(ТекущаяДата(), Структура);

Сообщить("Курс доллара = " + Структура.Курс);

Сообщить("Кратность = " + Структура.Кратность);

В этом примере для использования фильтра применяется структура, которая создается с помощью метода NewObject.

^ Примечание Важно иметь в виду, что если создать структуру в исходной конфигурации с по мощью конструктора Новый Структура ( ), то произойдет ошибка.

Использование OLE Automation Как следует из кода, приведенного в листинге 4.14, работа с регистрами полностью аналогична работе со справочниками и документами.

Использование запросов В системе "1С:Предприятие" использование запросов является самым ос новным способом получения сводных данных, поэтому и при использова нии системы в качестве OLE Automation сервера очень важно уметь исполь зовать механизмы запросов.

Для выполнения запроса к данным OLE-базы достаточно с помощью метода Newobject создать объект запрос и далее работать с ним стандартными ме тодами.

Рассмотрим простой пример вывода списка наименований контрагентов (листинг 4.15).

База = Новый СОМОбъект("V8.Application");

База.Connect(СтрокаПодключения);

Текст = "ВЫБРАТЬ * ИЗ Справочник.Контрагенты";

// Создаем объект запрос Запрос = База.NewObject("Запрос");

Запрос.Текст = Текст;

// Выполняем запрос РезультатЗапроса = Запрос.Выполнить();

Выборка = РезультатЗапроса.Выбрать();

// Обход результата выполнения запроса Пока Выборка.Следующий() Цикл Сообщить(Выборка.Наименование);

КонецЦикла;

Вызов пользовательских интерфейсов В предыдущем примере показана возможность выборки данных с помощью запроса и вывода результатов запроса в основную базу. Эти же данные мож но визуализировать и в базе данных, используемой в качестве OLE Automa tion сервера.

Для начала необходимо показать основное окно приложения с помощью свойства visible, а затем можно вызывать стандартные операторы — сооб щить, предупреждение, а также открывать формы объектов и формировать отчеты (листинг 4.16).

142 Глава База = Новый СОМОбъект("V8.Application");

// Шаг 1. Соединение с базой данных База.Connect(СтрокаПодключения);

// Шаг 2. Установка видимости главного окна приложения База.Visible = Истина;

// Шаг 3. Пример вывода сообщения в OLE-базе База.Сообщить("Пример сообщения через OLE Automation");

// Пример вывода предупреждения в OLE-базе База.Предупреждение("Форум для вопросов http://forum.erpg.ru",,"Внимание!!!");

// Шаг 4. Открытие формы списка справочника Форма = База.Справочники.Контрагенты.ПолучитьФорму("ФормаСписка");

Форма.Открыть();

// Шаг 5. Создание и формирование отчета НовыйОтчет = База.Отчеты.Монитор.Создать();

НовыйОтчетФорма = НовыйОтчет.ПолучитьФорму();

ВыбраннаяНастройка = База.ВосстановитьЗначение("Монитор_настройка");

Если ВыбраннаяНастройкаоНеопределено Тогда НовыйОтчетФорма.НачальноеЗначениеВыбора = ВыбраннаяНастройка;

КонецЕсли;

// Шаг 6. Открытие формы сформированного отчета НовыйОтчетФорма.Открыть();

В приведенном примере последовательно выполняются следующие действия:

1. Соединение с базой данных.

2. Установка видимости главного окна приложения.

3. ВЫВОД сообщений С ПОМОЩЬЮ операторов Сообщить И Предупреждение.

4. Открытие формы списка справочника контрагенты.

5. Создание и формирование отчета монитор основных показателей.

6. Открытие формы сформированного отчета.

Использование OLE Automation Данный пример полностью работоспособен на конфигурации "1С:Управление торговлей" (редакция 10).

..

Доступ к метаданным Для доступа к метаданным можно использовать свойство глобального кон текста Метаданные. Приведем пример вывода всех справочников и их рекви зитов для конфигурации, используемой в качестве OLE Automation сервера (листинг 4.17).

База = Новый СОМОбъект("V8.Application");

База.Connect(СтрокаПодключения);

МетаСправочники = База.Метаданные.Справочники;

// Перебираем все справочники Для каждого Справочник Из МетаСправочники Цикл Сообщить(Справочник.Имя);

// Перебираем все реквизиты Для каждого Реквизит Из Справочник.Реквизиты Цикл Сообщить(Символы.Таб + Реквизит.Имя);

КонецЦикла;

КонецЦикла;

Использование СОМ-соединения в версии 8. Основная задача использования СОМ-соединения для конфигурации систе мы "1С:Предприятие 8.0" — это обеспечение надежного и быстрого про граммного доступа к объектам конфигурации из внешних приложений.

СОМ-сервер системы "1C:Предприятие 8.0" реализован в виде библиотеки COMCntr.dll, которая выполняется в рамках исполняющего процесса.

Применение СОМ-соединения во многом похоже на использование OLE Automation сервера, но существуют и очень важные отличия. Приведем не которые общесистемные отличия СОМ-соединения от OLE Automation.

При использовании СОМ-соединения:

П затрачиваются гораздо меньше системных ресурсов;

П происходит более быстрая установка соединения с базой данных;

П происходит более быстрое обращение к свойствам и методам объектов;

П полностью отсутствуют пользовательские интерфейсы.

144 Глава Отличия в программном использовании СОМ-соединения можно опреде лить следующим образом:

О OLE-объект создается с идентификатором "vs.coMConnector";

П отсутствует свойство visible;

П не работают все методы системы "ЮПредприятие", касающиеся визуа лизации объектов;

П недоступен модуль приложения, но при этом доступен модуль внешнего соединения;

П из общих модулей доступны только те, у которых установлено свойство Внешнее соединение;

П метод connect возвращает объект соединения с базой данных (в OLE Automation метод возвращал значение логического типа, а доступ к базе данных происходил через объект, созданный с помощью идентификатора "V8.Application").

Приведем пример подключения к базе данных системы "1С:Предприятие 8.0" с помощью СОМ-соединения на языке Visual Basic Script (листинг 4.18).

п к базе данных с помощью СОМ-соединени ' Подключение к БД Set ее = CreateObject("v8.COMConnector") Set con = cc.Connect("File=C:\Progra~l\lcv8\Db\Trade;

изг=Иванов") ' Вывод сообщения о названии конфигурации MsgBox con.Metadata.Name, 0, "Конфигурация" ' Задаем текст запроса Text = "ВЫБРАТЬ * ИЗ Справочник.Контрагенты" Создаем объект Запрос Set Query = con.NewObject("Запрос") Query.Text = Text ' Выполнение запроса Set Result = Query.Execute() Set Choose = Result.Choose() ResultChoose = "" Выборка результата выполнения запроса Использование OLE Automation Do While Choose.Next() ' Конкатенация всех значений выборки в одну строку ResultChoose = ResultChoose & vbCrLf & Choose.Description Loop ' Вывод результата выполнения запроса MsgBox ResultChoose, 0, "Результат выборки" Достаточно сравнить данный пример подключения к базе данных с приме ром, приведенным в листинге 4.9, чтобы понять, что при использовании OLE Automation доступ к объектам базы данных происходит через перемен ную ее, а при СОМ-соединении — через переменную con.

Во всем остальном использовать СОМ-соединение можно так же, как и OLE Automation. Чтобы удостовериться в этом, рассмотрим пример досту па к справочникам (листинг 4.19), аналогичный примеру, приведенному в листинге 4.12.

I Листинг 4.19. Доступ к справочникам v8 = Новый COMC©beKT("V8.COMConnector");

База = v8.Connect(СтрокаПодключения);

// Доступ к справочникам СправочникОЬЕ = База.Справочники.Контрагенты;

Выборка = СправочникОЬЕ.Выбрать();

// Обход выборки элементов справочника Пока Выборка.Следующий() Цикл Если Не Выборка.ЭтоГруппа Тогда Сообщить(Выборка.Наименование);

КонецЕсли;

КонецЦикла;

// Создание нового элемента справочника СправочникОЬЕ = База.Справочники.Контрагенты;

НовыйЭлемент = СправочникОЬЕ.СоздатьЭлемент();

НовыйЭлемент.Наименование = "Михайлов Андрей";

НовыйЭлемент.Комментарий = "Создан автоматически.";

НовыйЭлемент.Записать();

Данный пример отличается от приведенного в листинге 4.12 только спосо бом создания объекта и методом подключения к базе данных.

146 Глава Работа с Microsoft Word Как уже было сказано ранее, Microsoft Word является OLE-сервером, кото рый можно использовать для автоматизации множества задач.

Для начала рассмотрим, каковы программные идентификаторы основных объектов Microsoft Word и что представляет собой его объектная модель.

Для OLE-сервера Microsoft Word доступны непосредственно следующие объекты:

О Application — с помощью этого профаммного идентификатора создает ся экземпляр Word без открытых документов;

П Document — с помощью этого программного идентификатора создается экземпляр Word с одним вновь созданным документом.

Все остальные объекты Word являются так называемыми внутренними объ ектами. Это означает, что они не могут быть созданы "сами по себе". Так, объект Paragraph (абзац) не может быть создан отдельно от содержащего его документа.

Если вспомнить, что основное назначение Word — работа с документами, легко понять иерархию его объектной модели. Основным объектом в ней, как и во всех других приложениях Microsoft Office, является объект Application, содержащий коллекцию Documents объектов типа Document.

Каждый объект типа Document содержит коллекцию Paragraphs объектов типа Paragraph, Bookmarks типа Bookmark, Characters типа Character И Т. Д.

Манипуляция документами, абзацами, символами, закладками реально осу ществляется путем обращения к свойствам и методам этих объектов.

Рассмотрим основные методы работы с объектом Microsoft Word, которые будут использоваться практически во всех примерах (листинг 4.20).

! Листинг 4.20. Основные методы работы с Microsoft Wor i _„ „„ ".

// Создание объекта MS Word Word = Новый СОМОбъект("Word.Application");

// Установка видимости приложения Word.Visible = Истина;

// Добавление нового документа в приложение Word.Documents.Add();

// Получение активного документа Документ = Word.ActiveDocument ();

// Добавить параграф Документ.Paragraphs.Add();

Использование OLE Automation I/ Добавить текст Документ.Paragraphs(НомерПараграфа).Range().InsertAfter(Текст);

// Стилевое оформление Документ.Paragraphs(НомерПараграфа).Range().Style="Зaгoлoвoк 2";

// Открытие существующего документа Word.Documents.Open(ИмяФайла);

// Сохранение документа Документ.Save();

Документ.SaveAs(ИмяФайла);

// Закрытие документа Документ.Close();

// Закрытие приложения Word.Quit();

Создание и открытие документов MS Word Для создания примеров использования Microsoft Word можно применять код создания контроллера, приведенный в листинге 4.20. Начнем сразу с создания и открытия документов.

Создать новый документ Word можно, используя метод Add коллекции Documents объекта Application — Word. Documents.Add (). Для создания ДО кумента с помощью шаблона нужно указать путь к шаблону в качестве па раметра метода Add: Word.Documents.Add("С:\Templates\NewStyle.dot").

Для открытия уже существующего документа следует воспользоваться мето дом Open коллекции Documents: W o r d. Documents. Open ("С: \MyWordFile.doc").

Отметим, что свойство ActiveDocument объекта Word.Application указывает на текущий активный документ среди одного или нескольких открытых.

Помимо этого к документу можно обращаться по его порядковому номеру с помощью метода item;

например, ко второму открытому документу можно обратиться так: word.Documents.item(2). Необходимо отметить, что нуме рация членов коллекций в Microsoft Office начинается с единицы.

Сделать документ активным можно с помощью метода Activate:

Word.Documents.Item(1).Activate().

Следующее, чему следует научиться, — это сохранять документ Word и за крывать сам Word.

Сохранение, печать и закрытие документов Закрытие документа может быть осуществлено с помощью метода close:

Word.Documents.Itern(2).Close () ИЛИ Word.ActiveDocument.Close ( ).

148 Глава Метод close имеет несколько необязательных параметров, влияющих на правила сохранения документа. Первый из них влияет на то, сохраняются ли внесенные в документ изменения, и может принимать три значения:

П о — не сохранять изменения;

О -1 — сохранять изменения;

О -2 — вывести диалоговое окно с соответствующим вопросом.

Второй параметр влияет на формат сохраняемого документа:

П о — сохранить в формате Word;

О 1 — сохранить в исходном формате документа;

О 2 — вывести диалоговое окно Сохранить как.

Третий параметр принимает значения истина или ложь и влияет на то, пере сылать ли документ следующему пользователю по электронной почте. Если эта функция не используется, этот параметр можно проигнорировать.

Таким образом, при использовании указанных выше параметров закрыть документ МОЖНО, например, так— Word. ActiveDocument. Close (4294967295, 2 ).

Просто сохранить документ, не закрывая его, можно с помощью метода Save — Word.ActiveDocument.Save().

Этот метод также имеет несколько необязательных (в случае позднего свя зывания) параметров, первый из которых равен истина, если документ со храняется автоматически, и ложь, если нужно выводить диалоговое окно для получения подтверждения пользователя о сохранении изменений (если та ковые были сделаны). Второй параметр влияет на формат сохраняемого до кумента, и список его возможных значений совпадает со списком значений второго параметра метода close.

Закрыть приложение Microsoft Word можно с помощью метода Quit объекта word.Application. Этот метод, в общем случае, имеет параметры, совпа дающие с параметрами метода close объекта Document.

Вывод документа на устройство печати можно осуществить с помощью ме тода Printout объекта Document, например: Word.ActiveDocument. Printout ( ).

Если нужно изменить параметры печати, следует указать значения соответ ствующих параметров метода Printout.

Е^ Примечание Для Microsoft Word их около двадцати параметров печати. Описание их можно найти на сайте Microsoft.

Использование OLE Automation Вставка текста и объектов в документ и форматирование текста Для создания абзацев в документе можно использовать коллекцию Paragraphs объекта Document, представляющую набор абзацев данного до кумента. Добавить новый абзац можно с помощью метода Add этой коллек ции: Word.ActiveDocument.Paragraphs.Add().

Для вставки собственно текста в документ, тем не менее, применяется не объ ект Paragraph, а объект Range, представляющий любую непрерывную часть документа (в том числе и вновь созданный абзац). Этот объект может быть создан разными способами. Например, можно указать начальный и конечный символы диапазона (если таковые имеются в документе), указать номер абза ца, или указать несколько абзацев, следующих подряд (листинг 4.21).

// 1-й способ (указать начальный и конечный символы диапазона) Rng = Word.ActiveDocument.Range(2,4);

//со 2-го по 4-й символы // 2-й способ (указать номер абзаца, например, только что созданного):

Rng = Word.ActiveDocument.Paragraphs.Item(l).Range;

// 3-й способ (указать несколько абзацев, следующих подряд) Rng = Word.ActiveDocument.Range( Word.ActiveDocument.Paragraphs.Item(3).

Range.Start, Word.ActiveDocument.Paragraphs.Item(5).Range.End);

// Вставка текста Rng.InsertAfter("Это вставляемый текст");

Вставить текст можно с помощью методов insertsef ore (перед диапазоном) или insertAfter (после диапазона) объекта Range.

Помимо объекта Range текст можно вставлять с помощью Selection, яв ляющимся свойством объекта w o r d. A p p l i c a t i o n и представляющим собой выделенную часть документа (этот объект создается, если пользователь выделяет часть документа с помощью мыши, и может быть также создан с помощью приложения-контроллера). Сам объект selection можно соз дать, применив метод Select к объекту Range, например — Word.ActiveDocument.Paragraphs.Item(3).Range.Select(). В данном при мере в текущем документе выделяется третий абзац.

Если необходимо вставить строку текста в документ вместо выделенного фрагмента текста, либо перед ним, это можно сделать с помощью фрагмента кода, который приведен в листинге 4.22.

150 Глава........--.-—,,-_-,•-!-....g-.-------—_,-—-,--- — ': ~---- v — эмена выделенного текста // Признак замены выделенного фрагмента при вставке текста Арр.Options.ReplaceSelection = Истина;

// Получить выделенный фрагмент Sel = Арр.Selection;

// Вставить текст Sel.TypeText("Это текст, которым мы заменим выделенный фрагмент");

// Конец абзаца Sel.TypeParagraph();

Отметим, что если свойство Options.ReplaceSelection объекта word.Application имеет значение истина, выделенный текст будет заменен на новый (этот режим действует по умолчанию). Если же нужно, чтобы текст был вставлен перед выделенным фрагментом, а не вместо него, следу ет установить значение этого свойства равным ложь.

Символ конца абзаца при использовании объекта selection может быть вставлен С ПОМОЩЬЮ метода TypeParagraph.

К объекту Selection, так же как и к объекту Range, можно применить мето ды insertBefore и insertAfter. В этом случае, в отличие от предыдущего, вставляемый текст станет частью выделенного фрагмента текста.

С помощью объекта selection, используя его свойство Font, а также и свойства объекта Font (Bold, italic, size и т. п.), можно отформатировать текст. Например, таким образом можно вставить строку, выделенную жир ным шрифтом (листинг 4.23).

| Листинг 4.23. Форматирование текста // Установка полужирного шрифта Sel.Font.Bold = Истина;

Sel.TypeText("Это текст, который мы выделим жирным шрифтом."

// Отмена полужирного шрифта Sel.Font.Bold = Ложь;

// Признак конца параграфа Sel.TypeParagraph();

// Установка стиля текста Sel.Style = "Заголовок 1";

Sel.TypeText("Это текст, который станет заголовком");

Sel.TypeParagraph();

Использование OLE Automation Для наложения на вставляемый текст определенного заранее стиля можно использовать свойство style этого же объекта (листинг 4.24).

Нередко документы Word содержат данные других приложений.

Простейший способ вставить такие данные в документ — использование метода Paste объекта Range. Естественно, в этом случае в буфере обмена уже должны содержаться вставляемые данные. Если нужно поместить в бу фер обмена часть документа Word, это можно сделать с помощью метода Сору объекта Range. Пример копирования и вставки данных приведен в лис тинге 4.24.

// Копирование данных Rng = Word.Selection.Range;

Rng.Copy();

// Вставка данных Rng = Word.Selection.Range;

Rng.Collapse(0);

Rng. Paste () ;

Параметр метода Collapse указывает на то, где, в начале или в конце ис ходного фрагмента, окажется новый объект Range или selection:

П 1 — новый объект находится в начале фрагмента;

П о — новый объект находится в конце фрагмента.

Перемещение курсора по тексту Перемещать курсор по тексту можно с помощью метода Move объектов Range и Selection. Этот метод имеет два параметра. Первый указывает на то, в каких единицах измеряется перемещение — в символах (по умолча нию) или словах, предложениях, абзацах и др. Второй параметр указывает, на сколько единиц при этом нужно переместиться (это число может быть и отрицательным;

по умолчанию оно равно i). Примеры таких перемещений курсора приведены в листинге 4.25.

j Листинг 4.25. Перемещение курсора по тексту // Перемещение курсора на один символ вперед Rng.Move();

// Перемещение курсора на три абзаца вперед Rng.Move (4,3) ;

152 Глава I/ Перемещение курсора на одно слово вперед Rng.Move(2);

// Перемещение курсора на десять слов назад Rng.Move(2, -10);

Второй параметр метода Move может принимать следующие значения:

О 1 — символ;

П 2 — слово;

П з — предложение;

П 4 — абзац;

П б — часть документа (например, колонтитул, оглавление и др.);

П 8 — раздел;

П 9 — колонка таблицы;

П ю — строка таблицы;

П 12 — ячейка таблицы;

П 15 — таблица.

Нередко для перемещения по тексту используются закладки. Создать за кладку в текущей позиции курсора можно путем добавления члена коллек ции Bookmarks объекта Document с помощью метода Add. При этом надо ука зать имя закладки в качестве его параметра.

Проверить существование закладки в документе можно с помощью метода Exists, а переместиться на нее — с помощью метода Goto объектов Document, Range или selection. Пример работы с закладками приведен в листинге 4.26.

// Добавить новую закладку Word.ActiveDocument.Bookmarks.Add("MyBookmark");

// Переместить курсор на закладку Rng = Word.ActiveDocument.Goto(-1, 2, ',"MyBookmark");

// Вставить текст после закладки Rng.InsertAfter("Текст, вставленный после закладки");

В методе Goto данного примера первый параметр указывает на необходи мость перейти к указанной закладке. Второй — определяет, что нужно ис кать следующий объект в тексте.

Использование OLE Automation Отметим, что с помощью метода Goto можно перемещаться не только на указанную закладку, но и на другие объекты (рисунки, грамматические ошибки и др.). Направление перемещения тоже может быть различным. По этому список констант, которые могут быть использованы в качестве пара метров данного метода, довольно велик.

Создание таблиц Создавать таблицы можно двумя способами. Первый заключается в вызове метода Add коллекции Tables объекта Document и последовательном запол нении ячеек данными. Этот способ при позднем связывании работает до вольно медленно.

Второй способ — более "быстрый". Сущность его заключается в создании текста из нескольких строк, содержащих подстроки с разделителями и по следующей конвертации такого текста в таблицу с помощью метода ConvertToTable объекта Range.

[^ Примечание В качестве разделителя можно использовать любой или почти любой символ.

Нужно только, чтобы он заведомо не встречался в данных, которые будут по мещены в будущую таблицу.

В листинге 4.27 приведен пример создания этим способом таблицы, со стоящей из трех строк и трех столбцов (в качестве разделителя, являющего ся первым параметром метода ConvertToTable, используется запятая).

• 4.27. Создание таблицы Rng = Word.Selection.Range;

Rng.Collapse(0);

Rng.InsertAfter("l, 2, 3 " ) ;

Rng.InsertParagraphAfter();

Rng.InsertAfter("4,5, 6") ;

Rng.InsertParagraphAfter();

Rng.InsertAfter("7,8,9");

Rng.InsertParagraphAfter();

Rng.ConvertToTable(",");

Отметим, что внешний вид таблицы можно изменить с помощью свойства Format, а также с помощью свойств коллекции columns, представляющей колонки таблицы, и коллекции ROWS, представляющей строки таблицы объ екта Table.

154 Глава.

Обращение к свойствам документа Свойства документа можно получить с помощью коллекции BuiltlnDocumentProperties объекта Document, пример работы С которой приведен в листинге 4.28.

// Получаем коллекцию BuiltlnDocumentProperties Prop = Word.ActiveDocument.BuiltlnDocumentProperties;

// Выводим некоторые свойства Сообщить("Название: " + Prop[I].Value);

Сообщить("Автор: " + Prop[3].Value);

Сообщить("Шаблон: " + Prop[6].Value);

Ниже перечислены все возможные индексы коллекции BuiltlnDocumentProperties:

П 1— название;

П 2 — назначение;

П з — автор;

П 4 — ключевые слова;

О 5 — комментарии;

О б — шаблон;

П 7 — автор, редактировавший текст последним;

П 8 — версия;

П 9 — имя приложения;

П ю — когда последний раз документ был выведен на устройство печати;

П и — время создания;

П 12 — время, когда документ был сохранен в последний раз П 13 — суммарное время редактирования;

О 14 — число страниц;

О 15 — число слов;

П 16 — число символов;

П 17 — правила доступа к документу;

П 18 — категория;

П 19 — формат документа;

Использование OLE Automation П 20 — менеджер;

П 21 — компания;

П 22 — число байт;

П 23 — число строк;

П 24 — число абзацев;

П1 25 — число слайдов;

П 26 — число комментариев;

П 27 — число скрытых слайдов;

П 28 — число мультимедиаклипов;

П 29 — путь к гипертекстовым ссылкам;

П зо — число символов без учета пробелов.

Итак, сейчас были рассмотрены основные операции, которые наиболее час то применяются при автоматизации Microsoft Word. В дальнейшем будут рассмотрены примеры практического применения Microsoft Word в качестве OLE-сервера.

Выгрузка метаданных в MS Word С помощью объекта word.Application, предоставляемого OLE-сервером MS Word, можно программно создавать текстовые документы, включающие в себя форматирование текстов, таблицы, рисунки и другие объекты, дос тупные пользователям данного редактора.

Приведем пример формирования отчета о конфигурации, который будет сформирован в MS Word (листинг 4.29).

инг 4.29. Выгрузка метаданных в MS Word для версии 8. Попытка Word = Новый СОМОбъект("Word.Application");

Исключение Сообщить("Не удалось открыть Word");

Возврат;

КонецПопытки;

Сообщить("Ждите... Это может занять продолжительное время...");

// Добавим новый документ Word.Documents.Add();

Документ = Word.ActiveDocument();

156 Глава /I Определяем все возможные объекты метаданных ВсеТипы = Новый Структура();

ВсеТипы.Вставить("ОбщиеМодули", "Общие модули");

ВсеТипы.Вставить("ОбщиеФормы", "Общие формы");

ВсеТипы.Вставить("ОбщиеМакеты", "Общие макеты");

ВсеТипы.Вставить("ОбшиеКартинки", "Общие картинки");

ВсеТипы.Вставить("Роли", "Роли");

ВсеТипы.Вставить("Интерфейсы", "Интерфейсы");

ВсеТипы.Вставить("Стили", "Стили");

ВсеТипы.Вставить("Языки", "Языки");

ВсеТипы.Вставить("ПланыОбмена", "Планы обмена");

ВсеТипы.Вставить("Константы", "Константы");

ВсеТипы.Вставить("КритерииОтбора", "Критерии отбора");

ВсеТипы.Вставить("Справочники", "Справочники");

ВсеТипы.Вставить("Документы", "Документы");

ВсеТипы.Вставить("ЖурналыДокументов", "Журналы документов");

ВсеТипы.Вставить("Перечисления", "Перечисления");

ВсеТипы.Вставить("Отчеты", "Отчеты");

ВсеТипы.Вставить("Обработки", "Обработки");

ВсеТипы.Вставить("ПланыВидовХарактеристик", "Планы видов характеристик");

ВсеТипы.Вставить("ПланыСчетов", "Планы счетов");

ВсеТипы.Вставить("ПланыВидовРасчета", "Планы видов расчета");

ВсеТипы.Вставить("РегистрыСведений", "Регистры сведений");

ВсеТипы.Вставить("РегистрыБухгалтерии", "Регистры бухгалтерии");

ВсеТипы.Вставить("РегистрыРасчета", "Регистры расчета");

// Определяем все возможные параметры ВсеПараметры = Новый Структура();

ВсеПараметры.Вставить("Измерения", "Измерения");

ВсеПараметры.Вставить("Ресурсы", "Ресурсы");

ВсеПараметры.Вставить("Реквизиты", "Реквизиты");

ВсеПараметры.Вставить("Формы", "Формы");

ВсеПараметры.Вставить("Макеты", "Макеты");

ВсеПараметры.Вставить("Графы", "Графы");

ВсеПараметры.Вставить("ТабличныеЧасти", "Табличные части");

ВсеПараметры.Вставить("Значения", "Значения");

// Перебор типов метаданных Использование OLE Automation Для Каждого ТипОбъекта Из ВсеТипы Цикл Состояние(ТипОбъекта.Значение);

Если Метаданные[ТипОбъекта.Ключ].Количество() > 0 Тогда // Добавляем новый параграф Документ.Paragraphs.Add();

Номер = Документ.Paragraphs.Count();

Документ.Paragraphs(Номер-1}.Range(). InsertAfter( ТипОбъекта.Значение);

Документ.Paragraphs(Номер).Range().Style="3aгoлoвoк 1";

// Перебираем конкретные объекты Для каждого Объект Из Метаданные[ТипОбъекта.Ключ] Цикл // Добавляем новый параграф Документ.Paragraphs.Add();

Номер = Документ.Paragraphs.Count() ;

Документ.Paragraphs(Номер-1).Range().InsertAfter(Объект.Синоним);

Документ.Paragraphs(Номер).Range().Style="Зaгoлoвoк 2";

// Перебираем параметры метаданных Для каждого Параметр Из ВсеПараметры Цикл Попытка Количество = Объект[Параметр.Ключ].Количество();

Исключение Продолжить;

КонецПопытки;

Если Количество > 0 Тогда // Добавляем новый параграф Документ.Paragraphs.Add();

Номер = Документ.Paragraphs.Count();

Документ.Paragraphs(Номер-1).Range().InsertAfter (Параметр.Значение + " ( + Количество + " " ;

" )) Документ.Paragraphs(Номер).Range().Style="3aгoлoвoк 3";

// Добавляем новый параграф Документ.Paragraphs.Add();

Номер=Документ.Paragraphs.Count();

// Добавляем новую таблицу 158 Глава Документ.Tables.Add(Документ. Paragraphs(Номер).Range О, Количество+1,4);

Счетчик = 1;

// Заполняем шапку таблицы Таблица = Документ.Tables(Документ.Tables.Count());

Таблица.Cell(Счетчик,1).Ranged.InsertAfter("Имя");

Pages:     | 1 || 3 | 4 |   ...   | 5 |



© 2011 www.dissers.ru - «Бесплатная электронная библиотека»

Материалы этого сайта размещены для ознакомления, все права принадлежат их авторам.
Если Вы не согласны с тем, что Ваш материал размещён на этом сайте, пожалуйста, напишите нам, мы в течении 1-2 рабочих дней удалим его.